Trouble with vanguard.com Login

Started by brcs55,

brcs55brcs55
edited 26 Apr 2013 in Windows #1

I am having an issue logging into Vanguard's two step process. It works under ie10, but the 2nd screen input is not working under chrome. The password is correct as I can type in exactly what it says manually. Any ideas on what to look for? I am using Windows 7.

  • khadkhad Social Choreographer Administrator
    edited 26 Apr 2013 #2

    I'm sorry that you are having some trouble. It is working well in my testing with my own Vanguard Login item. Please try saving a new Login manually like this:

    1. Visit the site's login page: https://investor.vanguard.com/home
    2. Enter your credentials, but DO NOT submit the form.
    3. Click the 1Password button in your browser's toolbar, and select the "+" button in the upper right hand corner.
    4. Add your password to the item before saving it.
    5. Step 4 is important, so I'll repeat it here. Add your password to the item before saving it.
    6. Change the title and make any notes (if desired).
    7. Click the Save button in the upper right hand corner.

    Using the above technique I was able to save and fill a sample login at:

    https://investor.vanguard.com/home

    Manually saving a new Login can be useful for logins that are either problematic to begin with or were once working but have since stopped. Saving a new Login item allows 1Password to refresh everything it "knows" about the page. Login pages often change as websites are updated and this can be a necessary but very useful tip. :)

    Then you can use that same Login item to fill both pages of the login process.

    I hope that helps. Please let me know.

  • Thanks for the response. I tried this tonight and still cannot get by the 2nd screen in Chrome. I then deleted all the various Vanguard logins and started again with your instructions, but still get the same result. Now it also no longer works in IE10. I get an error that says IE is denying access to a frame because it is on some other domain.

  • khadkhad Social Choreographer Administrator
    edited 3 May 2013 #4

    I get an error that says IE is denying access to a frame because it is on some other domain.

    This is not anything 1Password has any control over. The message that you are seeing is specific to Internet Explorer. IE is preventing something called "cross-domain scripting".

    When the login <form> is inside some <frame> and this <frame> is hosted on some other domain (other than the current domain), then IE does not allow scripting access to that <frame> (and that's why 1Password cannot touch it).

    Whenever this happens, our advice is to use Auto-Type or the 1Password extension in a different web browser such as Chrome, Firefox, or Safari.

    Are you pressing CTRL+\ (or selecting the Login item from the 1Password extension popup) on the second page to fill your password there? You need to tell it to fill on the second page too. Does that help?

  • macmanmacman Junior Member

    For me, I can use 1Password to fill in and submit my Username. But on the next screen, having 1Password on my Mac with Firefox, autofilling the Password does not work.

  • khadkhad Social Choreographer Administrator

    @macman, did you carefully follow my instructions above to create a new Login item including manually adding your password to it? It works very well for me and has for a long time. I'm sure we can get it working well for you too. :)

  • I've also been having problems with Vanguard on the password page. Followed instructions to create new item, but only works if autosubmit is turned off. Had to do this with Bank of America's site as well. Autosubmit used to work all the time for me but now it seems with banks, credit cards and now Vanguard, it doesn't. 1P still does the job, but requires many more clicks now. Are financial institutions now incorporating "features" that defeat auto submit? Any suggestions on how to get it operational again? Is AgileBits working on this? Thx.

  • khadkhad Social Choreographer Administrator

    What specific browser version and version of the 1Password extension? Is it the same for you in more than one browser? Autosubmit is working quite well in all my testing on vanguard.com and bankofamerica.com. I have accounts on both sites myself.

  • I started this discussion and have checked back occasionally. I had to turn off the auto submit which creates a lot of extra clicks as ThomasP mentioned. I am using Chrome. 1 PW version shows 1.0.9.327. In ie10 I cannot even get into Vanguard as I receive a frame error using 1PW

  • MikeTMikeT Agile Samurai Administrator

    Hi @brcs55 and @ThomasP,

    There are many financial institutions adding extra features on their sites to prevent automated tools (a thin line between criminal tools and legitimate tools like 1Password) from brute-forcing to get into customer's accounts. They are trying everything they can to protect their customers.

    We are always working on improving our auto-submit processes but for some sites, they won't allow it and we cannot force it.

    We'll look into those sites again and figure out why it's not working for you guys while it does for Khad.