Manual backups failing [Resolved by restarting 1Password mini]

Started by Sven Lohmann,

edited 4 Nov 2013 in Mac Beta #1

Downloaded the beta, installed the browser extension, run preferences, clicked on backup now (Sicherung) - received notification "Backup failed", in german "Sicherung fehlgeschlagen"

04.09.13 21:42:21,763 2BUA8C4S2C.com.agilebits.onepassword4-helper[2642]: 400175 [XPC:0x7fc8b699e8c0:] E performBackupAndShowToUser: | Failed to create backup: Error Domain=com.agilebits.onepassword.ErrorDomain Code=1206 "Unable to backup database because a backup or restore is already in progress." UserInfo=0x7fc8b69a60b0 {NSLocalizedDescription=Unable to backup database because a backup or restore is already in progress.}

No, there is no backup in progress.

  • edited 17 Sep 2013 #2

    Ok im going to BUMP this thread, because since the latest b84 backups keep failing, but NOTE : THIS ISNT FOR MANUAL BACKUP, its the automatic backup, I have backup once a day, but as its not doing one, it keeps trying.

    ??

  • MikeTMikeT Agile Samurai Administrator

    Hi guys,

    I'm sorry about the backlog, we're still going through them as fast as we can.

    Can you guys open the main 1Password app, go to the 1Password Menu > Preferences > Backups and check if there were any Backups created (that was not done manually by you) or did they all failed?

    I'm wondering if the backups are still being created and these errors are the result of a race condition in the code.

    Also, the next time you get the Backup Failed message, please open the main 1Password app, go to Help Menu > Troubleshooting > Show 1Password mini Log and copy the last 30 lines of code for me to paste here.

    Thanks!

  • faisal400faisal400 Junior Member

    having same problem in the official release

    Fri Oct 4 00:22:53 2013| 400200 [APP:0x7faf6840d830:] I applicationDidFinishLaunching: | Starting 1Password 4.0 #400200 built Sep 25 2013 22:21:41 Fri Oct 4 00:22:53 2013| 400200 [XPC:0x7faf6840d830:] I connect | Connecting to helper Fri Oct 4 00:22:53 2013| 400200 [XPC:0x7faf6840d830:] I startHelper | Starting '2BUA8C4S2C.com.agilebits.onepassword-osx-helper' Fri Oct 4 00:22:57 2013| 400200 [UI:0x7faf6b008c70:] I saveState:andReloadDataWithCompletion: | Selected 825 items: 0.11 Fri Oct 4 00:24:09 2013| 400200 [UI:0x7faf6840d830:] I saveItemChangesWithCompletion: | Saving item F84275360CA2441CB002E02FA4EC442C Fri Oct 4 00:24:09 2013| 400200 [UI:0x7faf70c28d80:] I saveState:andReloadDataWithCompletion: | Selected 826 items: 0.10 Fri Oct 4 00:24:14 2013Good-bye!

    Fri Oct 4 00:29:17 2013| 400200 [APP:0x7f9618c0d850:] I applicationDidFinishLaunching: | Starting 1Password 4.0 #400200 built Sep 25 2013 22:21:41 Fri Oct 4 00:29:17 2013| 400200 [XPC:0x7f9618c0d850:] I connect | Connecting to helper Fri Oct 4 00:29:17 2013| 400200 [XPC:0x7f9618c0d850:] I startHelper | Starting '2BUA8C4S2C.com.agilebits.onepassword-osx-helper' Fri Oct 4 00:29:21 2013| 400200 [UI:0x7f9621631a30:] I saveState:andReloadDataWithCompletion: | Selected 826 items: 0.10 Fri Oct 4 00:37:39 2013| 400200 [UI:0x7f9621da7e60:] I saveState:andReloadDataWithCompletion: | Selected 826 items: 0.10 Fri Oct 4 00:46:09 2013Good-bye!

    Fri Oct 4 00:46:51 2013| 400200 [APP:0x7ff45040d830:] I applicationDidFinishLaunching: | Starting 1Password 4.0 #400200 built Sep 25 2013 22:21:41 Fri Oct 4 00:46:51 2013| 400200 [XPC:0x7ff45040d830:] I connect | Connecting to helper Fri Oct 4 00:46:51 2013| 400200 [XPC:0x7ff45040d830:] I startHelper | Starting '2BUA8C4S2C.com.agilebits.onepassword-osx-helper' Fri Oct 4 00:46:54 2013| 400200 [UI:0x7ff458320120:] I saveState:andReloadDataWithCompletion: | Selected 826 items: 0.10 Fri Oct 4 00:48:37 2013| 400200 [UI:0x7ff458d50ce0:] I saveState:andReloadDataWithCompletion: | Selected 826 items: 0.10 Fri Oct 4 00:49:15 2013| 400200 [UI:0x7ff4584a9df0:] I saveState:andReloadDataWithCompletion: | Selected 826 items: 0.09 Fri Oct 4 00:49:21 2013| 400200 [UI:0x7ff458c9df90:] I saveState:andReloadDataWithCompletion: | Selected 825 items: 0.10 Fri Oct 4 00:51:12 2013| 400200 [APP:0x7ff45821fc10:] I troubleshootingRestartHelper: | Restarting 1Password mini... Fri Oct 4 00:51:13 2013| 400200 [APP:0x7ff45821fc10:] I troubleshootingRestartHelper: | Restarting 1Password mini... Fri Oct 4 00:51:14 2013| 400200 [APP:0x7ff45821fc10:] I troubleshootingRestartHelper: | 1Password mini restarted.

  • faisal400faisal400 Junior Member

    thanks its working now even though i did not do any thing

  • I think the problem was because backup process of the old 1Password program was working. LOG shows: Fri Oct 4 18:03:59 2013| 401005 [XPC:0x7fb20b57c8c0:] E performBackupAndShowToUser: | Failed to create backup: Error Domain=com.agilebits.onepassword.ErrorDomain Code=1206 "Unable to backup database because a backup or restore is already in progress." UserInfo=0x7fb20b5a5e40 {NSLocalizedDescription=Unable to backup database because a backup or restore is already in progress.}

    I have restarted OS and backups of new program data now are OK (before it old app must be removed)

  • My 1Password's backup automatic is not working either: what should I do???

    0x7ff95102ddc0>] I saveState:andReloadDataWithCompletion: | Selected 6 items: 0.01 Sat Oct 5 11:15:18 2013Good-bye!

    Sat Oct 5 11:27:21 2013| 400200 [APP:0x7fccd8c0f050:] I applicationDidFinishLaunching: | Starting 1Password 4.0 #400200 built Sep 25 2013 22:21:41 Sat Oct 5 11:27:21 2013| 400200 [XPC:0x7fccd8c0f050:] I connect | Connecting to helper Sat Oct 5 11:27:21 2013| 400200 [XPC:0x7fccd8c0f050:] I startHelper | Starting '2BUA8C4S2C.com.agilebits.onepassword-osx-helper' Sat Oct 5 11:27:22 2013| 400200 [UI:0x7fccd981af40:] I saveState:andReloadDataWithCompletion: | Selected 6 items: 0.01 Sat Oct 5 11:28:39 2013Good-bye!

    Sat Oct 5 11:36:08 2013| 400200 [APP:0x7f8cc3c0f050:] I applicationDidFinishLaunching: | Starting 1Password 4.0 #400200 built Sep 25 2013 22:21:41 Sat Oct 5 11:36:08 2013| 400200 [XPC:0x7f8cc3c0f050:] I connect | Connecting to helper Sat Oct 5 11:36:08 2013| 400200 [XPC:0x7f8cc3c0f050:] I startHelper | Starting '2BUA8C4S2C.com.agilebits.onepassword-osx-helper' Sat Oct 5 11:36:10 2013| 400200 [UI:0x7f8cc4872580:] I saveState:andReloadDataWithCompletion: | Selected 6 items: 0.01

  • I'm having the same issues - both Automatic and Manual backups fail in 1Password 4 ever since I installed v4 from the MAS. I previously had v3.x from the MAS installed. Any ideas how to fix this?

  • I am a new user. Installed 4.0.1 today. Having same issue. Backup are erroring out. There is no "com.agilebits.... " directory under /Users/myusername/Library/Containers/

  • I am also having failed backups both automatic and manual. Appreciate any and all help.

    Fri Oct 4 18:15:33 2013| 400200 [ER_SUBSYSTEM:0x7fcb4140d7e0:OPAddressFormat] W countryCodes | No localized country name for mf Fri Oct 4 18:15:33 2013| 400200 [ER_SUBSYSTEM:0x7fcb4140d7e0:OPAddressFormat] W countryCodes | No localized country name for bl Fri Oct 4 18:15:33 2013| 400200 [ER_SUBSYSTEM:0x7fcb4140d7e0:OPAddressFormat] W countryCodes | No localized country name for ps Fri Oct 4 18:16:42 2013| 400200 [UI:0x7fcb4140d7e0:] I saveItemChangesWithCompletion: | Saving item 84A49275596C45E0B5128BCCFC7E369B Fri Oct 4 18:16:43 2013| 400200 [UI:0x7fcb420f8020:] I saveState:andReloadDataWithCompletion: | Selected 241 items: 0.07 Fri Oct 4 18:52:56 2013| 400200 [UI:0x7fcb44523550:] I saveState:andReloadDataWithCompletion: | Selected 241 items: 0.08 Sat Oct 5 09:51:13 2013| 400200 [UI:0x7fcb46c29320:] I saveState:andReloadDataWithCompletion: | Selected 241 items: 0.09 Sat Oct 5 10:16:52 2013| 400200 [UI:0x7fcb46c37e80:] I saveState:andReloadDataWithCompletion: | Selected 242 items: 0.08 Sat Oct 5 10:17:36 2013| 400200 [UI:0x7fcb4140d7e0:] I saveItemChangesWithCompletion: | Saving item 78EFC3608F6948CEB735896E78E0DA57 Sat Oct 5 10:17:36 2013| 400200 [UI:0x7fcb46e1fb40:] I saveState:andReloadDataWithCompletion: | Selected 242 items: 0.07 Sat Oct 5 10:18:37 2013Good-bye!

    Sat Oct 5 11:16:28 2013| 400200 [APP:0x7fcb63c0d7e0:] I applicationDidFinishLaunching: | Starting 1Password 4.0 #400200 built Sep 25 2013 22:21:41 Sat Oct 5 11:16:28 2013| 400200 [XPC:0x7fcb63c0d7e0:] I connect | Connecting to helper Sat Oct 5 11:16:28 2013| 400200 [XPC:0x7fcb63c0d7e0:] I startHelper | Starting '2BUA8C4S2C.com.agilebits.onepassword-osx-helper' Sat Oct 5 11:16:32 2013| 400200 [UI:0x7fcb658516b0:] I saveState:andReloadDataWithCompletion: | Selected 243 items: 0.05 Sat Oct 5 13:49:46 2013| 400200 [UI:0x7fcb67613810:] I saveState:andReloadDataWithCompletion: | Selected 243 items: 0.10

  • Having same issue with user "ugniusb".

    Failed to create backup: Error Domain=com.agilebits.onepassword.ErrorDomain Code=1206 "Unable to backup database because a backup or restore is already in progress." UserInfo=0x7fb20b5a5e40 {NSLocalizedDescription=Unable to backup database because a backup or restore is already in progress.}

  • I newly installed the latest version from the Mac App store yesterday and I am having the same backup issues, both manual and automatic. There are no backup files saved at present. From the log:

    Sat Oct 5 23:49:19 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | Starting 1Password 4.0 #400200 built Sep 25 2013 22:21:41 Sat Oct 5 23:49:19 2013| 400200 [XPC:0x7fd6f240d780:] I connect | Connecting to helper Sat Oct 5 23:49:19 2013| 400200 [XPC:0x7fd6f240d780:] I startHelper | Starting '2BUA8C4S2C.com.agilebits.onepassword-osx-helper' Sat Oct 5 23:49:27 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | XPC connection is not yet available, retrying 4/25 in 1 sec... Sat Oct 5 23:49:28 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | XPC connection is not yet available, retrying 5/25 in 1 sec... Sat Oct 5 23:49:29 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | XPC connection is not yet available, retrying 6/25 in 1 sec... Sat Oct 5 23:49:30 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | XPC connection is not yet available, retrying 7/25 in 1 sec... Sat Oct 5 23:49:31 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | XPC connection is not yet available, retrying 8/25 in 1 sec... Sat Oct 5 23:49:32 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | XPC connection is not yet available, retrying 9/25 in 1 sec... Sat Oct 5 23:49:33 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | XPC connection is not yet available, retrying 10/25 in 1 sec... Sat Oct 5 23:49:34 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | XPC connection is not yet available, retrying 11/25 in 1 sec... Sat Oct 5 23:49:35 2013| 400200 [APP:0x7fd6f240d780:] I applicationDidFinishLaunching: | XPC connection is not yet available, retrying 12/25 in 1 sec... Sat Oct 5 23:49:40 2013| 400200 [UI:0x7fd6f240d780:] E updateWelcomeMessage | No keychains available to continue setup. Most probably the Helper is not available. Sat Oct 5 23:50:50 2013| 400200 [APP:0x7fd6f240d780:] I setupController:completedSetupWithPassword:hint:ubiquityEnabled: | Creating new profile 'default'. Sat Oct 5 23:50:50 2013| 400200 [XPC:0x7fd6f240d780:] I createProfile:ubiquityEnabled:completion: | Creating new profile Sat Oct 5 23:50:50 2013| 400200 [APP:0x7fd6f240d780:] I setupController:completedSetupWithPassword:hint:ubiquityEnabled: | Created profile 'default' Sat Oct 5 23:52:46 2013| 400200 [APP:0x7feb2840e070:] I applicationDidFinishLaunching: | Starting 1Password 4.0 #400200 built Sep 25 2013 22:21:41 Sat Oct 5 23:52:46 2013| 400200 [XPC:0x7feb2840e070:] I connect | Connecting to helper Sat Oct 5 23:52:46 2013| 400200 [XPC:0x7feb2840e070:] I startHelper | Starting '2BUA8C4S2C.com.agilebits.onepassword-osx-helper' Sat Oct 5 23:52:47 2013| 400200 [UI:0x7feb2918acc0:] I saveState:andReloadDataWithCompletion: | Selected 0 items: 0.00 Sat Oct 5 23:52:47 2013| 400200 [APP:0x7feb2840e070:] I crashReportApplicationLog | Crash detected; collecting application logs. Sat Oct 5 23:53:40 2013Good-bye!

    Sun Oct 6 13:01:38 2013| 400200 [APP:0x7f88f940d780:] I applicationDidFinishLaunching: | Starting 1Password 4.0 #400200 built Sep 25 2013 22:21:41 Sun Oct 6 13:01:38 2013| 400200 [XPC:0x7f88f940d780:] I connect | Connecting to helper Sun Oct 6 13:01:38 2013| 400200 [XPC:0x7f88f940d780:] I startHelper | Starting '2BUA8C4S2C.com.agilebits.onepassword-osx-helper' Sun Oct 6 13:01:40 2013| 400200 [UI:0x7f88fa2a5860:] I saveState:andReloadDataWithCompletion: | Selected 6 items: 0.01

  • jisjis
    edited 6 Oct 2013 #13

    I have bought the upgrade from 1password 3 to 1password 4. Everything is fine except the backup that results in an error (automatic and manual) :

    Sun Oct 6 20:54:55 2013| 401005 [XPC:0x7fe700754d80:] E performBackupAndShowToUser: | Failed to create backup: Error Domain=com.agilebits.onepassword.ErrorDomain Code=1206 "Unable to backup database because a backup or restore is already in progress." UserInfo=0x7fe70006e820 {NSLocalizedDescription=Unable to backup database because a backup or restore is already in progress.}

    edit : I have restarted 1password mini (from the help menu) and it solved the problem.

  • Thanks jis - I restarted 1password mini and I was immediately able to backup