Chase Bank (chase.com) autosubmit login issue

Started by DrGary,

I just wanted to know if there is a general thread already established for specific URL-related issues with the current 1PassWord beta running on 10.7/Safari 5.1?

It appears that the Chase banking website logon does not work correctly...as it did in 10.6....I just did not want to start a new thread if these issues are already being "rolled-up" in a different spot. Also, what other information do you need to troubleshoot a URL-related problem other than the specific URL involved.

Thanks...and keep up the good work!!

Dr Gary
  • khadkhad Social Choreographer Administrator
    Welcome to the forums, Gary! :-)

    Thanks for reporting an issue with the Chase banking website. Could you provide the exact URL you are using (if different from https://www.chase.com/). Also, are you having trouble with autosave, form filling, or autosubmit? The sample login I created fills fine. It looks like autosubmit may not work, but I don't actually have an account there to test it.

    Please try saving the login manually like this:

    1. Enter your username and password, but DO NOT submit the form.
    2. Click the 1Password button in your browser's toolbar, and choose Save Login.

    (Note that at this time, you won't have a chance to specify the name of the Login item when manually saving like this in the Safari 5.1 extension, so it will be saved with the domain name of the site.)

    Using the above technique I was able to save and fill a sample login in Safari 5.1 at:

    https://www.chase.com/

    Manually saving a login can be useful for logins that are either problematic to begin with or were once working but have since stopped. Doing this allows 1Password to refresh everything it "knows" about the page. Login pages often change as websites are updated and this can be a necessary but very useful tip. :-)

    If you are still having trouble, please take a look at our "Website Login Issues" guide:

    http://help.agilebits.com/1Password3/login_issues.html

    Note especially that editing the login to change the Submit value from "If Autosubmit is ON" to "Never" works on a lot of sites which modify the form before submitting it or are looking for a literal key press or mouse click. This will give you the chance to actually give them what they are looking for by submitting the form yourself rather than allowing 1Password to do it on your behalf.

    I hope that helps. Please let me know.

    Thanks!
  • edited 20 Jun 2011 #3
    Greetings...and thanks for the quick reply.

    I was using the URL: "https://chaseonline.chase.com/Logon.aspx"

    for access...but www.chase.com does not work any better. The UserID and Password fields appear to fill OK...but the auto-submit fails. Interestingly enough...even if I set Submit = Never...after having 1PassWord fill in the form...the submission is still performed...and fails....is this just a bug in Autosubmit in the beta?

    I tried you suggestion of creating a new 1Password entry for the www.chase.com URL but I get the same bad results.

    Thanks...

    DRGary
  • edited 21 Jun 2011 #4
    I still cannot get the Chase online banking website to auto-submit in the GA 3.6 release using Lion and the new extension.

    Any ideas?
  • barrybarry Junior Member
    Nor me. What seems to be happening is 1Password fills in both the username and password. Then the page refreshes leaving behind only the username. I tried setting submit to never for the item, but that didn't make any difference. 1Password still seems to be doing something in addition to just filling in the fields. I've attached the raw source from the login page.
    html
    html
    chase.html
    17K
  • edited 21 Jun 2011 #6
    Yes...that is exactly what I am seeing...1PassWord appears to perform the fill correctly...the form then gets submitted...(whether you have auto-submit on or not :D)...but then you just come back to the logon page...
  • barrybarry Junior Member
    DrGary wrote:

    Yes...that is exactly what I am seeing...1PassWord appears to perform the fill correctly...the form then gets submitted...(whether you have auto-submit on or not :D)...but then you just come back to the logon page...


    That page is filled with javascript. I'm sure that Chase is mucking with something.
  • khadkhad Social Choreographer Administrator
    edited 22 Jun 2011 #8
    even if I set Submit = Never...after having 1PassWord fill in the form...the submission is still performed...and fails....is this just a bug in Autosubmit in the beta?

    Interesting. Disabling autosubmit seems to work fine in Chrome which is *almost* using the exact same code, and it appears that Submit=Never works fine in Safari 5.1 on other sites where I tested it. However, I can confirm what you are seeing. I could not get 1Password's Safari 5.1 extension to honor the Submit value of "Never" for my sample Chase login item.

    Honoring the Submit value is important, but I will also make sure we try to just get autosubmit working at the Chase website in our latest code. :-)

    I apologize for the inconvenience. I'll pass this along to the developers for resolution in a future version!

    Thank you for alerting us to this. Please let me know if you have any additional questions or concerns.
  • bhenrybhenry Junior Member
    I am noticing some issues with the Safari extension and Chase's banking website that do not occur with Firefox. I deleted all the chase entries and let the 1PW extension rebuild in Safar and on that initial login it goes through to the Chase site fine, so it does not appear to be safari.

    When attempting to login in later w 1PW I see this after the PW is populated https://mfasa.chase.com/auth/fcc/login

    On Firefox with a successful login you immediately the following token info - I truncated the rest of the URL info in case it has key info in it

    https://mfasa.chase.com/auth/auth-stoken-osl.html > etc etc
  • bswinsbswins Agile Customer Care
    Hello bhenry,

    I merged your topic with a similar thread.

    Please review Khad's comments above and let us know if you have any further questions.

    Cheers!

    Brandt
  • I can autofill the username and password fields for Chase Online (https://chaseonline.chase.com/logon.aspx), but login doesn't work. I just get taken back to the same screen. This used to work.

    I am using Snow Leopard and the latest 1Password and Safari 5.1 dev preview.

    Also, I miss the ability to just auto-login. Now, the pop-up comes up and you have to press Enter. It used to be a pop-up (old context menu style) would come up only if you had multiple usernames/passwords for that site. Now it comes up even if you only have one. I hope that gets changed in the future. Or maybe it's just because I am using the Safari 5.1 dev preview on Snow Leopard (thanks for adding at least limited support for that config, BTW).
  • khadkhad Social Choreographer Administrator
    edited 4 Jul 2011 #12
    I'm sorry that you're having this problem. Please try saving the login manually like this:

    1. Enter your username and password, but DO NOT submit the form.
    2. Click the 1Password button in your browser's toolbar, and choose Save Login.

    Manually saving a login can be useful for logins that are either problematic to begin with or were once working but have since stopped. Doing this allows 1Password to refresh everything it "knows" about the page. Login pages often change as websites are updated and this can be a necessary but very useful tip. :-)

    If you are still having trouble, please take a look at our "Website Login Issues" guide:

    http://help.agilebits.com/1Password3/login_issues.html

    Note especially that editing the login to change the Submit value from "If Autosubmit is ON" to "Never" works on a lot of sites which modify the form before submitting it or are looking for a literal key press or mouse click. This will give you the chance to actually give them what they are looking for by submitting the form yourself rather than allowing 1Password to do it on your behalf.

    I hope that helps. Please let me know.

    Thanks!
  • First of all, let me just say... I love this product. It's made it a lot easier for me to manage my passwords SECURELY by not maintaining the same password for every website account of mine... I don't know what I'd do without 1Password!

    I'm currently on the GM of Lion and the latest release (as of today being upgraded) of 1Password. I see that a lot of the kinks have now been ironed out with the latest release of 1PW. For some reason, however, I am still having trouble using 1PW with Chase.com. Does anyone else have an account with them and are you experiencing the same problem? I haven't experienced the problem before and my password is the same.

    If I login manually at: https://www.chase.com/ the page redirects me to https://mfasa.chase.com/auth/fcc/login (which is a blank page) and then moves along to the account area. When I use 1PW to login at chase.com using the same details, the page hangs at https://mfasa.chase.com/auth/fcc/login and doesn't take me to the account area. This has never been a problem for me before with 1PW.


    I've tried removing/adding the extension and everything, but it seems to be a problem only isolated to this one website.

    Any ideas of what I can do? Thanks for your help :)
  • sapridynesapridyne Junior Member
    Unfortunately, it doesn't work with AutoSubmit set to never.

    Looks like others are having this issues, as well:

    http://forum.agile.ws/index.php?/topic/5174-chasecom-login-trouble/page__p__29558__hl__chase__fromsearch__1#entry29558

    It DOES work in Firefox with Autosubmit set to Always or Never, it works in Chrome when set to Never, but it doesn't work in Safari on either setting...
  • khadkhad Social Choreographer Administrator
    edited 4 Jul 2011 #15
    Thanks for pointing me back to this thread, sapridyne. I have now merged the two and updated the information on the Chase autosubmit issue in our internal tracker. There is, in fact, a known issue for this, and I apologize for having not caught it sooner in the thread from which these recent four posts were merged.

    Thanks for your patience as we work to resolve the issue in a future update. Some of us on the team use Chase, so it is annoying to us as well. :-)

    If we can be of further assistance, please let us know.

    We are always here to help!
  • bswinsbswins Agile Customer Care
    edited 4 Jul 2011 #16
    stephen p wrote:

    First of all, let me just say... I love this product. It's made it a lot easier for me to manage my passwords SECURELY by not maintaining the same password for every website account of mine... I don't know what I'd do without 1Password!

    I'm currently on the GM of Lion and the latest release (as of today being upgraded) of 1Password. I see that a lot of the kinks have now been ironed out with the latest release of 1PW. For some reason, however, I am still having trouble using 1PW with Chase.com. Does anyone else have an account with them and are you experiencing the same problem? I haven't experienced the problem before and my password is the same.

    If I login manually at: https://www.chase.com/ the page redirects me to https://mfasa.chase.com/auth/fcc/login (which is a blank page) and then moves along to the account area. When I use 1PW to login at chase.com using the same details, the page hangs at https://mfasa.chase.com/auth/fcc/login and doesn't take me to the account area. This has never been a problem for me before with 1PW.


    I've tried removing/adding the extension and everything, but it seems to be a problem only isolated to this one website.

    Any ideas of what I can do? Thanks for your help :)


    Hello Stephen and welcome to the Forums!

    I appreciate the kind words regarding 1Password, and I share your confusion on what I would do without it! :)

    I'm also running Lion (GM) and my Chase login is acting the same as yours. As Khad stated in his last reply, this behavior is a known issue, and it is being investigated.

    Thank you for reporting your experience. Since our members use different system configurations, it is helpful to know who is and who is not seeing a particular problem. Your feedback is very important, and I'm glad you let us know.

    Keep checking back on the Forums for any updates. As you and I are both Lion testers and Chase users, you know I'm not happy about it either. ;)

    Cheers!

    Brandt
  • sapridynesapridyne Junior Member
    Glad you guys eat your own dog food! :)

    Looking forward to seeing a resolution to this soon.

    Cheers,
    Sapridyne
  • khadkhad Social Choreographer Administrator
    Nom nom nom. :-D

    We are working hard on a number of issues. I don't have a time frame, but this is definitely on our radar!

    Please let me know if there is anything else I can help with in the mean time.

    Thanks!
  • pycetpycet
    edited 21 Jul 2011 #19
    Just throwing my 2¢ in as well...

    Same problem, using:
    1Password v3.6.1
    MacOS 10.7
    Chrome 12.0.742.112
    Safari 5.1

    Problem exists across both Chrome & Safari. My username auto populates, then the password populates when I press CMD + \. The auto-submit kicks in, and I'm redirected to a blank page (See attachement).

    Thanks for the help!
    Screen Shot 2011-07-21 at 10.29.09 AM.png
    1280 x 800 - 64K
  • Hey there, pycet!

    I personally have a credit card through Chase, and have found that disabling Autosubmit ( uncheck 1Password Preferences > Logins > Submit automatically after filling Logins (Autosubmit)) works well. Since the site is using its own scripting to look for your mouse click or Return press, just have 1Password fill your credentials and then submit the form manually.

    I hope this helps. :)
    pycet wrote:

    Just throwing my 2¢ in as well...


    Same problem, using:
    1Password v3.6.1
    MacOS 10.7
    Chrome 12.0.742.112
    Safari 5.1

    Problem exists across both Chrome & Safari. My username auto populates, then the password populates when I press CMD + \. The auto-submit kicks in, and I'm redirected to a blank page (See attachement).

    Thanks for the help!



  • KengelKengel Junior Member
    brenty wrote:

    disabling Autosubmit ( uncheck 1Password Preferences > Logins > Submit automatically after filling Logins (Autosubmit)) works well. Since the site is using its own scripting to look for your mouse click or Return press, just have 1Password fill your credentials and then submit the form manually.




    This works - Thanks! :)
  • bswinsbswins Agile Customer Care
    Hey Kengel,

    On behalf of Brent, you're very welcome!

    Thanks for updating the thread. I'm very happy to hear it works for you.

    Cheers!

    Brandt