7.3.654.BETA and previous versions will not save immediately to 1password.com

I've observed for quite some time and some versions and 1Password on Windows will not always immediately save to my.1password.com after making changes to my passwords.

I am using system-wide proxies via Internet Explorer's internet settings → Proxy Server, and have set HTTP, HTTPS and SOCKS proxies.
After making changes to my password, I wouldn't be able to view them on iOS and Mac, because they had not been up-to-date.

Most of the time I had to close 1Password for Windows completely and re-enter Master Password, then opened 1Password app window to make the sync.

This has been painful.
I hope the sync mechanism will be as good as it is on both iOS and Mac. Or at least provide an option to manually force a re-sync placed between LOCK and MINIMIZE.


1Password Version: 7.3.654.BETA
Extension Version: 4.7.3.90
OS Version: Windows 10 1809 17763.195
Sync Type: Subscription

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @doio,

    Thanks for reporting this. You said you've observed for some times, how long has this been happening and did you ever report this in the past?

    There are no changes to how 1Password sync to your 1Password account in these beta builds and we have no known sync issues in general for stable versions either as long as if we're talking about normal setups.

    If you're using proxies, then yes, they can interfere with 1Password. We do not support SOCK5 proxy for sure. We also do not allow HTTPS proxy interfering with the security of 1Password's connections to our service; in other words, it must not modify any of the HTTPS traffic from 1Password, it has to pass through normally.

    I hope the sync mechanism will be as good as it is on both iOS and Mac. Or at least provide an option to manually force a re-sync placed between LOCK and MINIMIZE.

    It is already, it syncs every time you unlock, make a change and many more. It also falls back to an hourly sync if there's no successful connection to 1Password.com.

    The problem is likely due to your proxy setup on Windows, it needs to exclude 1Password and allow it secure traffic to https://1Password.com and on secure port, 443. However, Windows is very "odd" with its proxy implementation, it is more fragile than it is on iOS and macOS, since macOS/iOS have the network stack integrated deeper in the system. This makes it easier for any apps to work without having to deal with network where it isn't the case on Windows.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file