OTP for 7.3.654 not working properly

Hi,
I've just tried to reset my OTP from Google Authenticator to 1Password for both Reddit and Origin [EA] but had problems on both occassions where before it was never a problem.

I have a dual screen setup and normally I'm able to select the from my screen option, but this time it didn't seem to register at all.
Weird but can happen of course. For Origin I ended up having to copy/paste the image from clipboard, so all was fair and didn't think much of it.

A few minutes later I'm trying the Reddit MFA and none of the options work for some reason.
I've even successfully downloaded the OTP image and tried loading the file, but it won't seem to accept it in any form.
Before I never had issues, but it seems a bit off with the new version.

Any tips on how to resolve this?

Kind regards
Robert


1Password Version: 7.3.654
Extension Version: 4.7.3.90
OS Version: Windows 10 Pro 1803 build 17134.523
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @powershellpr0mpt,

    Thanks for reporting this.

    We did change the OTP scanner in 7.3 but it doesn't like lack of edges that we are noticing now. We'll be changing it in the next stable update.

    If you take a screenshot of the barcode (Winkey + Shift + S on Windows 10) and save it to your clipboard, then select the From clipboard, does it work?

  • edited January 9

    OK, that did the trick, but kind of a weird workaround :(
    At least it's a known issue and there IS actually a workaround for it, will save me some time tonight [ticking another box of the 2019 Security Check List: fixing all WatchTower issues]

    Thanks for now @MikeT , hope the next stable update will be soon!

  • MikeTMikeT Agile Samurai

    Team Member

    Yep, it's a high priority to fix for the next stable update and we aim to have it out very soon, not like the length that it took to get 7.3 out for sure.

  • Hey @MikeT , unfortunately ran into something else strange related to OTP [since I've been using it nonstop since the workaround]
    If you add an OTP field and click on the QR code icon to select it, it shifts to the left and you need to re-click it.

    Kind of buggy and definitely not something one-off as I've been able to reproduce it time and time again, even after a restart of the application and my system.

    I have added an animated GIF that shows you what I mean

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @powershellpr0mpt,

    That's definitely odd but I can only reproduce it if I tab into the value field first. Do you know if that's the case here for you too?

    The field is resizing to fit the content, so if you enter it and then click icon, it will resize to fit even if it is empty.

    The resizing is definitely annoying and we will fix that in a future update.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file