Cannot upgrade to 7.3.654 on Windows 10 [Fixed in 657 for most cases, investigating others]

foutightfoutight
edited January 11 in Windows

Tried to update and I always see this same error.
https://imgur.com/a/k4d6FEJ

Ive closed all browsers, apps, disabled BitDefender, still same error


1Password Version: 7.2.617
Extension Version: 4.7.3.90
OS Version: Windows 10 Familly 1809 , OS 17763.253
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @foutight,

    Thanks for reporting this.

    Did you by any chance use our 1Password 7.3 betas before?

    Try this:

    1. Open Windows File Explorer and enter the following in the address bar: %LOCALAPPDATA%\1Password\app
    2. If you see 7.old folder, move this to your desktop and press retry, it should install.
  • Thank you for the quick response!

    This is what I found in the folder: https://imgur.com/a/2G40TD4

    However, when I tried to move the 7 folder to my desktop, I had a error that the files were in use and cant move them. I closed everything, tried again, same error. I rebooted, tried again, same error.

    Should I just reinstall fresh?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @foutight,

    You shouldn't be moving the active 7 folder, I was referring to 7.old. The file in use is why 1Password can't install the update.

    Move the 7.3.654 folder in this case and then install the latest 1Password copy from here: https://1Password.com/downloads/

    It should close all running 1Password instances and overwrite the 7 folder for you.

  • foutightfoutight
    edited January 10

    Still not working, I get the same error when I try to run the installer. (https://imgur.com/a/k4d6FEJ)

    I moved the 73654 folder out as well before trying. And did it a 2nd time, same error.

    Should I just delete everything and install fresh?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @foutight,

    Don't delete everything, just rename the app folder in %LOCALAPPDATA%\1Password and then install.

    The only thing that makes sense is that BitDefender is interfering with the app folder, which wouldn't be the first time but disabling isn't enough to avoid the issue.

  • Perfect, that worked! Thanks for the support.

  • MikeTMikeT Agile Samurai

    Team Member

    That's great to hear, we did just ship 7.3.657 update now with additional improvements to our installer, it should work from now on.

  • Exact same problem when I tried to install 7.3.657. Tried all the suggestions in this thread, none worked.
    What I had to do was first uninstall 1Password, then manually delete all the contents of the app folder that I could (would not let me delete the 7 folder yet), then restart the PC, then do a fresh install.

    To that I got the message that 1Password was just updated to 7.3.657 - which I though was a strange message to get to a fresh install. It works now and says I am on 7.3.657
    Just writing to let you know the update fixes didn't improve things much.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Andu,

    Thanks for reporting this.

    Can you tell me which anti-malware solution are you using?

    (would not let me delete the 7 folder yet)

    That is the cause of the issue. The fixes we made so far are not related to this specific issue and this is the one where we cannot reproduce yet; the fixes were due to having other stale app folders in the same directory, so far we've gotten confirmations they're fixed.

  • Windows Defender. This is my work laptop. My station back at home upgraded fine (use Bitdefender there).

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Andu,

    You didn't delete the logs folder within the 1Password directory, right? If yes, could you email us your 1Password diagnostics report, it'll have some installer-related logs we can analyze. Please use this guide to generate the report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • Done, sent.

    All i see in those logs is (os error 32) - but of course you will be able to read more into it.
    The last install, the one that is succesfull is after the restart that followed the uninstall of 1Password.

    Oh! Also, by the way: I love 1Password, I am a big fan, I recommend it to everyone. It works great and I very seldom had any issues with it through all these years. I am saying this so that I'm not that gu just posting if there are negative things to say. :)

    Have a great weekend!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Andu,

    Thanks, we got the email. Yep, something's blocking the 1Password's ability to rename the app folder. The fixes we did were for os error 5.

    Failed to rename existing app folder: The process cannot access the file because it is being used by another process. (os error 32)

    The big question is, which process. You said you already tried all suggestions, that includes closing any running 1Password instance, browsers as well?

    Oh! Also, by the way: I love 1Password, I am a big fan, I recommend it to everyone. It works great and I very seldom had any issues with it through all these years. I am saying this so that I'm not that gu just posting if there are negative things to say. :)

    Thanks for the kind feedback, we appreciate it. Not to worry, no feedback can be negative for us because you're taking the time to give us the feedback; which helps us improve the program. If someone doesn't really like the app, they're not going to take the time to give us feedback and the fact that they do take that time, is already enough.

    ref: YDL-17375-157

  • I got past this by disabling 1Password in the startup tab of Task Manager, rebooting, then I could install 7.3.654. Then I enabled it again in the startup tab of task manager.

    Now I am experiencing the same thing all over again as it tries to install 7.3.657.

    I also use Windows Defender.

  • @MikeT Yeah, I closed running 1Password instances, browsers as well.
    Made extra sure, went to task manager to see if there are any processes there that could be causing this.
    Because of admin privileges I could not disable Windows Defender.

  • Disabled 1password from startup in Task Manager again, rebooted, and was able to install 7.3.657. Before doing that I also opened up Process Explorer (a debug tool). Found that %localappdata%\1password\app\7\1password.exe was open under a process named "System". I did not do anything with Windows Defender to make it work.

  • Hello,

    I'm trying to upgrade from 7.3.654 to 7.3.657 and I am getting that same exact error message as others in this thread have reported (Failed to rename existing app folder...). I've tried moving the version folders from within the 1password/app folder, and the issue still persists when I try installing from the downloaded installer. I've closed all browsers, turned off 1password from the starutp tab of task manager, and turned off Windows Defender and I still get the pop up error message. Are there any other steps I can take? Please let me know, thanks!

  • @hancockjt I've seen occasionally system locking file for no reason just like you describe. Unfortunately we have no idea why it locks file even when no process is using it. We'll keep digging. There was another feature of Windows 10 - telemetry, when Microsoft collects data about what apps do you use. Personally I turned it off when it locked 1Password few times.

    @Andu I can only suspect that this is either Defender, Telemetry or Microsoft Edge, but we can't get that information without requesting elevated privileges and we are trying to avoid asking more privileges than we should have.

    @ediscovery & all - you can safely delete %localappdata%\1Password\app\ folder and run latest installer from http://1password.com/downloads/ (it will give 7.3.657 as of today). Your local data is stored at %localappdata%\1Password\data\, reinstalling app will not affect it.

  • @SergeyTheAgile , thanks for your quick response. I have tried deleting that folder but my system won't let me. I've tried deleting after quitting all programs including my browser and 1password. I get the message:

    Task Manager does not show any 1password processes running. Anything else I can try?

  • @ediscovery there is a tool I use - Handle by Sysinternals. It requires admin rights to run. Here is an example of use:

    C:\>handle C:\Users\serge\AppData\Local\1Password\app\7
    
    Nthandle v4.1 - Handle viewer
    Copyright (C) 1997-2016 Mark Russinovich
    Sysinternals - www.sysinternals.com
    
    explorer.exe       pid: 8444   type: File          1830: C:\Users\serge\AppData\Local\1Password\app\7
    explorer.exe       pid: 8444   type: File          31DC: C:\Users\serge\AppData\Local\1Password\app\7
    
    C:\>
    
  • Thanks again @SergeyTheAgile ! I installed the GUI version of the tool found in your link. For me, explorer.exe is using this file:

    I don't know what to do to get explorer to stop using this file. Any ideas? Thanks in advance for helping!

  • @ediscovery that is path to 1Password for Microsoft Edge extension, that folder should not interfere with updating app itself. If you run updater/installer again, does it work or it fails again? Can you deactivate 1Password extension in Microsoft Edge for a moment to see if it makes the difference? Thanks!

  • Hi @SergeyTheAgile - this worked! Specifically I had to fully uninstall the extension from Edge, then reboot the computer. After rebooting, I was able to successfully install using the installer application.

    My issue is resolved, thanks for your help and swift responses!

  • Thanks for letting us know! We will see what can be done to mitigate that interference from Microsoft Edge extension.

  • I used to have the exact same issue: I tried to upgrade from 7.2.216 to 7.3.657 but apparently renaming was impossible. When trying to delete/rename the %LOCALAPPDATA%\1Password\app\7 folder I was told that it was in use. Deactivating the 1password autostart task and rebooting the system did not solve this problem.
    I finally managed to install the 7.3 version by running the uninstallation and download the newest version from the 1password homepage and run the installer here.
    I do not have the Edge-Plugin, only Chrome-Plugin is in use and I did not even open chrome before trying to rename my app folder...

  • GregGreg

    Team Member

    Hi @Tavadras,

    Do you use any kind of AV/anti-malware software on your computer?

    Thanks!

    ++
    Greg

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file