Error in Dev console 1Password Chrome Extension

After signing in on a website the console log outputs error "Unchecked runtime.lastError: The message port closed before a response was received".
Disabling the 1Password extension resolves the issue.
This bug appeared since Chromium update 72.0.3626.81 as of January 29th.
Please check in to this because console log errors are a PITA for a developer;-)


1Password Version: 6.8.8
Extension Version: 4.7.3.90
OS Version: OS X 10.14.2
Sync Type: ICloud

«1

Comments

  • Hello @ikarusk,

    I think we're going to need detailed steps to reproduce I'm afraid. I just logged into one of the many sites I test and I'm not seeing anything either in the page's console or the background page for the extension. We'll be more than happy to investigate once we can recreate the issue.

  • My setup :

    • Mac - OSX 10.14.2
    • Chrome version 72.0.3626.81
    • 1Password Extension Chrome v 4.7.3.90

    Open developer tools in Chrome and open Console tab.

    • Visit for example https://aws.amazon.com/console/ and Sign in to the AWS Console.
    • With the 1Password extension enabled I instantly get an error in the dev console.
    • error "Unchecked runtime.lastError: The message port closed before a response was received."

    • Disable 1Password extension en Sign In again.

    • no error

    Make sure you have same Chrome version on mac because for me this problem started after the Chrome update yesterday.

    Best regards

  • littlebobbytableslittlebobbytables

    Team Member
    edited January 30

    Hello @ikarusk,

    Thank you, I've now been able to recreate the error message. I misread the first result I found on this error message and initially thought maybe this was a regression in Chrome but the result indicated a workaround which may apply to our extension as well. The workaround doesn't look to have any downside which if is the case can be something we look at.

    ref: xplatform/filling-issues#339

  • Hello @littlebobbytables,

    I have the same problem here.
    Environment:

    • Mac OSX 10.14.2 (Mojave)
    • Chrome 72.0.3626.96
    • 1Password Extension in Chrome: 4.7.3.90

    I don't understand your remark about a workaround.
    Are you investigating/working on this problem?

    Thanks for your help (and many thanks for a great product!!)

    Best regards,

    Bert

  • Hi @BertC,

    First it's worth remembering that the error message doesn't stop anything from working, the changes in Chrome simply mean it's logging an error message. I do appreciate that it will be cluttering up the console log but for the average user they won't even know something is being logged given everything continues to work. The workaround I referenced suggested a change to the extension's code could help to suppress the error or at least that was what I understood to be the case with my initial searching, I haven't tried yet to know for certain that it will help.

  • Also have this issue. I will add the problem with it is when it happens on a form, it causes the entire page to freeze and become non-responsive. This doesn't resolve until page refresh.

    This bug generally seems to happen when you're asked to enter more than 1 password or email field immediately following the other (confirmation fields are an example) while using the form filler or password generator. An example of this is the password reset form on Ikea.com.

    The workaround is to not use the form filler when duplicate fields are present. When creating passwords, manually copy and paste the password from the extension menu. [Not really a good user experience]

  • littlebobbytableslittlebobbytables

    Team Member
    edited February 18

    Hi @AsParallel,

    By any chance do you have our 1Password X extension installed? I am aware of a bug whereby the page appears to freeze after using the Password Generator there. The page isn't actually freezing but something goes wrong when 1Password X attempts to add an overlay for the save dialog prompt that ought to appear immediately. Part of the process happens which means the page itself can no longer be interacted with but the prompt never makes it. If this sounds like what you're experiencing then you should find that pressing the esc key causes proper behaviour to return as the escape key does dismiss the missing prompt and its associated overlay. In my limited testing I find that if I then instruct 1Password X to save that the prompt does correctly appear. I don't know if that will hold true everywhere but it seems to so far in the sites I've been playing with.

    This bug is not present for those running the companion extension that requires 1Password for Mac/Windows. The bug I've described is also separate from the error this thread relates to.

    If you're not running 1Password X please let me know as so far I've never found a page to lock up with the companion extension in this manner.

    ref: x/b5x#788

  • edited February 18

    @littlebobbytables
    I'll try that when I'm back at my desk.

    Itm, is there a thread for the bug in question? I can't find it via Google search, I'll add my +1 if you have a link.

  • Greetings @AsParallel,

    Our bug tracker is private I'm afraid but the issue is thankfully very easy to reproduce (for the developers to test) and given the widespread impact it's one I know our team will prioritise.

  • I'm experiencing the same error in my developer console.

    Here's my environment information:

    • OS: macOS Mojave 10.14.3 (18D109)
    • Chrome: Version 72.0.3626.109 (Official Build) (64-bit)
    • 1Password Extension: Version 4.7.3.90

    I see this in a brand new react project (https://github.com/facebook/create-react-app) when submitting a form. Specifically, it only triggers when a password is present in the form. Turning off the extension makes the error go away.

    I've gone as far as adding localhost to the list of sites for 1Password to ignore, but the error still fires on form submission.

  • Anybody inspecting the developer console will see this error message. Yes we need to consider an alteration to effectively suppress the error message but it does not stop the extension from working. If you're experiencing any other issues they will be independent of this error message and we will need to discuss those separately.

  • Yes it does actually break things, not just an error message.

    I have a site where the upload button triggers this error and the file dialog displays, you choose a file but does not work. Then the dialog shows a second time and if you choose that time, the file is uploaded. Removing 1Password extension makes this problem go away.

  • Hello @sdrew,

    I won't discount the possibility that somehow the 1Password extension is interfering with this page but I do not believe the error message is related. The error message can be found on any page where the injected script needs to communicate with the global page for the extension. What the issue with the page is I cannot say, it would need to be a page I could visit. Is it for a public facing site and one where either I can reach the upload form without an account or where I can easily create a test account?

  • Any status update on this? Happening on numerous websites.

  • Hi @virgofx,

    I would expect this to be visible on all sites. I don't have an estimated time for us resolving it but beyond the additional entry in the console log it should not be affecting actual usage of the extension.

  • Hi, I'm having the same issues (Chrome 72.0.3626.121, 1Password 4.7.3.90).

    Looking at this discussion, there seems to be an issue with handling async responses in chrome.runtime.onMessage
    https://github.com/gatsbyjs/gatsby/issues/9899#issuecomment-466862123

  • Same issue. on mac also. And yes it's affecting website functionality.

  • ag_sebastianag_sebastian 1Password Alumni

    @rjdegelder Is the error affecting the functionality in any way? If so, would you mind giving us more information about what's happening?

    @Invoxio Which 1Password extension are you using? In what way does it affect website functionality? The more details you can give us, the sooner we'll be able to look into it.

    Thanks to both. :smile:

  • I am receiving this message as well after the 1Password mini update. Kind of disappointed with the new 1Password mini as I thought the old one was great!

  • ag_sebastianag_sebastian 1Password Alumni

    Hi @skeltonm,

    Thanks for your feedback. I shared the same opinion, but after using the new mini for some time, I think it's better than the old one. I'm curious to see if the same will happen to you.

    I am receiving this message as well after the 1Password mini update.

    As @littlebobbytables mentioned earlier, everybody will see this message, but it doesn't mean anything is wrong. Is something not working for you?

  • @ag_sebastian I was having issues with the mini not filling logins on any sites, but that seems to be fixed in the second beta.

  • ag_sebastianag_sebastian 1Password Alumni

    Thanks for the update @skeltonm. That does indeed sound like a beta issue that was fixed in the latest beta release. :)

  • @ag_sebastian Sorry, missed your mention. It doesn't seem to affect the functionality, only that js error appear in my dev console when using 1password to login on some websites. I'm still able to use 1password to login.

  • ag_sebastianag_sebastian 1Password Alumni

    Thanks for letting me know, @rjdegelder. You will keep seeing the error message for now, but there's nothing to be alarmed about. Getting rid of it is on our todo list, but it definitely won't affect the fill functionality in any way. :smile:

  • Unchecked runtime.lastError: The message port closed before a response was received.

    Seeing this in Chrome on Windows 7. Logins are not being auto-filled. This started happening within the last week or two. Any advice much appreciated.

    • OS: Windows 7 Enterprise Service Pack 1
    • Chrome: Version 73.0.3683.86 (Official Build) (64-bit)
    • 1Password Version: 1Password for Windows 7.3.657
    • 1Password Extension: 4.7.3.90
  • ag_sebastianag_sebastian 1Password Alumni

    Hi @david_i_smith. We might have to take this to email. Can you please send us a diagnostics report from your Windows PC:

    https://support.1password.com/diagnostics/?windows

    Please add the following code (including the square brackets) to the subject of your diagnostics email before sending it:

    [#VXA-13899-221]

    I'll take a look and let you know what I find out. :smile:

  • Hello, when do you plan to fix this annoying console error message on MacOS?

  • ag_sebastianag_sebastian 1Password Alumni

    Hi there @heihachi88! Thanks for your interest in getting rid of the console error. While I wish I had a straightforward answer, I can't tell you exactly when we'll be able to get to it.

  • redneckredneck Junior Member

    2 months now. Please fix soon! Thanks, -Paying Customer :)

  • ceceliacecelia

    Team Member

    Hey @redneck - We really appreciate you reaching out about this error and I'm sorry this hasn't been resolved yet. I don't have a definitive time frame as for when the fix will come, but I assure you our devs are aware of it and we do have an issue open regarding removing this console error.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file