Unable to install 1Password 7

valentynvalentyn
edited January 2019 in Windows

As some others have descovered 1Password 4 no longer works with the latest version of Chrome 72. As Bundtkate has stated also.

I decided to take the plunge and try to install version 7. Although nothing happens when I try to run the exe. Even if I right-click and Run as Administrator; absolutely nothing happens.

Having tried multiple times, even checking task manager; I see 1Password only briefly flashes up, and then disappears.
I've been able to uninstall, and reinstall my download of 1Password 4 multiple times.
I can install and run multiple other installers from various programs, but it seems just 1Password 7 does nothing.

It seems the latest download of 7 just refuses to actually run or do anything.|

I would appreciate any advice ( although better yet have 1password 4 work again :P )


1Password Version: 7.3.657
Extension Version: 4.7.3.90
OS Version: Windows 10 Build 17134
Sync Type: Local vault / drop box

Comments

  • I'm having the same exact issue. Help!

  • GregGreg

    Team Member

    Hey guys,

    I am sorry for the troubles with 1Password 7 for Windows. We are investigating the issue with the installer at the moment. Please try to do the following:

    1) Uninstall 1Password 6 or 1Password 7 from your PC, if you see it in installed apps.

    2) Open Start menu, type %LOCALAPPDATA%\ there and press Enter.

    3) Find 1Password folder there and move it (cut and paste) to your desktop.

    4) Reboot your PC.

    5) Run 1Password 7 installer and check if the issue remains.

    Let us know if it works. Thank you!

    Cheers,
    Greg

  • Unfortunately I can’t uninstall it, as it never installs. As I’ve stated, it does nothing. Nothing runs, nothing installs.

    I briefly see it ( the installer ) flash up in task manager, but that’s it. There are no 1Password 7 folders or files installed at all.
    The only version I’ve been able to install and use is 1Password 4; but due to the changes in Chrome 72, only works if I disable the certificate checking.

  • valentynvalentyn
    edited January 2019

    Found a solution!

    I followed your steps in Safemode and found some 1password 6 files in there (%LOCALAPPDATA%). Even though I don't remember installing or using it. Removed those, restarted into normal mode, and then 1Password 7 installed.

    Sadly the cost is really high for Ireland. When I clicked get a license price shown in Dollars was far lower than in Euros.

    Then again, if it lasts another 6 years I'm not going to complain, considering I started with the Mac+Win Student license in 2013 :chuffed:

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @valentyn,

    Thanks for the details. Can I ask you to clarify once more for me; you saw some 1Password 6 folders that is not 1Password in %LOCALAPPDATA% directory? Is that correct?

    Do you recall the full name of that folder or check your Trash bin to see if it is still there. If it is there, see if you can get inside that folder and send us a screenshot of the directory's content.

  • Unfortunately I shift+delete things, so nothing in my recycle bin.

    The folder was simple 1Password 6, it wasn't in a primary folder called 1Password like 7 is. The date was 2017 on it, so it seems it's been there ages.

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 2019

    Yea, that's the weird part, we've always been using the 1Password folder for a long time. Even 1Password 6.0-6.8 were using the %LOCALAPPDATA%\1Password\app\6.

    Do you recalling using our 1Password Alpha builds?

  • I have before yes, including some betas in the past. Could likely have been some remnants of that causing some issues.

  • GregGreg

    Team Member

    some remnants of that causing some issues.

    That is most likely the case here. Thank you for the info, we will continue investigating this issue.

    Let us know if there is anything else we can help you with. :+1:

    Cheers,
    Greg

  • Thank you for the help, Greg, and MikeT!

    So far so good with 1Password.

  • bundtkatebundtkate

    Team Member

    Thank you for the help you gave, @valentyn! Mike and I were able to track down that some files/folders from some versions of 1Password 6 give the new installer trouble, but we're still sussing out exactly why so every little tidbit helps. We really appreciate it. :chuffed: I'm glad you're enjoying 1Password 7 thus far and hope it continues to treat you well. Of course, if you have any further questions as you're getting started, never hesitate to ask. We're happy to help! :+1:

  • Hello, @MikeT @Greg and @bundtkate

    I tried to follow these instructions, and deleted all remnants of Agilebits and 1Password files from my computer before trying to install 1Password 7... but it still will not work. Any ideas?

    I am in the same position as @valentyn. I have been using 1Password 4 for a long time, but I am trying to upgrade to the subscription service a 1Password 7 after the recent Chrome update made the previous extension unusable.

    OS Version: Windows 7 Professional
    Sync Type: stored on drop box

  • bundtkatebundtkate

    Team Member

    Are you seeing any sort of error message, @pl_kg, or does the installer just not appear to do anything? Also, it's worth checking if you've got .NET 4.7.2 installed as this isn't installed by default on Windows 7. You can just run the installer here:

    https://support.microsoft.com/en-us/help/4054530/microsoft-net-framework-4-7-2-offline-installer-for-windows

    If you've already got it, it will tell you so just giving it a go is the simplest way to check. :+1:

  • @bundtkate, that solved it! After installing .NET, it was a breeze to download 1Password 7, the browser extension, and migrate my data from my previous 1Password 4 account.

    Thanks!

  • GregGreg

    Team Member

    Hi @pl_kg,

    Fantastic news! On behalf of Kate you are very welcome. :)

    You should be all set, but please do not hesitate to contact us anytime. Thanks!

    ++
    Greg

This discussion has been closed.