1PasswordNativeMessageHost crashes on boot. Relaunches automatically and is fine.

This is just a minor annoyance, but I thought I would report it.

Every time I boot up, 1PasswordNativeMessageHost crashes with a KERN_INVALID_ADDRESS exception.

It is automatically relaunched, and works fine thereafter.


1Password Version: 7.2.4
Extension Version: 4.7.3.90
OS Version: macOS 10.14.3
Sync Type: Dropbox / Team Vault
Referrer: forum-search:1PasswordNativeMessageHost

Comments

  • LarsLars Junior Member

    Team Member

    @mwdiers - I'm sorry for the trouble! It's reassuring to hear that the problem resolves itself, but it's definitely not expected or normal behavior for it to recur on each restart. Are you using Chrome? Or Firefox? Or both? And have you tried deleting/reinstalling the 1Password extension in either browser?

  • dunkohdunkoh Junior Member

    this just happened to me as well.

    Here's the beginning of the crash log (I'm going to submit the entire thing through more appropriate channel

    Process: 1PasswordNativeMessageHost [1269]
    Path: /Applications/1Password 7.app/Contents/Library/LoginItems/1Password Extension Helper.app/Contents/MacOS/1PasswordNativeMessageHost
    Identifier: 1PasswordNativeMessageHost
    Version: 7.2.4 (70204001)
    Code Type: X86-64 (Native)
    Parent Process: Google Chrome [1196]
    Responsible: Google Chrome [1196]
    User ID: 501

    Date/Time: 2019-02-25 08:27:28.164 -0500
    OS Version: Mac OS X 10.14.3 (18D109)
    Report Version: 12
    Anonymous UUID: A5A14503-22F7-15D2-3C18-66408F2370FC

    Time Awake Since Boot: 190 seconds

    System Integrity Protection: enabled

    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000020

    VM Regions Near 0x20:
    -->
    __TEXT 00000001008bb000-0000000100e3b000 [ 5632K] r-x/rwx SM=COW /Applications/1Password 7.app/Contents/Library/LoginItems/1Password Extension Helper.app/Contents/MacOS/1PasswordNativeMessageHost

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 1PasswordNativeMessageHost 0x0000000100dc31de 0x1008bb000 + 5276126
    1 1PasswordNativeMessageHost 0x00000001008c3e89 0x1008bb000 + 36489
    2 1PasswordNativeMessageHost 0x00000001008c0f40 0x1008bb000 + 24384
    3 1PasswordNativeMessageHost 0x00000001008bf19f 0x1008bb000 + 16799
    4 1PasswordNativeMessageHost 0x00000001008bd4e7 0x1008bb000 + 9447
    5 1PasswordNativeMessageHost 0x00000001008bd108 0x1008bb000 + 8456
    6 libdyld.dylib 0x00007fff784dbed9 start + 1

  • me too

    Process:               1PasswordNativeMessageHost [1412]
    Path:                  /Applications/1Password 7.app/Contents/Library/LoginItems/1Password Extension Helper.app/Contents/MacOS/1PasswordNativeMessageHost
    Identifier:            1PasswordNativeMessageHost
    Version:               7.2.5 (70205002)
    Code Type:             X86-64 (Native)
    Parent Process:        Google Chrome [829]
    Responsible:           Google Chrome [829]
    User ID:               503
    
    Date/Time:             2019-03-26 15:23:56.535 +0800
    OS Version:            Mac OS X 10.14.4 (18E226)
    Report Version:        12
    Anonymous UUID:        F908946F-A220-28AE-A90A-55998BC5BA09
    
    
    Time Awake Since Boot: 710 seconds
    
    System Integrity Protection: enabled
    
    Crashed Thread:        0  Dispatch queue: com.apple.main-thread
    
    Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000020
    
    VM Regions Near 0x20:
    --> 
        __TEXT                 0000000105042000-00000001055c2000 [ 5632K] r-x/rwx SM=COW  /Applications/1Password 7.app/Contents/Library/LoginItems/1Password Extension Helper.app/Contents/MacOS/1PasswordNativeMessageHost
    
    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0   1PasswordNativeMessageHost      0x000000010554a1ce 0x105042000 + 5276110
    1   1PasswordNativeMessageHost      0x000000010504ae79 0x105042000 + 36473
    2   1PasswordNativeMessageHost      0x0000000105047f30 0x105042000 + 24368
    3   1PasswordNativeMessageHost      0x000000010504618f 0x105042000 + 16783
    4   1PasswordNativeMessageHost      0x00000001050444d7 0x105042000 + 9431
    5   1PasswordNativeMessageHost      0x00000001050440f8 0x105042000 + 8440
    6   libdyld.dylib                   0x00007fff5aed43d5 start + 1
    
    Thread 1:
    0   com.agilebits.AgileLibrary      0x00000001057a81cb runtime.mach_semaphore_wait + 11
    1   ???                             0x0000000100002803 0 + 4294977539
    2   com.agilebits.AgileLibrary      0x00000001057a2793 runtime.semasleep.func1 + 51
    3   com.agilebits.AgileLibrary      0x000000010577b114 runtime.semasleep + 68
    4   com.agilebits.AgileLibrary      0x0000000105763229 runtime.notesleep + 233
    5   com.agilebits.AgileLibrary      0x0000000105782a05 runtime.stopm + 229
    6   com.agilebits.AgileLibrary      0x0000000105783bcc runtime.findrunnable + 1292
    7   com.agilebits.AgileLibrary      0x00000001057846db runtime.schedule + 315
    8   com.agilebits.AgileLibrary      0x00000001057850df runtime.goexit0 + 559
    9   com.agilebits.AgileLibrary      0x00000001057a407b runtime.mcall + 91
    
    Thread 2:
    0   com.agilebits.AgileLibrary      0x00000001057a81e3 runtime.mach_semaphore_timedwait + 19
    1   ???                             0x0000003c00002c03 0 + 257698049027
    2   com.agilebits.AgileLibrary      0x00000001057a2793 runtime.semasleep.func1 + 51
    3   com.agilebits.AgileLibrary      0x000000010577b114 runtime.semasleep + 68
    4   com.agilebits.AgileLibrary      0x00000001057633a2 runtime.notetsleep_internal + 274
    5   ???                             0x007469622d343620 0 + 32766967684544032
    
    Thread 3:
    0   com.agilebits.AgileLibrary      0x00000001057a81cb runtime.mach_semaphore_wait + 11
    1   ???                             0x0000000000001903 0 + 6403
    2   com.agilebits.AgileLibrary      0x00000001057a2793 runtime.semasleep.func1 + 51
    3   com.agilebits.AgileLibrary      0x000000010577b114 runtime.semasleep + 68
    4   com.agilebits.AgileLibrary      0x0000000105763229 runtime.notesleep + 233
    5   com.agilebits.AgileLibrary      0x0000000105782a05 runtime.stopm + 229
    6   com.agilebits.AgileLibrary      0x0000000105783bcc runtime.findrunnable + 1292
    7   com.agilebits.AgileLibrary      0x00000001057846db runtime.schedule + 315
    8   com.agilebits.AgileLibrary      0x0000000105784a06 runtime.park_m + 182
    9   com.agilebits.AgileLibrary      0x00000001057a407b runtime.mcall + 91
    
    Thread 4:
    0   com.agilebits.AgileLibrary      0x00000001057a81cb runtime.mach_semaphore_wait + 11
    1   com.agilebits.AgileLibrary      0x000000010577afe2 runtime.semasleep1 + 82
    2   com.agilebits.AgileLibrary      0x00000001057a2793 runtime.semasleep.func1 + 51
    3   com.agilebits.AgileLibrary      0x000000010577b114 runtime.semasleep + 68
    4   com.agilebits.AgileLibrary      0x0000000105763229 runtime.notesleep + 233
    5   com.agilebits.AgileLibrary      0x0000000105782a05 runtime.stopm + 229
    6   com.agilebits.AgileLibrary      0x00000001057833d9 runtime.startlockedm + 153
    7   com.agilebits.AgileLibrary      0x000000010578460f runtime.schedule + 111
    8   com.agilebits.AgileLibrary      0x0000000105784a06 runtime.park_m + 182
    9   com.agilebits.AgileLibrary      0x00000001057a407b runtime.mcall + 91
    
    Thread 5:
    0   com.agilebits.AgileLibrary      0x00000001057a81cb runtime.mach_semaphore_wait + 11
    1   ???                             0x0000000000002503 0 + 9475
    2   com.agilebits.AgileLibrary      0x00000001057a2793 runtime.semasleep.func1 + 51
    3   com.agilebits.AgileLibrary      0x000000010577b114 runtime.semasleep + 68
    4   com.agilebits.AgileLibrary      0x0000000105763229 runtime.notesleep + 233
    5   com.agilebits.AgileLibrary      0x0000000105782a05 runtime.stopm + 229
    6   com.agilebits.AgileLibrary      0x0000000105783bcc runtime.findrunnable + 1292
    7   com.agilebits.AgileLibrary      0x00000001057846db runtime.schedule + 315
    8   com.agilebits.AgileLibrary      0x000000010578151e runtime.mstart1 + 158
    9   com.agilebits.AgileLibrary      0x0000000105781466 runtime.mstart + 118
    10  com.agilebits.AgileLibrary      0x00000001058e4bb3 crosscall_amd64 + 12
    11  libsystem_pthread.dylib         0x00007fff5b0c22eb _pthread_body + 126
    12  libsystem_pthread.dylib         0x00007fff5b0c5249 _pthread_start + 66
    13  libsystem_pthread.dylib         0x00007fff5b0c140d thread_start + 13
    
    Thread 6:
    0   com.agilebits.AgileLibrary      0x00000001057a81cb runtime.mach_semaphore_wait + 11
    1   com.agilebits.AgileLibrary      0x000000010577afe2 runtime.semasleep1 + 82
    2   com.agilebits.AgileLibrary      0x00000001057a2793 runtime.semasleep.func1 + 51
    3   com.agilebits.AgileLibrary      0x000000010577b114 runtime.semasleep + 68
    4   com.agilebits.AgileLibrary      0x0000000105763229 runtime.notesleep + 233
    5   com.agilebits.AgileLibrary      0x00000001057828f9 runtime.templateThread + 249
    6   com.agilebits.AgileLibrary      0x0000000105781567 runtime.mstart1 + 231
    7   com.agilebits.AgileLibrary      0x0000000105781466 runtime.mstart + 118
    8   com.agilebits.AgileLibrary      0x00000001058e4bb3 crosscall_amd64 + 12
    9   libsystem_pthread.dylib         0x00007fff5b0c22eb _pthread_body + 126
    10  libsystem_pthread.dylib         0x00007fff5b0c5249 _pthread_start + 66
    11  libsystem_pthread.dylib         0x00007fff5b0c140d thread_start + 13
    
    Thread 7:
    0   libsystem_pthread.dylib         0x00007fff5b0c13f0 start_wqthread + 0
    
    Thread 8:
    0   libsystem_pthread.dylib         0x00007fff5b0c13f0 start_wqthread + 0
    
    Thread 0 crashed with X86 Thread State (64-bit):
      rax: 0x0000000000000000  rbx: 0x0000000105f8e318  rcx: 0x00000000ff000000  rdx: 0x0000000300001d80
      rdi: 0x00007f9cf2303c00  rsi: 0x0000000000000000  rbp: 0x00007ffeeabbd7b0  rsp: 0x00007ffeeabbd4e8
       r8: 0x00000000000043d6   r9: 0xffffffff00000000  r10: 0x00007fff86a45090  r11: 0x00007f9cf2002880
      r12: 0x00007f9cf2301ed0  r13: 0x00007f9cf2301f80  r14: 0x00007ffeeabbd4f0  r15: 0x900000010555fe50
      rip: 0x000000010554a1ce  rfl: 0x0000000000010246  cr2: 0x0000000000000020
    
    Logical CPU:     2
    Error Code:      0x00000004
    Trap Number:     14
    
    
  • LarsLars Junior Member

    Team Member
    edited March 26

    Hi @dunkoh and welcome to the forum, @Mitt! Sorry for the trouble. This one's already on our radar screen. Fortunately it seems to be happening to very few people (though I realize that doesn't help you at all). We're still looking into it, but as of now I have nothing to report on the issue. Apologies for the inconvenience and thanks for your patience as we work to get this solved. If you'd be willing to have us take a closer look, I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/100894/1passwordnativemessagehost-crashes-on-boot-relaunches-automatically-and-is-fine#latest
    • Your forum username: (respectively)

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure they're added to this issue Thanks very much!

    ref: apple-3202

  • I have this problem with Brave browser on Mac. The 1P extension is v4.7.3.90 and Brave is v0.62.50 Chromium 73.0.3683.86. Posting from iPhone due to internet outage, btw.

  • ag_anaag_ana

    Team Member

    Hi @bergdesign!

    Have you sent us a diagnostic report too? If you did, can you please let us know your Support ID number so we can locate it in the system?

    Thank you!

  • I just sent you three :)

    [#XVG-92197-328]

    Thanks for following up :)

  • ag_anaag_ana

    Team Member

    Thank you @bergdesign! We will get back to you via email as soon as possible :)

  • I'm running into this problem as well with Chrome Version 73.0.3683.103 (Official Build) (64-bit) and 1Password extension 4.7.3.90.
    The Support ID associated with my diagnostic report is. [#NLY-92969-941]

  • LarsLars Junior Member

    Team Member

    @M_Horst - please try clicking Preferences > Updates and checking the box marked "include beta builds," then updating to the current 7.3 beta version and see if that resolves your issue. Thanks -- let us know how that works for you.

  • @Lars Upgrading to Version 7.3 Beta 12 seems to have resolved the issue for me. Thanks!

  • ag_anaag_ana

    Team Member
    edited April 20

    @M_Horst, on behalf of Lars, you are very welcome! I am happy to hear he was able to clarify things for you. :)

    Have a wonderful day!

  • @Lars Support also suggested removing the old 1Password 3 folder from Application Support. That seems to have resolved the issue on a different machine still running 7.2.5 and not any of the 7.3 betas.

    "It seems like you have some leftovers from 1Password 3 still running and messing with your system. Here's what we need to do:

    • Open this location - /Users/~/Library/Application Support/
    • Find and delete the "1Password" folder that is in this location.
    • Restart the computer."

    Thanks!

  • BenBen AWS Team

    Team Member

    Glad to hear that helped out, @M_Horst. Indeed there should only ever be one copy of any version of the 1Password app on a system at a time, as having more than one can cause issues. :+1:

    Ben

  • @Ben To be clear, there was only a single instance of 1Password.app installed. The folder to be deleted was the 1Password folder within Library/Application Support, not the application itself.

  • BenBen AWS Team

    Team Member

    Thanks @M_Horst. That folder will have contained a copy of the "1PasswordAgent.app" which was likely the culprit.

    Ben

  • It's the chrome extension causing the problem.
    I sent several dumps over the last 6 months with no response.

  • brentybrenty

    Team Member

    @dtmcbride: I'm not seeing anything like that. Where did you send them?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file