IPv6 login fill vs IPv4 (reopening)

BLDBLD

There's an old discussion on this that was closed back in April 2017.

It looks like 1P still doesn't handle numeric IPv6 addresses for auto-fill. This is not a big deal yet obviously -- but eventually it will be.

I have several local servers that I access via numeric IP -- and while I can certainly use IPv4 addresses now, I am trying to constantly move in the IPv6 direction to be future ready.

I don't have a local DNS setup, nor do I want to go to very machine and add this to a hosts file.

I hope there's an open defect report for this -- hopefully scheduled to be fixed "at some point."


1Password Version: OS X 7.2.4
Extension Version: Firefox 4.7.3.90
OS Version: OS X 10.14.3
Sync Type: N/A

Comments

  • Hi @BLD,

    I've found support for IPv6 in the UK has been somewhat underwhelming so I don't have an easy way to test anything here. What I would be curious to learn though is if you save a Login item using the steps detailed on our support page How to save a Login manually in your browser whilst accessing a page by its IPv6 address what does 1Password save and does it not display it as a match when you next access 1Password mini?

  • 1P saves a Login item that looks correct, i.e., the 'website' field displays a URL in the correct format: 'http://[IPv6-numeric-address]/...'.
    (Also, just saving the URL manually on my own worked as well.) And the 1P Mini also correctly suggests that item as a match.

    However, when the Suggested item is selected, the username and password fields are not autofilled -- nothing happens. I tried in Chrome, Firefox and Safari under OS X.

    The exact same web page using an IPv4 numeric address rather than IPv6 works fine.

  • littlebobbytableslittlebobbytables

    Team Member
    edited February 4

    Hi @BLD,

    I really wish I could try and reproduce this. It isn't that I don't believe you, I just wish I could learn more about where the failure is happening. I've filed a report and hopefully we can get this fixed.

    ref: apple-3081

  • @littlebobbytables ok -- but you could test this just by using a link-local IPv6 address to your own machine. You don't need support from your ISP in any way to reproduce this problem.

  • Hi @BLD,

    With some assistance from a colleague I believe we've located the cause, hopefully the issue I've filed contains enough detail for the developers to act on.

  • @littlebobbytables that's great, thanks!

  • BenBen AWS Team

    Team Member

    Hi @BLD

    We expect this to be fixed in 1Password for Mac v7.3. Please let us know how it turns out.

    Ben

  • BenBen AWS Team

    Team Member

    :)

    Ben

  • BLDBLD

    @Ben -- so when will v7.3 (for MacOSX) be released?

  • BenBen AWS Team

    Team Member

    As soon as it is ready. ;) In all seriousness, we don't pre-announce release dates, but it should be coming soon.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file