Are there any issues in upgrading to Firefox 10.0.1

I'm still on Firefox 8... It took a long time for me to make that switch, because I was concerned about potential incompatibilities or problems with 1P, since I rely on it so much. Should I upgrade to FF10? Are there issues that I should be aware of before moving forward?

TIA... Robert

Comments

  • khadkhad Social Choreographer

    Team Member
    edited February 2012
    Compatibility issues are essentially a thing of the past ever since the new extension was released back with Firefox 5 (or was it 6?). We used to have to compile a new version of the extension with each new release, but that is no longer the case. The current extension has been working in Firefox since version 5 (or 6) and already works in Firefox 10, 11, and 12. :D

    We strongly encourage you to keep up to date with your browser — whoever one you use — since the web browser is one of the primary vectors of attack for malware. It is the main portal from your machine to the wild wild web. Browser updates contain important security updates which, as a 1Password user, I'm sure you are keen to keep up with.

    If we can be of further assistance, please let us know. We are always here to help!
This discussion has been closed.