1Password 7 Beta Extension isn't working with Vivaldi 2.2

Hello,
I've reinstalled the MacBook today and it seems the 1Password Beta Extension isn't working with Vivaldi anymore.

Steps to produce

  1. I did a fresh install of my Macbook Pro with MacOS Mojave 10.14.3
  2. I've installed Vivaldi (Stable Channel) Version 2.2.1388.37 (Stable channel) (64-Bit)
  3. Did the same with 1Password 7 and did also the Beta update already
  4. Installed the Chrome Extension to use it in Vivaldi

Expected behavior

The 1Password Extension should work in Vivaldi to use autofill and more

Actual behavior

Everytime if I try to open the 1Password Extension to connect it with my 1Password I receive the message "Couldn’t connect to 1Password"

Additional information

1PASSWORD_VERSION: 7.2.5-Beta1
OPERATING_SYSTEM: MacOS Mojave 10.14.3 (fresh installation)

I hope anyone can help me to solve this problem.


1Password Version: 7.2.5-Beta1
Extension Version: 4.7.3.90
OS Version: MacOS 10.14.3
Sync Type: 1Password Family Account

Comments

  • @ShadowFM,

    Given the fresh installation of macOS I suspect the issue you're having is one of a missing Chrome support folder which Vivaldi uses for native messaging. 1Password should have displayed a prompt and guided you towards our support page If you see “1Password can’t save or fill” when you open your browser; specifically you want the steps in the section titled For all browsers. That should see things work :smile:

  • Hey @littlebobbytables,

    I've never seen this page before, and I hadn't a prompt with this guide but it solve my problem :chuffed:

    Thanks! :+1:

  • rudyrudy

    Team Member

    @shadowFM,

    I'm glad that @littlebobbytables was able to help. The prompt he was thinking of is no longer being shown since it was wired up to our legacy WebSockets listener; Safari pre-7.2 was the last thing using WebSockets so when we shipped 7.2 the opportunity to remove an attack surface was worth more than the benefit of legacy connections from the extension (which would just be presented with a "you can't connect using WebSockets anymore" alert.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file