google 2fa no longer offers authenticator option

1Password adds a purple banner to items where the site supports 2FA but the item doesn't have a TOTP field.

I see this banner for one of my G Suite accounts and try to follow the instructions. When I get to Google's "2-Step Verification" page, the main option is "Google Prompt" and the only others offered are 1) Security Key or 2) Text Message or Voice Call.

Any idea why Google is anti-TOTP-app?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:google 2fa

Comments

  • Never mind, I found out that if I just accept Google Prompt (and also configure a backup, e.g. text message), I then arrive at a screen that allows choosing an Authenticator App (which Google assumes is their app!). Once I set that up (using 1P), I can turn off Google Prompt.

    Simple, eh?

  • Even after I turn off Google Prompt, it seems to be used by default when logging in (although it "times out" immediately), and I have to manually select "Use Google Authenticator". Very clunky!

    My ask to 1P is to update the 2FA docs for Google to mention this tortuous path to 2FA via 1P.

  • Hi @ceich62,

    So I'm going to apologise for the large image but I deactivated 2FA on one of my Google accounts and went through the steps to re-enable it. After the dance with the SMS I was presented with the following page, is this what you saw as well?

    At the top it has the Google prompt so they seem to be pushing that over other methods but below I was also offered a number of alternative methods, one of which was Authenticator app.

    It's of course entirely possible you saw a different page for some reason which meant you did have to apply a certain amount of trial and error to finally locate the desired option. I'll wait to see your thoughts :smile:

  • Perhaps you didn't see my two followups? I saw what you saw. The rub is that during login, I have to select using "Google Authenticator" (really 1P) every time.

  • Hi @ceich62,

    What I was trying to understand was in setting up 2FA on the Google account I tested with I had the option of Authenticator app immediately. I didn't need to set up Google Prompt and when I log into the account I'm automatically asked for the 2FA code. You could try disabling 2FA on the account and setting it up once more to see if you can streamline the process.

  • Perhaps for public accounts? I was using a G Suite account.

    Or it may depend on whether you've signed in to that account using a Google mobile app (which is the vector for Google Prompt).

  • I'm probably not well versed enough with Google's various offerings to comment with any confidence. If you have no option but to select Google prompt when you first try to set up 2FA then we're being presented with slightly different paths. That's a pity if that's the case.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file