Is "Open and Fill" supposed to work with 1Password X?

LarryMcJLarryMcJ Senior Member

I'm using 1Password X with Chrome on a Pixelbook. "Open and Fill" either isn't supposed to work with 1Password X or I'm doing something wrong. I've been a 1Password user for over a decade but I'm new to 1Password X. The best I can do is use "Open and Fill" and then as soon as I click once in either the USERNAME or PASSWORD field, my credentials are automatically filled in. This isn't a big inconvenience, but I'd just like to know if this is all I should expect from 1Password X.


1Password Version: X
Extension Version: 1.13.2
OS Version: Chrome OS
Sync Type: AgileBits Families Plan
Referrer: forum-search:open and fill 1password x

Comments

  • Hello @LarryMcJ,

    You're seeing the expected behaviour. The way that open-and-fill in 1Password X works is 1Password X waits for the page to place keyboard focus on a field. In terms of events we can listen for the trouble is there is a page loaded event but all that tells us is the browser has finished downloading the parent HTML and associated resources. Stuff like JavaScript and iframes mean that event doesn't mean the page is ready to interact with and I've seen pages where it takes five or more seconds before the page is actually ready. Five seconds may not seem like a lot but it's an age when things are normally measured in milliseconds.

    A well designed page, especially if it's a dedicated sign-in page, will hopefully leave keyboard focus on the first field rather than force the user to click first. If nothing else it can help those with visual impairments, a little thing to make things a bit easier and quicker. If a page does this you should find 1Password X fills the fields automatically. Amazon is a good example of it working. If a site doesn't leave keyboard focus on a field though it would see a pause and then 1Password X fills after you click.

  • LarryMcJLarryMcJ Senior Member

    Thanks so much, Bobby. Great explanation of what I'm seeing. Amazon, and a few others open "and" fill instantly, others open and then fill after a few seconds, while quite a few (most) require either a tap in one of the fields or a tap on the key icon at the top of the 1Password browser.

    The few that infuriate me simply won't autofill at all, no matter how many times I tap the autofill key icon.

  • kaitlynkaitlyn

    Team Member

    Thanks for the explanation, @LarryMcJ. Would you mind providing the URLs for the sites that won't autofill at all? If you don't feel comfortable sharing them on a public forum, feel free to shoot us an email at [email protected] and mention this post in the message.

  • LarryMcJLarryMcJ Senior Member

    Kaitlyn, there is nothing at all sacred about these sites. (1. and 3.) are the problematic ones I see right now in X, but I threw in (2.) just because it's really odd what it does.

    1. https://www.anylist.com/auth/sign-in?next=/account (1Password X launches the account login page but nothing happens. Can't click in either field to fill and "Fill" isn't displayed in the 1Password X login while on the login page (as it is on most sites).

    2. https://tellico.chelseareservations.com/Login.aspx (Works fine in 1Password X but 1Password for Android populates the username in both the username and password fields.)

    3. https://www.dine-rewards.com/ (Email address autofills just fine but the password can't be filled by 1Password.

  • Hello @LarryMcJ,

    So I don't have a ChromeBook or any ChromeOS device to test with but I tried testing in Chrome on my Mac. Using the stable version of 1Password X I saved a Login item for AnyList and then use open-and-fill. Everything worked without any sign of an issue.

    Dine Rewards was a different issue. They're using a text field for the password and and as you enter characters they're replacing them with ●●●s in a bid to make the password field look like it does on iOS. The difference is iOS does that natively to help with typos when tapping on the virtual keyboard and has a useful point. For now I think you will be limited to copy and paste for the password which I don't like having to suggest.

    I don't have a solution for the Tellico site I'm afraid. The desktop version of the page uses a password field and if I manually visit the URL loaded in Android Chrome in either Chrome on my Mac or Safari set up to pretend to be iOS Safari it still shows as a password field. In Android Chrome though it's a text field and again that throws filling off because the item saved uses a password field. I can't figure out why that is only happening on an Android device - it makes no sense to me. I fear copy and paste again will be the only recourse.

  • LarryMcJLarryMcJ Senior Member

    I'm fine with (2. and 3.) but I don't experience what you do on (1.) at all. I've even re-created the login and here is what I experience using Chrome browser on a Pixelbook (Chromebook).

    1. Press "Go" in the 1Password X login
    2. I'm taken to the AnyList login page (https://www.anylist.com/auth/sign-in?next=/account)
    3. Both fields are empty
    4. Click in either field does nothing
    5. In 1Password X there is no option for "Fill" as normally exists with logins there. The only option is "Go" again
    6. The only option here is apparently copy/paste as well

    Is there anything else I can try for autofilling this site? I know it should work as I downloaded a couple other Chrome browser extensions for competitive password managers and it works fine in both. Thanks.

  • Greetings @LarryMcJ,

    So the tab opened by 1Password X loads, looks fine but along with no filling even the toolbar interface suggests something isn't right as it's offering open-and-fill, almost like the tab doesn't exist.

    Can you check something for me please. Reproduce the issue and click on the toolbar button. In the left sidebar, just below the search field is the first option Suggested Items and if so is there any text immediately below the title but still part of that menu option? What it would normally display is the domain of the current tab and I'm wondering what 1Password X is seeing.

  • LarryMcJLarryMcJ Senior Member
    edited February 11

    Bobby, the sub-text below the login name does, in fact, show the correct URL, but it does not have the usual "Fill" button out to the right. I decided to completely remove/add the login again (already done this several times) but this time when I added it back the "Fill" button on the right side of the login was displayed...and it now works. I don't know if they changed something on their end, but all I did was re-create the very same login with the exact same URL. I've done this several times so I'm 100% certain it never worked before.

    So now the only place this login won't work is the Android app (and I even changed to the current Android beta to see if that made a difference). The 1Password browser simply can't load the site URL and displays the error I reported earlier in this thread. I can, however, turn on the "Accessibility" fill option in the Android app and then use the Android Chrome browser. The login page displays in Chrome and I simply tap on either the USERNAME or PASSWORD field and the 1Password Login selection pops up and I can fill the credentials.

    While not a huge inconvenience, I hope the 1Password browser will eventually work with this site as it's my primary hotel for travel and I use it a lot. FWIW, this is the first site I've ever encountered that won't load in the 1Password browser. If there's anything I can report to this hotel chain's web team, please let me know...it's worth a shot. Thanks for all your help!

  • ag_sebastianag_sebastian 1Password Alumni

    ...and it now works.

    That sounds odd, but I'm glad to hear things are working again. :smile:

    The 1Password browser simply can't load the site URL and displays the error I reported earlier in this thread.

    I did some testing on my own Android device, and https://tellico.chelseareservations.com/Login.aspx loads for me in the 1Password browser, but with an expected caveat; I get redirected to the mobile site, https://tellico.chelseareservations.com/mobile/Loginm.aspx. The issue on the mobile site, like Bobby already mentioned, is that the password field is set as a regular text field. If you'd like to report anything to the hotel chain's web team, I'd suggest asking them to make sure the mobile site has the input field type set to password. That should help 1Password fill properly on the site.

  • LarryMcJLarryMcJ Senior Member

    Crap! I just realized my last reply to Bobby (and discovery after removing/adding the login) was actually regarding a different thread here:

    https://discussions.agilebits.com/discussion/99426/problematic-site-using-android

    I'll revisit his last comments regarding "this" thread. Obviously, not enough coffee yet this morning!

  • LarryMcJLarryMcJ Senior Member

    (Back on topic for this thread)

    Here is a recap of what happens with this login:

    1. Press "Go" in the 1Password X login
    2. I'm taken to the AnyList login page (https://www.anylist.com/auth/sign-in?next=/account)
    3. Both fields are empty
    4. Clicking in either field does nothing
    5. Staying on this login page and going back to 1Password X there is no "Suggested Items". on the top left. There is only the login entry again with the "Go" button where I should be seeing a suggested item with a "Fill" button.

    As Bobby said, it's like 1Password X doesn't recognize there are credential entry fields on the page. When using this login on the Android app it takes me to the correct account login page and both fields are blank. tapping the key at the upper right displays "No matches found". Tapping inside either login field does nothing, where it would normally open the 1Password popup and tapping that would fill both fields.

    I know the developers of this app well...anything I should suggest to them that would make this work with 1Password X and Android?

  • ag_sebastianag_sebastian 1Password Alumni
    edited February 12

    @LarryMcJ: I was able to make the Anylist filling work: Video

    I'd like to ask you to try using the 1Password X inline menu to save a new Login item, and see if the new item will fill:
    1. Go to https://www.anylist.com/auth/sign-in?next=/account
    2. Type in your credentials
    3. Click the 1Password icon on any of the fields > Three dots > Save login. Save it as a new Login item.
    4. Reload the page and see if the new Login item is suggested. If it is, that item should work on your Android phone as well.

    Let me know how it goes. :smile:

  • LarryMcJLarryMcJ Senior Member
    edited February 12

    Thanks. While this procedure works, it presents some issues perhaps you could explain.

    1. The login you use in item (1.) above is different from the actual login URL captured by the browser. The original login URL is still what the browser displays if yoiu click the "Sign In" button on the AnyList website.

    Yours: https://www.anylist.com/auth/sign-in?next=/account
    Original: https://www.anylist.com/auth/sign-in?next=/account

    1. When using the altered URL you provide, I lose the rich icon I previously had with the actual login URL of the site's sign in page (see attached screenshot from 1Password.com. I tried using your URL with the original login and it simply changed that icon to the generic one. Any way to fix this? Thanks!

  • kaitlynkaitlyn

    Team Member

    I can't tell if I'm just missing something, but the two URLs you provided look the exact same on my end. Could you point out the difference that you're seeing? Perhaps you're referring to the %2F that replaces the /. That's the only difference I can see between the URL you posted and the URL I have saved in 1Password. %2F is the URL encoded value of the forward slash, but that shouldn't make a difference when it comes to rich icons. Do you recall adding the AnyList rich icon manually to your previous item? I've got an issue filed in reference to adding the AnyList rich icon, so that should be fixed soon.

  • LarryMcJLarryMcJ Senior Member

    Hi, Kaitlyn! The original URL (with the %2F) is the URL that I've used for this site for the past 7-8 years. It has always worked fine and has always had a rich icon. A few months ago I gave up on Apple and started using a Pixelbook (with 1Password X) and a Pixel phone and that's when things went south with the original login URL not working.

    Also, I specifically posted two different URLs above in my previous text, but I see the %2F was replaced by the / by your forum software.

    The loss of the rich icon just started today when I stopped using the login URL that has been in 1Password for this site for all those years and changed it to the login that @ag_sebastian suggested earlier in this thread. Even though the rich icon doesn't work with this URL, the favicon appears on the login page but just doesn't work in 1Password anymore.

    Thanks for your help!

  • ag_sebastianag_sebastian 1Password Alumni

    Hi @LarryMcJ,

    I'm not entirely sure where you got the previous rich icon. Considering your Login item was added such a long time ago, it's possible that we previously had it somewhere and it just stuck. Either way, we've just added the real Anylist rich icon. You should see the change in a week or so, because it takes time for the change to propagate. Thanks for your report!

  • LarryMcJLarryMcJ Senior Member
    edited February 13

    Thanks, I'll watch for the new icon. The developer told me the icon was from their earlier site anylistapp.com and now it's anylist.com.

    In my 1Password login should I use the / or the the encoded %2F? On their site the last forward slash in the login page URL displays as %2F.

  • ag_sebastianag_sebastian 1Password Alumni

    @LarryMcJ Ah, that explains it! :)

    The URL shouldn't matter too much in this case, but please note that the URL I gave you was also converted by our forum, and it did display as %2F on the page as well.

  • LarryMcJLarryMcJ Senior Member

    I see the new AnyList rich icon in both 1Password X and my 1Password.com account. But it's still not displaying in the latest Android version 7.1.1. Is that normal?

  • beyerbeyer

    Team Member

    @LarryMcJ: I had to check with some of my Android friends here to confirm and from what I hear it does sound like it may be normal. 1Password for Android caches Rich Icons to help save mobile data. As far as I can tell, this cache can't quickly be cleared and would require a complete reinstall of 1Password on your Android device. I'd like to see that changed in the future, so we've opened an issue on your behalf, and hopefully, the Android team can add a nice way to update Rich Icons. ❤️

    Cheers,

    Beyer

  • LarryMcJLarryMcJ Senior Member

    Thanks, @beyer. That worked...I uninstalled/reinstalled and the AnyList rich icon now displays.

  • beyerbeyer

    Team Member

    @LarryMcJ: Great! I'm glad that worked, but we will try to make that better soon.

    I don't it's a tad early, but I hope you have a wonderful weekend!

    Cheers,

    Beyer

  • LarryMcJLarryMcJ Senior Member

    Thanks @beyer. In the end, I solved all my 1Password problems by simply trading in my Pixel 3 XL and Pixelbook on an iPhone XR and MacBook Pro. Now everything works fine again and I'm back in an ecosphere in which I feel comfortable again :)

  • I have to admit Apple stuff works for me so I'm quite happy to continue using it. It was certainly an interesting time with the Chromebook that you had.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file