1Password extension no longer works after Chrome update

Chrome for Windows automatically updated to v72.0.3626.96 and now 1Password extension no longer works. No error messages, it just won't open 1Password nor prompt for saving a new password. I have uninstalled and reinstalled the 1Password extension but it still doesn't work.


1Password Version: 4.6.2.626
Extension Version: 4.7.3.90
OS Version: Windows
Sync Type: local

Comments

  • GregGreg

    Team Member

    Hi @Kelvin,

    Thank you for reaching out!

    Google has updated the code signature in Chrome 72, so 1Password 4 for Windows will not work with it. Please check this reply from Kate about this situation.

    If you want to use 1Password 4 for Windows, you can switch to a different supported browser, 1Password extension should work there. However, I would recommend you to take a closer look at 1Password 7 for Windows:

    Get to know 1Password 7 for Windows

    Let me know if you have other questions. Thank you!

    Cheers,
    Greg

  • res1492res1492
    edited February 7

    So what your saying is .."Google has updated the code signature in Chrome 72 and we can't be arsed updating 1password 4 because we have sucked all the money we're gonna make out of that version....Thanks for being loyal and sticking with us but now we're gonna take a dump on your head"......I'm sure there is a way to keep 1password 4 chrome extension working, and don't blame google chromes updates...you don't seem to have any problems making 1password 7's browser app work with the update....i have been with you guys since the very start and this kind of "Reward" makes me sick...disgusting!!

  • I am disappointed that 1Password no longer works on Chrome and there does not appear to be a plan to correct this.
    I tried switching to Internet Explorer 11, and have the add-on enabled and the icon appearing on the Command Bar, however this also does nothing when clicking the icon. The shortcut Ctrl + \ does not work either. This makes 1Password virtually useless.

  • res1492res1492
    edited February 7

    Kelvin, I have switched to firefox, you can import all your bookmarks from chrome to it too...in the long run im going to be looking for a new password manager though.
    Let me know if you need help

  • Does that mean, you won't fix the extension?

    I don't want to switch to 1Password 7 as the data is no longer stored on my local machine. Or am i wrong here?

  • haematom no you can make a vault "on this PC"...local storage

  • res1492 ... thanks for the info .. then i will hava look at 1pw7

  • res1492res1492
    edited February 7

    Don't quote me word for word as I have only been using 7 since 3 pm today.

    The setup is nowhere near as "smooth" as 4 but its still pretty self explanatory if you just stop and think before pressing buttons.

    Just pick "open a vault on this pc" and highlight your 1password "1Password.agilekeychain" folder, press select folder and it will do the rest...if you have a lot of logins like I have (700) don't panic ...it takes a while to convert them to the new vault system but in the meantime you don't get a progress bar and I thought I was going to lose everything

  • bundtkatebundtkate

    Team Member

    Thanks for hopping in here @res1492! @haematom, res here has covered everything I would at the outset, but if you decide to upgrade and need a hand, I'd be happy to help. :chuffed:

  • Thanks @bundtkate and @res1492 ... i upgraded to 7 and my local vault was converted without a problem and is still local.

  • bundtkatebundtkate

    Team Member

    Delighted to hear it, @haematom! Enjoy and if I can do anything else to help as you get to know the new app, just let me know. :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file