My router has a self signed cert, and I can't use 1passwordX in chrome to fill the login.

The title mostly covers it but ...

My router uses a self signed certificate, so my browser thinks it's an invalid site. (I understand why that happens, that's fine)

How can I tell 1passwordX that I know the cert is considered invalid, but to fill in my username and password anyways?


1Password Version: Not Provided
Extension Version: 4.7.3.90
OS Version: Windows 10
Sync Type: Not Provided
Referrer: forum-search:invalid certificate

Comments

  • BenBen AWS Team

    Team Member

    Hi @sloot

    1Password doesn't pay any attention to what certificate is in use by a website. Your browser may warn you about it, but that won't prevent 1Password from filling. If it isn't filling the login page for your router that'd be caused by something other than a self signed certificate. Have you tried saving a new login item for it using 1Password X?

    Ben

  • I just tried that, and it still didn't populate.
    One thing that I forgot to mention in my original post is that the 1password plugin brings up the popup to fill in the username and password, but when I click on the account, it doesn't fill in the fields.

  • Hi @sloot,

    It could be the issue is quite specific to this page. Maybe somebody here at 1Password has the same router or a router from the same family and we can test. Can you let us know the make and model please and we'll see if we get lucky.

  • slootsloot
    edited February 12

    sure. it's a Edit: Redacted

  • Hi @sloot,

    I've asked amongst the team, now to see if anybody comes back with a yes.

  • 👍🏻

  • Hello @sloot,

    Sadly no joy yet. It makes it tougher given this is only a page reachable by owning the correct brand/model of router.

    Can you try saving a new Login item on the page using the inline menu. If you reload the page and attempt to fill with that new item do you see any change in filling?

    If that doesn't fare any better, can you create a Login item outside of the 1Password X extension. One way is in the native 1Password for Windows application if you have it installed. If you don't another way is to click the 1Password X button in browser's toolbar and in the toolbar interface click the + New Item button. This will open a new tab and place you in the 1Password account web interface where you will need to copy and paste the username, password and URL for the router. Does this item do any better/different from the previous Login items?

  • slootsloot
    edited February 11

    Thank you
    a) do you have the capability to delete my comment above with my router model? seems like the type of thing I shouldn't post on a public forum (in case it has a vulnerability)
    b) what do you mean by "inline menu"?
    c) might it help if I posted the html of the login page somewhere?

  • ag_sebastianag_sebastian 1Password Alumni

    Hi @sloot,

    a) I went ahead and removed the router model from the message. :)
    b) Inline menu is the 1Password menu that shows up on an input field of a website. You can access it if you click the 1Password icon on the field > Three dots (to access more options) > Save login. Please note that you have to type in your credentials before clicking Save login.

    c) It might help us understand why 1Password isn't filling, but if you can, please try manually saving first, just as @littlebobbytables suggested. :)

  • I created an entry in 1Password for Windows. Still won't fill.
    I created an entry using the 'inline menu'. Still won't fill.
    I saved the html login page to an S3 bucket and added that URL as a website for one of the existing 1Password entries, and it filled successfully.

    As a reminder, 1PasswordX knows that the entries are there, they show up in the dropdown, but when I click them it doesn't fill in.

    The only other thing that I don't think I've mentioned is that it is an IPv6 style address for the router's login page ( https://[::ffff:c0a8:501]/blahblah ). I enter an IPv4 address into the address bar, and it redirects me to the IPv6, so I can't attempt to login using IPv4.

  • BenBen AWS Team

    Team Member

    The only other thing that I don't think I've mentioned is that it is an IPv6 style address for the router's login page ( https://[::ffff:c0a8:501]/blahblah )

    Ah. That's the problem. :) We have a bug filed w/r/t IPv6 addresses. Hopefully we can get that fixed up soon. In the mean time if the router offers any option to disable the redirect so the page can be accessed with an IPv4 address that should allow you to fill it (unless there do also happen to be issues with the form).

    Ben

    ref: apple-3081

  • EXCELLENT! At least we know the reason. Sorry for not specifying that earlier.

    What is the expected timeline for that bugfix?

  • Hi @sloot,

    Honestly, if our positions were reversed I wouldn't have thought to mention the URL was using an IPv6 address either. After all why should that matter? The bug is limited to IPv6 addresses as some code is stripping the [ and ] from the URL and they are needed for things to work. Hopefully it won't take us too long to fix.

  • 👍🏻

  • BenBen AWS Team

    Team Member

    :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file