Popup is blank in Firefox private browsing with normal history / privacy settings

There's a sticky thread that says 1PasswordX shows a "blank page" in Firefox private browsing mode with certain settings. Assuming "blank page" means the popup is a white square, I'm experiencing that as well.

The sticky says it can be caused by either of these settings:

Never remember history
Always use private browsing mode

But my browser doesn't have those enabled. My "History" settings are as follows:

Firefox will Use custom settings for history

[OFF] Always use private browsing mode
[ON] Remember browsing and download history
[OFF] Remember search and form history
[OFF] Clear history when Firefox closes

The "Content blocking" settings are set to the default that the browser ships with: "Standard - Only blocks known trackers in Private Windows"

I think it's worth noting that the extension still works (the 1P icon appears in text boxes and I can still fill forms from there, but the popup won't show).

Let me know if you need any more info to diagnose this issue. I'd love to get it resolved soon; it's become a hassle to log into various hub-type websites, lol.


1Password Version: 7.3.657, but it's not even running
Extension Version: 1Password X 1.13.2
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • Hello @marshall_stacks,

    So just to make sure I'm following correctly, the inline menu will display, show the correct matches and allow you to fill but clicking the 1Password X button in the Firefox toolbar garners zero response.

    This is what I see if I try to access 1Password X whilst in a private window and is what I believe we're referring to in that thread.

    Is the issue happening everywhere or do you see it occur with certain sites? I'm just wondering if there is something we can do to try and reproduce whatever you're experiencing as it isn't something I've come across yet (I think anyway).

  • Hi, your screenshot shows what I'm experiencing here. So technically not "garners zero response" but rather the popup is just a white square like I said. It happens on every site as far as I know. Let me know if you need more info from me!

  • ag_sebastianag_sebastian 1Password Alumni

    Hi @marshall_stacks,

    Firefox doesn't support the extension.getBackgroundPage() API we use in Private Browsing mode. It looks unlikely that Mozilla will change this restriction (which isn't an issue in Chrome), so we will have to work around it on our end.¸We have an issue filed for this, I don't see us getting to it any time soon, as it would require fundamental changes to how things work.

    Is 1Password X working in a normal, non-private window?

  • It works fine in non-private windows. I guess I was just confused by the sticky thread saying "blank page" and making it sound like it would work with certain history settings. If it's just a consequence of Firefox's pitiful webextensions API support, then I'll just suffer with it. Using Firefox in 2019 is all about suffering :P Cheers

  • beyerbeyer

    Team Member

    @marshall_stacks: We can't support using 1Password X in Private Browsing on Firefox with our current method of communication between the popup (what you see as the white screen) and the background page (where all the heavy lifting is done for everything from database transactions to opening new tabs). We've known about this for some time and up until recently held off fixing it because frankly, it's a lot of work. However, the good news is we are finally at a place where we are making some significant improvements that will require and facilitate the changes needed to make Private Browsing work in Firefox. I honestly can't give you a firm timeline on when these changes will be complete, but it is coming so please stay tuned for updates! ❤️

  • It's all good, Firefox is a disgrace :lol:

  • ag_sebastianag_sebastian 1Password Alumni

    @marshall_stacks Well, all software has areas that could improve. Good thing is there are usually plenty of options, and we're able to use what we like best. :)

  • Hi all! I had the problem with a 'blank window' appearing when I clicked on the 1Password extension in Firefox in Private Browsing quite a while ago and it drove me crazy trying to figure it out. I realized that I can't live without that 1PW extension!!!

    I remember spending hours looking thru the Support Forum threads and trying all of the solutions with no relief. Finally I found a reply to another poster from a 1Password Team member that was so simple and worked. Yay!

    .... Until a few days ago when it happened again, and life sucked once again. :( I could NOT remember what I had done last time and proceeded to waste a ton of time trying the various possible solutions.

    Today I found an old post of mine from long ago thanking a Team Member for his suggestion. Feeling pretty dumb, but so glad that this worked for me. Again!

    All I did to fix the problem was to delete the extension and to reinstall FROM THIS LINK: https://1password.com/downloads/windows/#browsers

    Adding the extension from my browser (Firefox Quantum 65.0.2 (64-bit)) did not work. Must use the 1PW download on their site.

    So happy that the solution was simple and hoping this will work for others having the 'blank window problem' as well!

  • Greetings @ssdore,

    I'm seeing more than one separate issue being reported in the thread you linked to and reinstalling the extension shouldn't impact the blank window in private mode as that issue is one at the API level. My suspicion is you're experiencing a separate issue.

  • mattn8mattn8
    edited March 12

    I am having a similar issue except when I click the icon I get a blank tab that opens and that is it. Not in private browsing or anything like that. All default normal settings in Firefox.

  • ag_sebastianag_sebastian 1Password Alumni

    Hi @mattn8!

    Please try the following and let us know how it goes:
    1. Sign out and sign back into your account on 1Password.com.
    2. Reinstall the add-on.

  • Following up, in case anybody is searching for this specific problem as I was: 1Password X works in Firefox Private Browsing as of version 1.15 :chuffed:

  • kaitlynkaitlyn

    Team Member

    Hi @marshall_stacks – I just tried this out on my Mac, and I'm still seeing the same behavior when Private Browsing is enabled in Firefox. Could you let me know what version of Firefox you have installed?

  • I'm on Firefox 67.0 / Windows 10; it actually just updated yesterday so it was working in 66.x as well.
    If I clear my cookies (which reverts the extension to the old design, with the prompt to upgrade to the new design), it doens't work anymore (meaning the popup box is blank). If I do that upgrade (from a non-private window), then the new design works as expected in both private and non-private windows :)

  • kaitlynkaitlyn

    Team Member

    I'm still having trouble reproducing this, @marshall_stacks. Just to double check – do your Firefox settings (I searched for "private") look the same as mine after you've already enabled the new popup design?

  • Nope! My settings are still the same as in the first post in this thread. I'm not always using private mode; I have the default settings, except I've disabled "Remember search and form history"

  • kaitlynkaitlyn

    Team Member
    edited May 30

    I see! Thanks, @marshall_stacks. I got word from our developers, and things have changed a bit in the redesigned popup. We're no longer using extension.getBackgroundPage() as Sebastian mentioned previously. Now, the core issue is that extensions can't access IndexedDB in Firefox private browsing mode, which B5X relies on to function.

    That being said, if you unlock 1Password X in a normal window, then switch to a private window (as you mentioned), you'll be able to use all parts of 1Password X that don't require talking to the database. I hope that clears things up a bit, and I'm sorry for any confusion!

    For anyone else reading this, this only applies to the redesigned popup in version 1.15.0+.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file