Browser Plugin Error

Receiving the error from Safari browser extension:

Safari can't open "onepassworld4-extension://activate/Safari" because OS X doesn't recognise Internet addresses starting with "onepassword4-extension:".

Using 1Password Version 3.8.22 and getting an update error.

On Sierra 10.12.6


1Password Version: Version 3.8.22
Extension Version: (build 32010)
OS Version: OSX 10.12.6
Sync Type: Dropbox

Comments

  • rudyrudy

    Team Member

    @noise17,

    I believe this is because you're trying to use the 1Password 4 extension with 1Password 3, I'm fairly certain that the two are not compatible and that you would need to use 1Password 4 or 6 in order to use the browser extension you have installed. In all 3-6 are no longer being developed so you might consider taking a look at either a standalone license for 7 or our 1Password.com subscription going forward.

  • noise17noise17
    edited February 12

    I haven't (manually) updated the browser extension. It just stopped working. I really don't want yet another subscription. I'm having trouble finding anything telling me about 7 or price and the application I'm using is giving me an update error so there's no path to move forward there. It's not really mentioned on the site and all-in-all makes it look like that's not supported either so its either subscription or see ya.

    Been using 1password since at least 2009. Loved it so far because it keeps out of the way and just works.

  • BenBen AWS Team

    Team Member

    @noise17

    Sorry for the delay here. You can learn more about 1Password 7 here:

    1Password 7 for Mac: The Best Ever | 1Password

    We are no longer advertising licenses. I'd really highly suggest at least considering the membership route. You can read more about the advantages of that here:

    About 1Password membership

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file