Master password required when using in app / autofill

narindonarindo
edited February 10 in iOS

Ok,

So when I restart my phone, and go into for instance safari and use the auto fill option within safari which prompts 1password. Because I haven’t use 1password yet, it will ask me to input the master password.

However, it keep asking me the master password every consecutive use until I open 1password app itself and input it there, then every consecutive use (in a app or 1password) will then provide thee much more easier Touch ID as authentication.

Is this a security feature or a limitation or ...?

Bit annoying though!

Comments

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @narindo ,

    When you tried to open 1Password in Autofill, it defaults to Master Password, but there should have been a TouchID button right below the Master Password field. If you press that it should prompt for TouchID. The next time you restart your phone, give that a try, and let us know it goes.

    Thanks,
    Kevin

  • brian67brian67 Junior Member

    Same problem, but with the new 2018 ipad pro. There is no touch id button, or face id action to reopen 1 password so the master password has to be entered for every new login. Frustrating.

    Thanks
    Brian

  • brian67brian67 Junior Member

    Ah! the 1Password app has to be running and signed in and then face id pops to confirm the login on other site logins.

  • brian67brian67 Junior Member

    ... and in Settings in the app, Face ID must switched on. Found under under Security.

  • narindonarindo
    edited February 12

    @ag_kevin thanks for reply.

    Well, there is no Touch ID at all. What @brian67 says is a different issue than mine. I made screenshots to explain. You can see the screen I get when I tried to log in into this forum.

    So again:

    1) clean start, restarted device (iPhone 7 plus)

    2) open safari

    3) go to this forum and click login

    4) keyboard appears with autofill from 1password

    5) 1password appears requesting master password (no Touch ID icon to be found!)

    6) successfully unlocks and successfully auto fill

    Until here it goes as desire.

    7) open another website on safari and then step 1-5 appears again. I preferred to have step 5 requesting Touch ID. (See below my fourth screenshot which is similar as the one above one)

    This issue has been happening already for months, not sure whether that was there before that. Also, to remedy the issue, I need to pen 1password directly and fill in the master password there, THEN any subsequent autofill within safari for example will only request Touch ID.

    Could you not try this on a similar setup?

    1password v7.2.7
    iPhone 7plus iOS 12.1.3 (16D39)

  • Hm.. @ag_kevin . I wrote a while post and edited afterwards, it seems to be gone. Hm.. will rewrite, hopefully it doesn’t appear double.

    Ok

    A) I don’t have any issues with Touch ID on 1password. Whenever I open the 1password, after singing in once with the master password it never fails to request Touch ID. It works as advertised, been using this for years now.

    B) the issue is when you do not use the 1password app to fill in the master password, but through autofill (example using safari). It will always ask for there master password and doesn’t offer you Touch ID until I do above in A (open the app directly).

    So...

    Autofill screen shot

    Then this appear

    I fill in the master password and successfully unlocks

    But here is the issue, when I use autofill again on the same or other sites, it does this:

    So it request the master password again without enabling Touch ID. The only remedy I found was to go to 1password app directly and fill in the master password again, then the autofill will also offer Touch ID as the first option. This is the question I have.

    iOS 12.1.3 (16D39)
    1password 7.2.7

    Hope you can check for me!

  • BenBen AWS Team

    Team Member

    Hi folks,

    Yes, that seems to be working as designed.

    Ah! the 1Password app has to be running and signed in and then face id pops to confirm the login on other site logins.

    Correct.

    ... and in Settings in the app, Face ID must switched on. Found under under Security.

    Yes, also correct (or in the case of Touch ID enabled devices, Touch ID must be enabled).

    the issue is when you do not use the 1password app to fill in the master password, but through autofill (example using safari). It will always ask for there master password and doesn’t offer you Touch ID until I do above in A (open the app directly).

    Yes, you have to unlock the main 1Password app once using the Master Password in order to enable Touch ID / Face ID. I will check with the development team to see if there is any way with the Password AutoFill framework that we can improve this, but it does sound like it is working as intended at the moment.

    Thanks!

    Ben

  • @ben thanks. Hope it is dineer possible Some time the future to unlock already with autofill!

  • BenBen AWS Team

    Team Member

    :+1: :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file