Authentication required causes filtering to fail

Hello,

Drop down notification banner:
"Authentication required
Tap to enter your two-factor code"

I'm frustrated with this notification in the iOS app every time I'm sent to 1Password app after clicking on the auto fill passwords section in the bar just above the keyboard. (I think that may be called the password keychain section.)
Interestingly it does not require one to click the banner notification to enter the 2FA code either and once the banner is gone I can search as normal to get passwords but with the message I always have to search for the app that needs the password as it never pre filters the search to the correct app. The message appears everytime I access the 1Password app no matter whether I click the banner
or dismiss the banner.

Yes I have two factor authentication enabled on my 1Passwird account and I also have touch ID enabled upon every login.

Please advise if there is a solution.

Comments

  • To add additional functional information as to why the banner appears to be of no benefit is:
    1) when redirected from the third party iOS app to 1Password it asks for a touch ID confirmation to open it the first time at which time it presents this banner imposed on the selection screen one would choose the correct entry to use to auto fill.
    2) if I click the banner it redirects me back to the 1Password app by opening it a second time and I need to provide a second touch ID upon the opening of the 1Password app a second time, but no 2FA. Upon the second time opening I'm looking at a generic 1Password interface instead of the customized auto fill credentials selection box.
    3) if i dismiss the banner (or wait for it to auto dismiss) then I have to search for my desired credentials in the customized auto fill credentials selection box.

    So the big question is, what is the point to it other than to be annoying as it opens it a second time and losses the customized clean auto fill filtering window?

  • For additional clarity:

    I've just realised that the first auto fill screen which presents this banner is an overlay on the third party iOS app for selecting the credentials.
    If it's an overlay why can't it filter down to the right credentials based upon the app information it is overlaying immediately for selection?

    The second opening if one clicks the banner is the opening of the actual 1Password app and it airs all information is lost as it turns into a copy and paste exercise, rather than and auto fill.

    This experience is also somewhat new as it didn't used to do this in prior versions, such as the first releases of the auto fill feature.

  • ag_andrewag_andrew

    Team Member

    Hi @evertb,

    This is a bug that we thought we had squashed, but it looks like you may have been bitten by it.

    When the 1Password AutoFill interface opens, we try and sync your 1Password.com Account(s). What appears to be happening to you is that the sync is failing due to a 2FA handshake not completing properly.

    What should happen in that case is that you tap the banner (which will launch the 1Password app), unlock, and then enter your 2FA code. However for some reason, 2FA is failing in the AutoFill extension and not in the app itself.

    To dig into this further, I'd like you to reproduce the issue (and note the day/time) then I'd like to ask you to create a diagnostics report from your iOS device so I can look at the 1Password logs to see if we can pin-down where this is going wrong for you. (This is where the day/time will help, I'll look at the logs around that time)

    Sending Diagnostics Reports (iOS)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: url
    • Your forum username: username

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Hopefully we can get this sorted out for you quickly, because obviously this is an annoying issue.

  • evertbevertb
    edited February 11

    Hi
    Automated rely case [#LMK-98922-248]
    This issue happens everytime I try to provide passwords for a third party app by clicking the "password" keychain section which is offering a password.
    I did it and then created the log file. So the time is right now. 9:35am. I also did it yesterday several times while typing my posts so you can look at those time stamps as well.
    I would guess the issue is easily replicated yourselves as it happens every time. Simply open a third party app, click to get a password and bingo you'll See it.

    @ag_andrew they were clear instructions however that was a lot of instructional steps to try and tie this together. As a suggestion a simpler method should be revised such as:
    1) allow uploading diagnostic reports to the forum in private for support.
    2) provide a support ticket number to include in the subject of the diagnostic email.

    As a general experience of support with 1Password I believe there is hugh room for improvment. When I tried email support last time it took weeks, so this time I tried the forum at which I had to create an account and I did get my first response from you within 24 hours but this lack of integration is disappointing.

    May I suggest the main support option being suggested and monitored be a direct email communication from the help section within the app that automatically includes the diagnostic report you are looking for and provides the user a direct email support method that is monitored as diligently as the forum.
    Then you can create relevant forum topics yourselves for people to read like an FAQ section of which people can reply. Activity would keep the topic as a current issue.

    In case your wondering, Yes I very much like 1Password.

  • ag_andrewag_andrew

    Team Member
    edited February 11

    Hi @evertb,

    Thanks for sending in the Diagnostic Report, I'll take a look.

    And thanks for the support suggestions. We're always looking for ways to improve our support flow, but those need to be implemented against our stringent privacy and security rules, so changes can take some time.

    I'll respond to you via email to follow up on your diagnostic report.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file