Autofill is using old vault

Hi! I'm using a standalone version on iPhone (7.2.7) and Mac (6.8.9) and sync is via iCloud (but no difference when using WLAN sync). However, I have activated autofill but when trying to using it, it shows me an old vault for some reason. Of course I tried to reset iCloud data (via 1Password app and iCloud options directly) and I also created a new vault with new master password but it still shows me an old vault?
Any ideas/tipps are really appreciated!
Thanks!


1Password Version: 6.8.9 + 7.2.2
Extension Version: Not Provided
OS Version: MacOS 10.14.3 + iOS 12.1.4
Sync Type: iCloud

Comments

  • ag_andrewag_andrew

    Team Member

    Hi @T_o_m,

    Are you seeing items you don't expect show up in the QuickType bar above the keyboard? Or are you seeing these unexpected items when you tap the Key icon in the QuickType bar, then tap "1Password..." and are then shown the 1Password interface?

  • Thank Andrew for your answer! Yes, I tap on the "password" sign, choose 1password which will be unlocked and then there are an old vault with old passwords (most of them) and new ones are missing.
    But I was able to resolve it in the meantime! I deleted 1password completely including iCloud data, re-installed it and re-created it with a new master password. After one test entry and re-activating iCloud sync it was working again. Then I imported my passwords from a backup I made before. Some strange behaviors during this (after sync all items was just called "unnamed"; just 43 items were synced instead of 61) but in the end it was working again.

  • BenBen AWS Team

    Team Member

    Thanks for the update @T_o_m. At present it is expected that the 1Password screen within the Password AutoFill feature shows results from alL vaults (it does not respect the 1Password "All Vaults" exclusion settings). That is something we're looking to improve for the future. The results shown on the QuickType bar _should respect those settings and only show results from vaults you have shown in your "All Vaults" view. Does that explain what you were previously seeing? Just to be clear: everything seems to be working now? Is there anything else we can help with?

    Ben

  • Hi! First of all I really appreciate your support! Many thanks!!

    I just recognized it just shows „Login“ passwords and not „Server“ passwords? Can this be changed somehow? I‘m using a Synology app and the passwords for it are stored as „Server“ passwords in 1password and therefore it can be acces via autofill function. Am I right?

  • BenBen AWS Team

    Team Member

    Hi! First of all I really appreciate your support! Many thanks!!

    You're very welcome @T_o_m.

    I just recognized it just shows „Login“ passwords and not „Server“ passwords? Can this be changed somehow? I‘m using a Synology app and the passwords for it are stored as „Server“ passwords in 1password and therefore it can be acces via autofill function. Am I right?

    I don't believe we currently share Server items with the Password AutoFill function but I'll be happy to pass that along as a suggestion to the development team.

    Ben

  • Many thanks Ben!

  • BenBen AWS Team

    Team Member

    You're very welcome. :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file