Not being prompted to save login details on new sites

Ind3XInd3X Junior Member
edited February 13 in Mac

I've noticed recently that 1P is not offering to save logins when I sign up to new sites. This is occurring in v7.2.4 and also the latest v7.2.6.BETA-0. I believe this has been happening since I've started to use the internal password generator more (I used to use a 3rd party generator) and never had this issue, though this could be unrelated.

My workflow:

  • At the signup page, complete sign up info.
  • CMD + Option + \ to open 1P mini & generate password / click 'fill'
    **At this stage the password is saved in 'generated passwords', but no prompts to save any login details have occurred.
  • Sign out of site & go to login page
  • CMD + \ to open 1P mini and fill the generated password
  • Manually fill in my email address / username.
  • Login
    **At this stage, there is still no prompt to save the login details as a login item. I am forced to go into 1P and 'convert to login' and manually fill in the missing details.

I've restarted my browser (Safari 12.0.3), updated from 1P v7.2.4 to the latest beta and followed the info here, no change.

Has there been a change to how detecting of logins work / is this a bug / or something else (user error) ???


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • LarsLars Junior Member

    Team Member

    @Ind3X - I'm sorry for the trouble. I doubt this is related to using 1Password's generator instead of a 3rd party version. This is the recommended method for saving a login using 1Password for Mac. There are occasionally Login pages that give 1Password trouble, but they should be uncommon, which means that if you're trying the above and still reliably not getting prompts to save newly-entered login items, then something else is wrong with your specific setup. What specific version of 1Password extension do you see in Safari's Preferences > Extensions?

  • Ind3XInd3X Junior Member

    Hi @Lars

    I'm using the extension that is bundled with the application (not one that is downloaded from the Safari extensions gallery). The extension versions have matched the main application versions mentioned in my original post.

    I read through the page you linked to, which has prompted me to remember that I have removed the Safari toolbar button recently too, I never use it as I always use keyboard shortcuts, and I like to keep my browser window tidy, without excess buttons). Could this be a possible issue?

  • LarsLars Junior Member

    Team Member

    @Ind3X - it depends on how you removed it, and what you removed. You should check within the main 1Password 7 for Mac app to make sure that in Preferences > Browsers, the "Always keep 1Password Extension Helper running" button is checked, as well as the "Detect new usernames and passwords, and offer to save them" button. Are they?

  • Ind3XInd3X Junior Member

    I literally just removed the icon from the Safari toolbar to clear space. Both of those options are still checked..

  • mxclmxcl
    edited February 16

    I have the same problem, I have the Mac App Store version of 1Password installed and use Mojave & Safari, the extension is “inside the app” or at least this is what Safari says when I try to remove it in Safari preferences.

    When signing up to new sites I use ⌘\ and then “Password Generator”, then “Fill”, 1Password remembers the generated password in its history but doesn’t prompt me to save the sign-up.

    1Password 7
    Version 7.2.4 (70204001)
    Mac App Store

    Hope you can fix as this is fundamental functionality and makes me feel a little unhappy about paying you a monthly fee quite frankly :/

  • Corey_CCorey_C

    Team Member

    @mxcl Just as a quick check, is the 1Password 7 extension in Safari enabled? As in, is the box checked? Also, does this happen on all sites or just specific ones?

  • mxclmxcl
    edited February 20

    It’s enabled. All sites.

    I had two accounts in the settings, one frozen, one active. When I removed the frozen account it started prompting me to save passwords again.

  • Corey_CCorey_C

    Team Member

    @mxcl Yeah, that would do it. The frozen account would prevent any browser functions from working.

  • The frozen account was from a client, I can't help that they didn't pay.

    I was paying for my account though, and accordingly expected the functionality I am paying for to work.

  • Corey_CCorey_C

    Team Member

    @mxcl Having a frozen account connected to the app takes precedence. As you said things started working again once you removed it.

  • It took me three weeks to figure this out, and I got there through coincidence, may I recommend you show some kind of warning or error message for anyone unfortunate enough to end up in this situation in the future. Thanks.

  • Corey_CCorey_C

    Team Member

    :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file