Trouble installing browser extension for Firefox (1Password 6 for Mac)

This discussion was created from comments split from: 1passwordX doesn't unlock correctly on new firefox 65.

Comments

  • Hi Ben! Thank you for your prompt reply. I wanted the stand alone extension that I've always had for Firefox, but when I go to install it, it says it can't install because of a connection issue. Can you help with this? I've tried several times. Maybe it's a problem in my Firefox Browser settings. Thanks a million.

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @dontrepeat! I hope you don't mind; we've split this request off into its own thread, since it didn't really have anything to do with the topic of the original thread.

    Can you tell us a bit more? What sort of "connection issue" are you having? What's generating this error message -- Firefox? 1Password? macOS? Can you take a screenshot of the error message and include it in a reply here? Thanks! :)

  • Hi Lars! Thank you for your response. I solved the problem. It required me downloading the stand alone extension from another browser ( I used Safari) and then installing it to Firefox 65. I found the answer somewhere in this forum by accident and it worked, so I am back in business. Thank you again for your quick response. Hope this solution will help other people having the same issue.

  • LarsLars Junior Member

    Team Member

    @dontrepeat - you're quite welcome! I had a hunch that might be the case, but I always prefer not to make too many assumptions if we don't have all the facts. Glad to hear you solved things all on your own. :)

  • edited July 30

    Hi Lars,

    I just switched computers and I am now running High Sierra on an iMac using Firefox 68.0.1

    When I downloaded the 1Password extension from Firefox it no longer works to ask me if I want to save passwords when I go to websites.

    I started a completely new 1 password database from the beginning, although I saved all my previous BackUps from my old machine.

    Am I doing something incorrectly?

    Please advise.

    Thanks a million.

    PS - Do I need another "Stand Alone Extension" from another Browser?

  • Greetings @dontrepeat,

    If when you click the 1Password button in the Firefox toolbar 1Password appears and correctly shows you a match, assuming one exists, then that would indicate the extension at least has a good connection to the native 1Password application.

    Can you let us know what version of 1Password for Mac you have installed please and if you know if you have either a 1Password account or have purchased 1Password in the past. If you have purchased 1Password do you happen to have a record of whether you purchased it directly from us, so you should have been sent a receipt or if you purchased via the Mac App Store. If we know when you made the purchase as well we can determine what licence you have.

    I suspect 1Password may be in read-only mode as that would mean 1Password would not prompt to save. The above information will either confirm or eliminate that as a possibility and we can decide what the next best step is to troubleshoot the issue.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file