Extension size in chrome

2

Comments

  • ag_yaronag_yaron

    Team Member

    I Always use ⌘ + and ⌘ -, very strange that it is different between platforms. Thanks for filing the issue! :chuffed:

  • Back in town. Tried most of the suggestions here. Bottom line is if chrome is set to anything above 100% as default I get the zoomed extension window with non working sliders.
    Something must have changed with chrome to cause this (no surprise, they like screwing with it) to suddenly happen.
    I give up. Since I now primarily use Vivaldi I will just deal with it fro the few sites I use on chrome.
    Thanks for your help.

  • brentybrenty

    Team Member

    Likewise, thanks for the update! We'll continue to investigate and see if there's something we can do to work around this behaviour. :)

  • I recently had this problem. The 1PasswordX Chrome extension window was always showing zoom 150% even when i reduced Chrome default zoom to 100% or less.
    I uninstalled the extension. shut down Chrome and restarted it.
    I reinstalled the extension and found that when I logged in again (after typing the password which the extension asks for the first time), the initial welcome page was at 150% zoom.
    I reduced it to 100%.
    After this, the extension popup window reverted to default zoom of 100%.

  • kaitlynkaitlyn

    Team Member

    Thanks for sharing your experience, @Satyajit! We're aware of what's going on, and we'll continue to investigate as Brenty mentioned. :)

  • trivigytrivigy
    edited November 2019

    @Satyajit Not sure what system you are working on. I tried your recommendation and it doesn't seem to work. As a comment to another duplicate discussion happening on a different thread () the solution there, and all the solutions suggested so far, stopped working after chrome migrated to api v2. In particular: the migration from extension://[extension-id]/popup/popup.html to chrome-extension://[extension-id]/popup-v2/popup.html.

    Would greatly appreciate any kind of recommendations on how to solve it. One potential solution that comes to mind is making sure to properly configure the <meta> element of the popup.html header. <meta name="viewport" content="width=device-width, initial-scale=1"> (https://developer.mozilla.org/en-US/docs/Mozilla/Mobile/Viewport_meta_tag). I tried doing some of this manually via inspect but did not apply. Could be because that configuration is taken during loading and does not re-render after manual manipulation. I don't know. As I said, any advice is highly appreciate because this issue is directly client facing and has existed for at least since February 15 when the first reports came in.

    EDIT:
    duplicate: https://discussions.agilebits.com/discussion/108298/1password-x-extension-for-chrome-popup-window-size

    My spec:
    CHROME VERSION: 78.0.3904.108
    OS VERSION: Linux: 4.15.0-65-generic

  • brentybrenty

    Team Member
    edited November 2019

    @trivigy: Can you clarify? I'm not sure what you're referring to regarding "February 15", how 1Password or Mozilla is involved, or the specifics of the issue you're experiencing. You've only mentioned Chrome and Linux versions. Please let me know.

  • Feb 15th is the first post I made about this issue. Which is still an issue, nothing has changed.

  • trivigytrivigy
    edited November 2019

    @brenty Thanks for getting back quickly. The comment about February 15 was just a reference to the first time this issue was created. I was expressing dissatisfaction that it has taken so long for this issue to be investigated without any results. Given that 1 Password is a commercial for profit company surely it is just a matter of prioritizing engineering resources. In either case it is a mute point. Instead of going into further rants, and after spending a few hours of my life trying to fix this, I will just share the solution here.

    The issue has to do with chrome enforcing default window.devicePixelRatio value across all pages. This is the value that ultimately is set based on calculations from the zoom settings and the --high-dpi-support=1 --force-device-scale-factor=1 flags that can be passed from command line when initiating chrome. Chrome has this special chrome://settings/content/zoomLevels that is a per webpage configuration for custom zoom. It used to work for scaling chrome extensions popup windows as well, but unfortunately that no longer works.

    For example these instructions used to work but no longer apply:
    https://stackoverflow.com/questions/39108722/how-to-zoom-out-on-an-chrome-extensions-popup
    https://discussions.agilebits.com/discussion/84449/1password-x-window-content-too-large-for-extension-popup-when-page-zoom-not-set-at-100

    I couldn't figure out exactly why that is or find the specific chromium changes that cause those instructions to break. Maybe someone else can. But my assumption is that it has something to do with the fact that chrome extension popups now run in some sort of sandboxing approach. I know this because following the instructions from the links above does create a custom modification in chrome://settings/content/zoomLevels however those do not propogate to the actual popup that is opened.

    Anyhow... The fix to this problem. I have tested it and it does change the zoom appropriately however this solution requires a modified release of the browser extension. The idea is to simply apply the css zoom setting to the html tag to counter any default zooming that users apply.

    Example:
    1. Right click on the extension and choose Inspect popup
    2. In the window that opens up navigate to console tab.
    3. Copy paste this code and hit enter.

    function defaultScale1Password() {
        document.querySelector("html").style.zoom = `${1 / window.devicePixelRatio * 100}%`;
    }
    window.onresize = defaultScale1Password;
    defaultScale1Password();
    

    What this code does is counters whatever scaling happened back to the original 100% scale specifically for this popup.html page (the 1password extension window). Unfortunately this solution does not persist because it needs to be editted in the code of the actual extension's popup.html file. This solution is very generic and is probably not good for everyone since not everyone scale their default zoom (usually only those with hi res screens like myself 2560x1440). To make this more specific one could use something like to match more specific media types.

    window.matchMedia(`(resolution: 1ddpx)`).addEventListener("change", function(e) {
        console.log(`${1 / window.devicePixelRatio * 100}%`);
    });
    

    Example that shows how the solution works.

    Executing the previous solutions to show that it does not work.

  • A little beyond my understanding but Yeah! So maybe this can be fixed.

  • brentybrenty

    Team Member

    @avspinball, @trivigy: Thanks for clarifying. The reason I was confused is that the whole popup menu has been redesigned since this discussion was started originally, in addition to the changes in Chrome itself, and that I am unable to reproduce that issue at all. Can you try the beta to see if that helps?

  • @brenty The beta exhibits identical issue as the original.

  • brentybrenty

    Team Member

    @trivigy: Thanks for checking! So, to clarify, 1Password X does not "fit" within its window on your setup? I'll see if someone else here is able to reproduce the issue.

  • @brenty This can be reproduced easily with the following steps:
    1. Chrome -> Settings -> Page Zoom -> 150%

    So, to clarify, 1Password X does not "fit" within its window on your setup?

    Correct.

  • brentybrenty

    Team Member

    @trivigy: Ah, thanks for teaching me! I didn't realize there was an actual setting for that. I always just use the keyboard shortcut. :lol: So what happens if you set it to 100%?

  • For me I use 2x 27" monitors each 2560x1440 but set to view 5120x1440. My chrome default view is set to 150% for everything. If I go back to 100% default it works fine but I can see anything because I'm getting old. Once I move back to 150% the extension displays like above and the sliders do not work. so I can't see the right or bottom of the extension window.

  • brentybrenty

    Team Member

    @avspinball: Thanks for confirming. We'll see what we can do. :)

  • So what happens if you set it to 100%?

    Everything goes back to normal. All chrome windows scale back to 100% zoom by default and so does the extension popup. Unfortunately that is not the desired state. I use a HiDPI screen devices set to high resolution. At 100% zoom I practically cannot read any web-page without using glasses.

    I'm getting old

    Same here!!! :'(>_<

  • brentybrenty

    Team Member
    edited November 2019

    @trivigy: It seems like it would be better to set the system display to make everything larger then, since you wouldn't need to try to zoom individual apps (and browsers/extensions) separately. But we'll see if there's a reliable way to make 1Password X scale better without screwing up the UI for others. Thanks for your feedback. :)

    ref: dev/core/core#223

  • trivigytrivigy
    edited November 2019

    @brenty Is there a way to see the development issue? I see the reference (ref: dev/core/core#223) but it is not a link. I will gladly help the engineers if it means that this issue can be resolved quickly. This is really annoying and if I could have just committed the code to the repo myself I would have already.

  • brentybrenty

    Team Member

    @trivigy: That's a reference which allows us to find the corresponding resources; it's not something you'd be able to access. There's a lot more to it than just what meets the eye, but I'll let the team know of your offer.

  • dtearedteare Agile Founder

    Team Member

    Thank you for digging so deep on this issue, @trivigy! 🤗

    This looks like something we could add. I’ll need to play with it for a bit before I can say anything with certainty, but it certainly looks promising. I’ll report back and hopefully have this in a beta (either by default or behind a flag) by next week.

    Thanks again!

    ++dave;

  • @dteare Thank you for the update. Looking forward to it.

    @brenty I appreciate you guys moving this along. I know this is not 1Password's (you personally!!! ;) ) fault but rather due to chrome changes. But I really appreciate you guys taking the time addressing this client facing bug. It makes me feel good knowing that I made the right decision switching away from lastpass.

  • kaitlynkaitlyn

    Team Member

    @trivigy – I look forward to it as well, and thank you for the kind words. We truly appreciate it. ❤️

  • dtearedteare Agile Founder

    Team Member

    Ah drat, @trivigy! It doesn't look like your workaround is going to work. At least not how I imagined anyway. 😢

    What I wanted was a hidden flag that you could set to activate your workaround but the result of doing so is pretty bad. Here it is in a video that @dalton took of the workaround in action:

    https://com-agilebits-users.s3.amazonaws.com/dave/chrome-popup-with-scaling-issue-workaround.mp4

    You can see the window gets resized after it opens and the result is quite jarring. So it seems we can't
    go this route after all.

    That's really sad as I know this is a PITA and I'd love to give you a workaround. I can't bring myself to force the zoom level for all users as it is nice to allow folks to zoom in.

    I read this whole thread yesterday but I don't recall if you tried these two things:

    1. Have you tried Brave or Vivaldi or other browsers yet? I know there's been some success there.
    2. If you change your default zoom level to 100% and then zoom webpages with the hotkey, does it allow the popup to work as expected?

    Sorry if I'm repeating any questions here – I'm running out the door to an appointment and wanted to get this posted before I left.

    ++dave;

  • For me Vivaldi works fine and that's my main browser because of this issue. I just installed 1password x on brave and it does the exact same thing as chrome so brave is out.

  • brentybrenty

    Team Member

    @avspinball: Thanks for confirming! Sometimes I wonder if it's just me. :lol: I've long been a Vivaldi fan, and now that they've smoothed out some other issues on Windows too I'll likely go back to using that as my "main". :):+1:

  • Just checking back on if there is any update on this issue as I still have it in Chrome only. Using extension 1.18 and 7.4.53
    Thanks

  • ag_michaelcag_michaelc

    Team Member

    Hey @avspinball. Nothing new to report at this time, I'm afraid. Thanks for checking in and for your patience here.

  • I would also like to see a fix for this issue, it makes it impossible to use the extension if your zoom level is not 100%. I'm going to have to revert back to the companion app extension.

    Is there a fix forthcoming?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file