Is there any way to change the touchpad scrolling speed on the Windows version of the app?

I find it way too fast to accurately move between records. The Windows Touchpad controls have no effect on the speed.


1Password Version: 7.3.657
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Not Provided
Referrer: forum-search:touchpad

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited February 2019

    Hi @Vicw,

    Thanks for reporting this issue.

    We don't control this scrolling within the app, it is left up to Windows to manage this for us.

    What kind of trackpad do you use? Do you have a touchscreen display as well and if yes, does it scroll normally there?

  • Hi @MikeT,

    Thanks for your response.

    I'm using a new ASUS Laptop on W10. The touchpad is described as a Precision Touchpad, and the Driver is ASUS Precision Touchpad, version 11.0.0.25, dated 3/13/18, which appears to be the current version. Scrolling via touch directly on the screen is normal, whereas in the app it seems very fast using two-finger scroll on the touchpad. Unfortunately, there isn't any adjustment in Settings for Scroll Speed.

    Since you have enlightened me that Windows is managing the two-finger scroll speed for the app, I understand now that my problem is apparently with the driver or Windows 10 itself, rather than 1Password. It is weird that the two-finger scrolling speed using 1Password on the browser is well-behaved.

    On my ASUS Desktop, using a mouse with the 1Password app, scroll speed using the roller is fine.

    Looks like I need to dig into the driver and/or Windows to solve the problem.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Vicw,

    Since you have enlightened me that Windows is managing the two-finger scroll speed for the app, I understand now that my problem is apparently with the driver or Windows 10 itself, rather than 1Password.

    Sorry, we're not saying the issue is within the driver entirely; we're saying we don't control the scrolling itself meaning we don't tell Windows to scroll fast, we're telling Windows that we have the standard list view and it should come with the standard behaviors of all item lists.

    It is entirely possible the issue is between the Microsoft's UI framework we're using and Windows. If we can reproduce it, we can report it to Microsoft to fix or they may have a better approach that we're not aware of.

    Do you have a Hi-DPI monitor and if yes, what scaling factor do you have it set at, 150% or 200%? Some scrolling can be affected by the type of monitor, like a Hi-DPI monitor may be confusing the UI to scroll twice as fast instead of normally.

  • HI @MikeT

    I apologize for seeming to ignore your response. Being new to the forum, I had assumed that emails would be generated by default, if there were any replies, and I just learned that I needed to set the Notifications in my profile to make that happen.

    I have a couple of laptops, and the behavior is about the same on both. The new one is an ASUS UX461UA Signature Edition. The resolution is set at the recommended 150% setting, with a resolution of 1920 x 1080.

    If I drop it down to 100%, everything is much smaller, or course, but the scrolling seems just as speedy. Both laptops do have touch screens, and movement follows my fingers that way. If there is no other way to tame it down, I guess I could force myself to use the touch functionality for 1Password. Actually SafeinCloud looks to scroll pretty much the same. Also, I just updated the OS from 1803 to 1809, and the behavior hasn't changed at all.

  • bundtkatebundtkate

    Team Member

    Thanks for the extra detail, @Vicw! I see this myself on my Surface Pro 3 using the type cover as well, actually. Like you noted with SafeinCloud, I had noticed the same tendency to scroll rather quickly outside 1Password, so I had assumed that this wasn't really 1Password-specific and wrote it off as a result. That said, since Mike mentioned we can reach out to Microsoft if this is reproducible, I'll make sure I touch base with him and see what I can do to help. :+1:

  • @bundtkate

    It's not a critical issue, but a minor annoyance. I appreciate that you will see if it is reproducible, and whether there can be a enhancement to control the scrolling speed. I assume it would likely have to be a Microsoft option rather than internal to 1Password.

  • bundtkatebundtkate

    Team Member

    I think you're probably right, @Vicw, but no harm in taking a look. It's easy enough for me to reproduce and even if we can't do anything to address it ourselves, at the least we can add our hearty +1 to a request to Microsoft to improve touch scrolling generally. :chuffed::+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file