2FA disables support for saving generated histor

SirSpideySirSpidey Junior Member

Didn't see this specific issue in the forums.

I turned on 2-factor authentication. After that, 1P X displayed a message that the password "...couldn't be saved to Generator History."
I had already logged into my account in the same browser session (after it prompted me to when unlocking 1P X).

Restarting the browser and disabling/re-enabling the extension did not change the behavior.

Disabling 2FA on the account and restarting the browser removed that message about saving to generator history and did save the generated password.

Chrome v72.0.3626.109


1Password Version: Not Provided
Extension Version: 1.15.1
OS Version: Mac OS 10.12.6
Sync Type: Not Provided

Comments

  • dtearedteare Agile Founder

    Team Member

    Good morning, @SirSpidey! ☀️

    I was able to recreate this issue as you described, but when I unlocked 1Password X after 2FA was enabled I got this notification letting me know that I needed to sign in again to enable MFA:

    When I clicked that notification I was taken to my sign in page and after logging in I was able to generate passwords again.

    I'm guessing that you have notifications disabled or were in Do Not Disturb mode. In any event, you should be able to go to your log in page and sign in again.

    Please give that a go and let us know how it turns out.

    Thanks! 🤗

    ++dave;

  • SirSpideySirSpidey Junior Member

    Hi Dave,

    That notification doesn't seem to be the answer for me. ("I had already logged into my account in the same browser session (after it prompted me to when unlocking 1P X)."

    In fact, I kept getting that notification even after successfully signing in.

    But I'll try turning on 2FA again and verify.

    Allen

  • dtearedteare Agile Founder

    Team Member

    Thanks for the update, @SirSpidey.

    I kept getting that notification even after successfully signing in.

    This doesn't sound good. Just to be sure we're on the same page, the sign in needs to take place within a tab and not the popup.

    I'm pretty sure if you remove your account entirely from 1Password X and add it back again you'll resolve this issue. Let's not take that step just yet, however, as we should be automatically updating your existing account when you sign in within the tab. If it happens again, please collect your console logs and post them here so we can investigate.

    Thanks!

    ++dave;

  • SirSpideySirSpidey Junior Member

    I re-enabled 2FA and am getting the same result.

    I got the notification for "Authentication Required" and signed in on another a tab in the same browser; however no prompt for auth code.

    I did get the prompt for the auth code when I enabled 2FA. And I got the prompt on my mobile device.

    Here's the console log from when I logged in after the notification.

    b5-6a38e0093087d5406e40.min.js:183 [action/Session#verify] ClientError: Please authenticate with MFA
        at new b (https://app.1password.com/js/b5-6a38e0093087d5406e40.min.js:1736:435)
        at https://app.1password.com/js/b5-6a38e0093087d5406e40.min.js:1944:257
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:183
    t @ b5-6a38e0093087d5406e40.min.js:601
    Promise.catch (async)
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:146
    verify @ b5-6a38e0093087d5406e40.min.js:1943
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1943
    Promise.then (async)
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1943
    signin @ b5-6a38e0093087d5406e40.min.js:1942
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1533
    Promise.then (async)
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:146
    A @ b5-6a38e0093087d5406e40.min.js:1532
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1532
    Promise.then (async)
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:146
    z @ b5-6a38e0093087d5406e40.min.js:1531
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1532
    d @ b5-6a38e0093087d5406e40.min.js:1530
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1529
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1529
    t @ b5-6a38e0093087d5406e40.min.js:1528
    B @ b5-6a38e0093087d5406e40.min.js:1532
    e.signIn @ app-21f6146abbac296ac17f.min.js:771
    (anonymous) @ app-21f6146abbac296ac17f.min.js:770
    Nb @ vendor-fee6a99fdab80198b30a.min.js:1388
    Ea @ vendor-fee6a99fdab80198b30a.min.js:1388
    fe @ vendor-fee6a99fdab80198b30a.min.js:1469
    ee @ vendor-fee6a99fdab80198b30a.min.js:1460
    Eb @ vendor-fee6a99fdab80198b30a.min.js:1459
    uf @ vendor-fee6a99fdab80198b30a.min.js:1473
    jd @ vendor-fee6a99fdab80198b30a.min.js:1362
    b5-6a38e0093087d5406e40.min.js:183 [action/auth#signInWithMpAndSk] ClientError: Please authenticate with MFA
        at new b (https://app.1password.com/js/b5-6a38e0093087d5406e40.min.js:1736:435)
        at https://app.1password.com/js/b5-6a38e0093087d5406e40.min.js:1944:257
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:183
    t @ b5-6a38e0093087d5406e40.min.js:601
    Promise.catch (async)
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:146
    A @ b5-6a38e0093087d5406e40.min.js:1532
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1532
    Promise.then (async)
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:146
    z @ b5-6a38e0093087d5406e40.min.js:1531
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1532
    d @ b5-6a38e0093087d5406e40.min.js:1530
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1529
    (anonymous) @ b5-6a38e0093087d5406e40.min.js:1529
    t @ b5-6a38e0093087d5406e40.min.js:1528
    B @ b5-6a38e0093087d5406e40.min.js:1532
    e.signIn @ app-21f6146abbac296ac17f.min.js:771
    (anonymous) @ app-21f6146abbac296ac17f.min.js:770
    Nb @ vendor-fee6a99fdab80198b30a.min.js:1388
    Ea @ vendor-fee6a99fdab80198b30a.min.js:1388
    fe @ vendor-fee6a99fdab80198b30a.min.js:1469
    ee @ vendor-fee6a99fdab80198b30a.min.js:1460
    Eb @ vendor-fee6a99fdab80198b30a.min.js:1459
    uf @ vendor-fee6a99fdab80198b30a.min.js:1473
    jd @ vendor-fee6a99fdab80198b30a.min.js:1362
    b5-6a38e0093087d5406e40.min.js:183 [action/auth#signIn] ClientError: Please authenticate with MFA
        at new b (https://app.1password.com/js/b5-6a38e0093087d5406e40.min.js:1736:435)
        at https://app.1password.com/js/b5-6a38e0093087d5406e40.min.js:1944:257
    
  • dtearedteare Agile Founder

    Team Member

    Thanks for the update, SirSpidey, and thank you for the logs.

    I see from your logs that you have Desktop App Integration enabled. This should be fine but it looks like we have a bug in our flow that prevents MFA from being enabled.

    For now please remove your account from 1Password X and add it back manually. Afterwards I suspect you'll be in a good state.

    Please give that a go and let us know how it turns out.

    ++dave;

  • SirSpideySirSpidey Junior Member

    Hi Dave, didn't see your reply. Sorry.
    Independently, that's exactly what I did: remove my account from 1P X and add it. That seems to have done the trick. Thanks.

  • dtearedteare Agile Founder

    Team Member

    Thanks for the update! I'm glad to hear that resolved the issue. 👍

    I'm still curious why this is the case but we'll figure it out.

    Take care, 👋

    ++dave;

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file