1Password 7 Safari Extension missing

I am running 1Password 7 (version 7.2.5) on my Mac (OS X 10.13.6) and got the most recent update for 1Password in the last day or so. I used it today (for the first time since the update) and it will not automatically open Safari and it also will not fill in the username/password like it normally does when I tell it to "Open and Fill" or just "Fill". I checked in Safari and there is no 1Password extension listed. I checked for help on the 1Password support pages and I see a message saying that my browser does not have the extension, but unlike Chrome, Firefox, etc., I can't separately download and re-install the Safari extension because it appears to be imbedded in the 1Password 7 application. Until the very recent update, it was working fine. I looked through some threads but couldn't find anyone posting this problem. Any suggestions on how to get the Extension back into Safari? Thank you.


1Password Version: 1Password 7 (version 7.2.5)
Extension Version: It's missing from Safari
OS Version: OS X 10.13.6 High Sierra
Sync Type: iCloud

Comments

  • dancodanco Senior Member Community Moderator

    The 7.2.5 extension SHOULD be installed automatically. Do you see it in Safari > Preferences > Extensions?

    If not, there is something weird going on (I certainly have it in mine). But I wonder if it is there but not enabled - though, again, it should have been enabled automatically.

  • In Safari > Preferences > Extensions the 1Password Extension is not listed. In 1Password under Preferences > Browsers the Extension Helper is Enabled and the Autosave (Detect new usernames ...) is Enabled.

  • dancodanco Senior Member Community Moderator

    As I said, it should have worked. An AgileBits person will come along to help at some point, but in the mean time there are various standard tricks you might try.

    They are quitting 1PW completely (ctrl-option-cmd-Q) and quitting Safari, then reopening them. Trashing 1PW and redownloading. Restarting your computer.

    Of course, rather than these leaps in the dark, you may well prefer to wait for an official response

  • I have the same problem. I can install the extension from the Apple Safari extension website:

    https://safari-extensions.apple.com/

    It shows up along the top of the browser as installed, and in Safari>Preferences>Extensions it's listed, but after I Command+Q, and restart Safari, it's gone again.

    I recently upgraded to Mojave, but this phenomenon was present prior to that as well.

    1Password 7
    Version 7.2.4 (70204001)
    Mac App Store

    MacOS Mojave 10.14

  • LarsLars Junior Member

    Team Member

    @lukevan - I'm sorry for the trouble. What version of Safari are you using?

  • Hi Lars: Safari Version 12.0.3 (13606.4.5.3.1). A couple of more tidbits that may be of interest. I've done a full re-start of the computer a couple of times since I last posted. I can now see the 1Password extension in Safari through Preferences > Extensions. But Safari still will not open when I click a password in 1Password and tell it to "Open and Fill". Also, even when I manually open a new Window in Safari and navigate to the site I want (e.g. Amazon.com), I have to manually cut/paste the username/pw from 1Password and I'm no longer getting the option to simply "Fill" the information in like normal once you're already at the site you want. It's as if 1Password does not recognize that Safari is open and already sitting at the the log-in screen for the specific password. As I originally indicated, all of this unusual lack of response by 1Password began immediately following the last update to the program.

  • Additional update: I realized from re-reading Wyzzer's post that my 1Password button in Safari is missing, but the quick access button in the menu bar at the top of the Mac screen is there as always (I normally access 1Password via the button at the top of the Mac). I looked in Safari > Preferences > Extensions and saw that the 1Password extension did not have a check mark in the small box to the left of it's name. I "checked" this and then re-started Safari. The 1Password button at the top of Safari has re-appeared and now the program appears to be operating Safari properly. I don't believe the 1Password button has been at the top of Safari recently but I'm not sure as I haven't gotten in the habit of using it.

  • LarsLars Junior Member

    Team Member

    @lukevan - glad you were able to get it sorted out. 1Password's Safari extension should be enabled when updating, but when it's not, checking Safari's Preferences > Extensions to make sure it's enable there is a good place to start. :)

  • I have the exact same problem!! But nothing has fixed is. 1Password 7.2.5, Safari 12.0.3, Mac OS 10.13.6. The problem appeared after the most recent 1Password update. I did a basic maintenance with the Cocktail for Mac software and a full restart - fixed the issue for exactly one web page. When I closed that page and moved to another the extension was missing from Safari's toolbar!!!! It is also not visible in the Safari > Extensions. And of course their is no way to reinstall it. HELP! It works fine in Firefox but that's not my primary browser.

  • BenBen AWS Team

    Team Member
    edited March 24

    @raroche

    As far as I'm aware the only troubleshooting step for 1Password not appearing in Safari > Extensions under those conditions is to restart the Mac. I realize you mentioned you've already done that once, and that the extension worked briefly after doing so. I hate to ask... but could you please try restarting again and report back what the outcome is?

    P.S. We'd always recommend keeping up to date with the latest versions of all of your software, but especially 1Password, your operating system, and your web browser. As such I'd be remiss if I didn't point out that you're a whole major version behind on your operating system. macOS 10.14 (Mojave) is now available.

    Ben

  • I have the same problem.

    1p - 7.2.5
    Mojave 10.14.3
    Safari 12.0.3

    After installing there is no 1p extension in safari extensions tab. Extensions for Firefox and Chrome works as they should and autopaste login data with command\ shortcut.

    Removed all 1p data from ~/Library/, rebooted, reinstalled and nothing helped to make it work with safari

  • After the 5th restart Safari finally kept it active and visible even if I quit and restart Safari. I am a certified Apple consultant so I run High Sierra on this machine so I can support it more easily. If this become an issue for any of my clients - many run 1Password on my recommendation - I will let you know - thanks Ben

  • ag_anaag_ana

    Team Member

    Hi @nysander! Welcome to the forum!

    Without touching the ~/Library/ folder, can I please have you try to reboot once again? Do you see the same issue after another reboot?

  • ag_anaag_ana

    Team Member

    Hi @raroche!

    Thank you for the update! And on behalf of Ben, you are very welcome :)

  • I'm afraid I am having the exact same problem, but none of the suggested remedies have worked. I am running the latest (OS 10.14.5) and the latest production 1Password 7 (7.3). I have done nothing, but allow updates for the OS and 1Password 7 to be installed as per normal, but the extension has disappeared in Safari (Safari is also up to date!). I have restarted Safari. I have shutdown all applications and restarted my Mac (2018 MacBook) twice... at least... and still the extension does not appear in the list of Extensions present under Safari PREFERENCES/EXTENSIONS. What can be done to make this work? Since it is no longer a separate extension download and install (i.e. seemingly integrated with the 1Password 7 install, then I can't seem to act on this without de-installing 1Password 7 and re-installing... which I am, of course, reluctant to do! Help!

  • LarsLars Junior Member

    Team Member

    @erik43 - go ahead and uninstall/reinstall 1Password. It won't affect your data (which resides in your Library folder). Make sure you do things in this order:

    1. Quit Safari and any other running browsers
    2. Quit 1Password 7 Completely by typing ^⌥⌘Q (or just holding down the Control and Option keys as you choose Quit from the 1Password menu).
    3. Delete 1Password 7 for Mac -- don't use any app cleaners or uninstallers to do this, as these programs can remove more data than we want them to. Just drag the 1Password app to your Mac's Trash.
    4. Empty the trash.
    5. Restart your Mac.
    6. Visit our downloads page and grab a fresh copy of the current 1Password 7 for Mac installer and run it.
    7. You should see all your data once you enter your Master Password; re-open Safari and make sure the 1Password extension is visible in the menubar of Safari. Test to make sure you can save and fill.

    Let us know how that works for you.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file