Issue with Android For Work and enabling Filling/Autofill or Accessibility

I'm using a Pixel 3 XL with Android for Work (AwF) profile. 1Password is installed in the AfW profile.

When enabling Filling/Autofill, I select the Autofill service 1Passowrd (it has the AfW icon on it), I'm asked if I trust the app, select OK, but the Autofill is still disabled.
When enabling Filling/Accessibility I get the error: "you are using this app outside of your work profile".

I had a similar error with enabling Fingerprint Unlock, however I found I could enable separate locks for private and work and, after enrolling my fingerprints in the work profile, I was able to fix the issue.

How can I enable Filling with AfW?


1Password Version: 7.1.1
Extension Version: Not Provided
OS Version: Android 9
Sync Type: 1Password
Referrer: forum-search:android accessibility you are using this app outside of your work profile

Comments

  • periperi

    Team Member

    Hi @johnlennon. Is the 1Password app installed in your work profile, or in your personal one?

  • I have this exact issue, app is installed in the work profile only.

  • periperi

    Team Member

    Hi @srl. Thanks for reaching out. Are you having trouble with both Autofill and accessibility, or is it just one of those? Does it help to install 1Password in your personal profile?

  • Hi, any update on this? It's both Autofill and Accessibility that don't seem to work. I got the Fingerprint unlock working but everytime it takes me to the work profile setting for Autofill, I select 1Password, then it takes me back to 1Password but the setting isn't enabled.

  • periperi

    Team Member

    Hi @chris_j_gbny. Early betas of Android 10 seemed promising in this department. Do you have 1Password installed in your personal and work profiles on this device? Or is it just installed in the work profile?

  • Just installed on the work profile on a Note 9.

  • periperi

    Team Member

    Thanks! Are you using Android 10 on your device? If you're using Android 10, you should be able to turn Autofill on through Settings > Autofill in either profile.

    If you're using Android 9, you'll need to have 1Password installed in both your work and personal profiles. When you've enabled Autofill and Accessibility in your personal profile settings, they should also be enabled in your work profile.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file