1Password 7 installer does nothing

I have a Windows 7 64-bit computer, with .Net Framework 4.7.2 already installed.
I had 1Password 4 (synced to a vault on Dropbox).
I tried running the 1Password 7 installer, but it did nothing beyond closing 1Password 4.
I have uninstalled 1Password 4 and tried running the 1Password 7 installer, but it still does nothing. In Task Manager, a line pops up saying "1PasswordSetup -7.3.657.exe *32" flashes up, but disappears within a second.

Can someone help get this fixed. This is my primary computer for work, and now I do not have access to any of my passwords.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • 1Password Support got back to me and sent me a link to version 7.2.617 to install, and that worked. I then upgraded it to 7.3.657 from within the app.

  • bundtkatebundtkate

    Team Member

    Glad you have things sorted, @jsimpson! Enjoy and if I can do anything else to help, just let me know. :chuffed:

  • I have the same problem. Windows 10 64-bit. 1Password4 (synced to vault on Dropbox). I tried running 1Password 7 installer, but it does nothing.

  • BenBen AWS Team

    Team Member

    Hi @MFrank

    Please try this download:

    https://c.1password.com/dist/1P/win6/1PasswordSetup-7.2.617.exe

    Once installed, update within the app. Please let me know how it turns out.

    Ben

  • Ben:

    Thanks for the link. Installed, updated, working perfectly.

    -MF.

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. On behalf of Ben, you are most welcome! It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file