1Password in Tor 8.0

Hi, I'm trying to use 1Password in the Tor browser (8.0.6). It is based on Mozilla/FF. I was able to install the Firebox extension for 1Password, and its icon appears in the Tor browser bar. But it is grayed out, and clicking on it has no effect. There is no error given. Does anyone know how to make this work?


1Password Version: 7.2.5
Extension Version: 4.7.3.90
OS Version: OS X 10.14.3
Sync Type: Not Provided

Comments

  • Hi @michael_p,

    I'm sorry but the Tor browser isn't a supported so no level of effort on your part will allow you to use that combination. As it stands supported browsers include:

    • Safari (macOS only)
    • Edge (Windows only)
    • Firefox
    • Chrome
    • Vivaldi
    • Opera
    • Brave

    If Tor 8 is based on a reasonably new version of Firefox, one that supports WebExtensions and if you are a 1Password account user rather than the combination of licence plus standalone vaults then 1Password X may allow you to use the Tor browser. As it is a standalone extension it is designed to connect to our 1Password account server and has to perform all the tasks of a client. That would allow you to bypass the supported browser requirement that both 1Password for Mac and 1Password for Windows has.

    At this time it is very unlikely that any other browsers will be added to the supported list so 1Password X would seem to be the only option to work with Tor I'm afraid.

  • Hey @littlebobbytables

    I know that Tor Browser is not officially supported, but I also tried the 1Password X version and it doesn't work either - when I click on it I just get a blank page so there is no way I can authenticate. Do you maybe know about any workaround that might enable me to use 1Password X extension in the Tor Browser? Or maybe just my own settings are somehow blocking that?

  • Hey @ondrejfuhrer, the Tor Browser has a default setting that interferes with 1Password X. If you check about:preferences#privacy you should find a setting titled Always use private browsing mode. If you disable that and restart Tor, you'll hopefully find you can set up 1Password X. Let me know if that helps!

  • Hey @ag_michaelc , thank you for your reply. That helped, great! :+1:

  • @ondrejfuhrer, I'm glad to hear it! Let us know if you need help with anything else. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file