.NET Framework initialization errors: CLR Activation Issues

Hi there - I'd appreciate some help with the issue listed in the subject line and below please:

When I boot into Windows 10 Professional, and 1Password initializes, I receive ".NET Framework initialization errors: Managing the user experience, CLR Activation Issues error messages" and 1Password is unable to start. Once I dismiss the error and start 1Password manually I don't receive the error again and 1Password starts normally and continues to work without errors.

I've done the following:

  • repaired the .NET Framework installation using the Microsoft Utility and I've also reinstalled .NET Framework software executables.
  • Uninstalled and Reinstalled 1Password including the Edge extension

The error opens up the following URL:
https://docs.microsoft.com/en-au/dotnet/framework/deployment/initialization-errors-managing-the-user-experience?version=(null)&processName=1Password.exe&platform=0009&osver=6&isServer=0&shimver=4.0.30319.0

Hardware: Windows Surface Pro 6, Core i5, 8Gb Ram, 128Gb
Operating system: Windows 10 Professional ver 1803 (OS Build 17134.590)
Internet Browser: Microsoft Edge
1Password Family

Thanks in advance for your assistance.

Regards
Mich


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • GregGreg

    Team Member

    Hi there @Michinoz,

    Thank you for your detailed post! It is really appreciated.

    If you disable 1Password extension in Microsoft Edge and reboot your PC, does the issue remain? Here is how you can do it:

    Thanks in advance!

    ++
    Greg

  • Hi there Greg,

    You're welcome and thank you for the quick response. I can confirm that disabling the extension in Edge does not produce the .NET Framework error after a system restart.

    In addition to the above, I can also confirm that if I now fire up Edge, and manually enable the extension again, the .NET Framework error does not appear and the extension fires up with no issue.

    Thanks
    Mich

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. On behalf of Greg, you are most welcome! I'm glad to hear that all is well. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

  • Hi Brenty

    I think my message is misunderstood.

    The issue is not resolved. I've just disabled the 1Password extension in Edge which removes the error when I restart the machine.

    Once the machine has restarted and I manually enable the extension in the Edge browser after Edge has started up the system doesn't produce the error.

    ...or am I to understand that the solution proposed is that I disable the 1Password browser extension?

    Thanks
    Mich

  • brentybrenty

    Team Member

    @Michinoz: Thanks for clarifying. There are certainly different ways of looking at it. If you're okay with doing that, that's fine by me. But I do love a good puzzle too. :)

    Do you perhaps have Edge set as your default browser? There's a known issue with that where it launches in the background on boot, I guess to make loading faster. The problem is that when that happens, it also loads any extensions it has installed/enabled. And of course since 1Password isn't yet running (Windows loads its own stuff before anything else) it cannot connect.

    Does it work better for you if you disable Edge as the default in Settings, and just launch it from the task bar or whatever, once everything is up and running? I wish there were a way to have Edge be a little less aggressive in that regard so we could avoid the error, but since that isn't something we have control over this can help in the mean time. Let me know.

  • Hi Brenty

    Edge is indeed my default browser. I understand what you're saying, your explanation regarding background start-up control for Edge that is only controlled by Microsoft makes sense. I would say though that I have other extensions that do not present this problem but I suppose may work a bit differently during Edge start-up.

    Disabling Edge as the default browser is not a feasible workaround for me as it is the only browser I use.

    However, I managed to create a registry setting to stop Edge from pre-loading during machine start-up, which works great as it eliminates the .NET Framework error and also does not require me to disable the 1Password Extension in the Edge browser.

    This achieves the same outcome as your suggestion of disabling Edge as the default browser.

  • tmakarotmakaro
    edited March 10

    This would potentially explain my issues with 1password at startup. (I just see a message when 1password restarts saying that it quit unexpectedly, and it does this once a day in the morning) @Michinoz What is the registry key that needs to be changed and to what value? I'm curious to check it out.

    @brenty I don't know how the browser extension is built, but I imagine that there is a way to anticipate that 1password hasn't started yet.

  • brentybrenty

    Team Member

    @Michinoz: Indeed, that;'s a really good point. I'm not aware of other Edge extensions that work the way ours does, connecting to a separate native app. That's been a huge challenge not only in Edge, but with all of our browser integration over the years. We've made a lot of progress, and so has Microsoft (and other browser vendors) is giving us and other developers tools to work with, but especially with 1Password we're trying to do something pretty unique. Otherwise none of us could take advantage of stuff we can only do with the native app -- Windows Hello just being one example.

    Anyway, I didn't realize there was a reliable way to disable Edge's pre-load/suspend behaviour. If it's something you think is suitable to share, that would be really cool. :) I think maybe the downside would be that any updates might require that to be reconfigured.

  • brentybrenty

    Team Member

    @tmakaro: We don't have any control over Edge, so even if there is a way for it to check if 1Password is running or not it we can't make that happen. And I think there's good reason for Microsoft to not want extensions to be able to scan running processes. :)

  • tmakarotmakaro
    edited March 15

    The issue seems to have disappeared before I tried to disable Edge auto-starting at boot. It's been much more stable lately. For the record, I believe that this is the needed instructions for disabling Edge auto-start. I'll try this edit if I notice the instability of the app return.

    It makes sense that extensions are not able to scan running processes. I was thinking more of a "if the browser extension tries and fails to call the app because the app isn't running / hasn't started yet" then handle that error a little more gracefully instead of crashing the app and/or browser extension.

  • bundtkatebundtkate

    Team Member

    We'd be delighted to handle that error better, @tmakaro, but it's unfortunately out of our hands. My understanding is it's not 1Password encountering a problem, but .NET itself, so we can't control the error shown. That said, all of this will ultimately be moot down the road. Microsoft is in the process of revamping Edge and the new version will be built on Chromium. One of the many things to be excited about here is that this will allow us to greatly simplify our implementation of 1Password in Microsoft Edge – we have supported Chrome for a long while and have an all-but-seamless integration there – and our strong hope is that this will resolve many of the little issues that have plagued us to varying degrees since we introduced Edge support. Of course, nothing is real until it's released, but we have reason to be hopeful and are excited for what's to come. :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file