Password Generator suggested password is not editable

The password generator is EXTREMELY unhelpful. There's no way to edit the suggested password if what you're given doesn't quite meet the requirements. What I run into most often is a website that only accepts a subset of all special characters. In previous versions, I'd generate a password, then change any unacceptable characters into acceptable ones before submitting. Now, I can generate a password, but there's no option for editing it. You get whatever is offered by the generator, and if it's not acceptable then the only option is to generate a whole new one that's also almost certainly not going to work. I'm left with the very manual process of 1. Generate a password, 2. Copy it to a text editor, 3. edit and manually submit it, 4. manually update the saved password in 1Password.


1Password Version: 7.2.5
Extension Version: 1.14.1
OS Version: 10.14.3
Sync Type: Not Provided

Comments

  • BenBen AWS Team

    Team Member
    edited March 11

    Hi @Tipperon

    I agree it would be helpful, at least until a better solution to the password complexity requirements problem is found, to be able to edit generated passwords. I'll see what I can do to advocate for that position. That said in my personal experience I do typically find that within the first two or three passwords generated an acceptable one is found. Thanks for sharing your feedback on this.

    Ben

    ref: x/b5x#693

  • I will second this suggestion. I'm evaluating a switch from LastPass Enterprise to 1Password Business for my company. This inability to edit a suggested password is this first thing that I tried, and it really poses a deal killer to my migration plan.

  • BenBen AWS Team

    Team Member

    Thanks @RichardWest. I would suggest reaching out to our business team at [email protected] with that feedback. They'll be in the best position to push that angle.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file