Chrome 72 Select chrome button after filling

I have a problem recently.
When I press 1 Password hot key in Chrome, account and password will be automatically filling.
But 1 Password won't help me click the [Sign in] button.
I checked for a long time and finally found that when 1Password automatically fills in the information, it will select the [More] button in the upper right corner of Chrome, please see the picture.
What is the cause of this?


1Password Version: 7.3.657
Extension Version: 4.7.3.90
OS Version: Windows 10(17763)
Sync Type: 1 Password

Comments

  • GregGreg

    Team Member

    Hi @nerverfs,

    Thank you for reporting this! This is quite strange.

    Could you please check your item in question and tell me what you have enabled under submit?

    Do you have it enabled? If you select "Never submit", does the behaviour your described remain? Please let me know. Thank you!

    Cheers,
    Greg

  • Hi @greg,
    I tried the three options in [submit], but unfortunately no matter which one I choose, this will happen.
    I tried a lot of websites and the probability of this problem is 90%.

  • bundtkatebundtkate

    Team Member

    1Password relies on focus being in the password field for autosubmit to work properly, @nerverfs. In essence, 1Password is simulating an enter key press to submit the form. We ask for focus to remain in the password field after filling, but our control over that is somewhat limited. There are sites that attempt to place focus elsewhere when you open the page and we can't guarantee 1Password can override that. It's up to Windows to decide which of us wins out. This is one reason I've never been fond of auto-submit. It can have unexpected results when focus isn't where we need it and is a nightmare on sites with CAPTCHAs, so it only took me a short while to disable it. Pressing enter isn't a ton of work and doing so myself gives me the opportunity to notice my cursor isn't blinking in the password field rather than being surprised by the results of that simulated enter.

    Now, that said, I wouldn't expect this to be such a pervasive issue unless something else is leading to more consistent focus switches. Do you have any extensions installed in Chrome that might reasonable impact focus? What about your keyboard shortcut – do you use the default (Ctrl + \) or something different? Also, although probably not the culprit, it's worth checking the global auto-submit setting as well. If you choose 1Password > Settings, then click Browsers, is "Automatically sign in after filling usernames and passwords" toggled on? Thanks! :chuffed:

  • @bundtkate
    Thank you so much for your suggestion!
    I do have a lot of chrome extensions, and the test found that this issue is not related to the extension I installed.
    My keyboard shortcut is (alt + .)I tried to change the keyboard shortcut to —— (Ctrl + ),invalid.For convenience, I changed the keyboard shortcut to (shift + /),The problem no longer appears!
    Thank you for your help!

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. On behalf of Kate, you are most welcome! I'm glad to hear that all is well. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file