I have a website my credit union is testing for our online banking- 1password wont open and fill

My credit union is testing a new online banking system and I can't get 1password to fill in the credentials on the site. I've tried to create a new password after filling in my credentials but nothing happens. I then opened the 1password app, added the login manually, and used the open and fill option and it opened the site but didn't fill in the credentials. The site is https://onlinebanking.1stfinancialfcu.org/login. If it's an issue with the vendors coding on the site, I'd like to report what they need to change. Any assistance is appreciated.


1Password Version: 1Password Version 6.8.9 (689000) Mac App Store
Extension Version: 4.7.3.90
OS Version: Mac Mojave 10.14.3
Sync Type: Not Provided
Referrer: forum-search:open and fill not working on online banking site

Comments

  • edited March 15

    Hi, @carolarm

    I can't say it for sure as I'm not a 1Password team member, but from what I saw in the source code of the page, all the logins are handled using some DIVs and JavaScript, which is totally a no-no from the standpoint of recommended web standards.

    I'm 90% certain that is the reason. The way it should be done is through the HTML tag <input> and then, by sanitizing and escaping the content in the back end. Of course, it requires to practically redesign the entire page, which, if you ask me, they should do regardless they wanted to make 1Password work correctly or not :chuffed:

    Hopefully I could be of help. If you have any questions, let us know!

  • ag_sebastianag_sebastian 1Password Alumni

    Hi @carolarm,

    Thanks so much for your report. It looks like the site is actively trying to discourage anything from filling there. 1Password doesn't even recognize the form as a login form, so you can't even save the login manually. As @arturoaubry suggested, it would be ideal if they conformed to input field standards. Having said that, there's almost always something we can do about it. I'll file a bug report for the rest of the team to look into, but I can't give you any promises when and if we'll be able to make it work.

    I'll update this thread when there's progress.

    ref: xplatform/filling-issues#448

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file