1Password Accessibility with Samsung Internet not working on Android Oreo 8.0

On my old Samsung Galaxy S5 on Android 5.1.1, the Autofill with 1Password pop-up comes up automatically on Samsung Internet when username/password fields are detected on a webpage.

On my Galaxy S8 on Android Oreo 8.0.0, the Autofill with 1Password pop-up does not come up at all on Samsung Internet, even with Autofill turned off to force it to use Accessibility.

I’m not talking about the known issue with Samsung Internet where the correct login cannot be identified because Samsung Internet is masking URLs. I’m talking about the Autofill with 1Password pop-up not coming up on Samsung Internet on Android Oreo 8.0 with the Accessibility feature the same way it comes up on Pre-Android Oreo 8.0

Why is the 1Password Accessibility feature not working with Samsung Internet on Oreo 8.0?


1Password Version: 7.1.3-BETA-1
Extension Version: Not Provided
OS Version: Android 8.0.0
Sync Type: Dropbox - opvault

Comments

  • johnny808johnny808
    edited March 21

    To add to my post above, I discovered it's seems a little more serious what's really happening on Android Oreo 8.0 with the filling function. Saving function was not tested.

    With 1Password Autofill turned off (Use Accessbility) > "Autofill with 1Password" pop-up comes up on Google Chrome and Firefox, but not on Samsung Internet.

    With 1Password Accessiblity turned off (Use Autofill) > "Autofill with 1Password" pop-up does not come up on any of the tested browsers, Google Chrome, Firefox, or Samsung Internet

    In conclusion, it seems 1Password Autofill for filling does not work on Android Oreo 8.0, it was 1Password Accessbility all along doing the filling. And 1Password Accessibility does not work for some reason for Samsung Internet where it was working fine Pre-Android Oreo.

  • brentybrenty

    Team Member

    @johnny808: Thanks for getting in touch. I'm sorry to hear you're having trouble with Samsung Internet, especially if it worked for you before. Unfortunately it isn't something we support, and honestly we don't have any way of knowing what they might have changed in Oreo(?) to break accessibility, nor is it something we can fix for them. Are you able to upgrade to Pie? Maybe they've improved things there (or fixed a regression). Otherwise you'll have a better experience using a browser with better support for Android standards like Autofill and Accessibility. The latest version of Firefox has support for Autofill with 1Password for Android 7.1 or higher, and Chrome is compatible with Accessibility filling. :)

  • I found a fix. Turns out 1Password does work in Samsung Internet.

    I use Transmission for Mac and have Remote login set up. The web interface, (when launched in the Samsung Internet app) will show the 1Password autofill pop-up. No idea why it works here and nowhere else but it got me playing with the settings and I found a fix to get it working on all sites.

    Open 1Password > Settings > Filling > Tap 'Autofill' > select 'Google' as the Autofill service which will turn off the Autofill toggle in 1Password.

    1Password will now pop-up for autofill when tapping on a username or password field in the Samsung Internet app. It will also still prompt 1Password autofill inside Android applications.

    Note: once 1Password autofill has prompted and been unlocked for a website login, you will have to manually type to search for the password you need. I assume 1Password cannot detect the website you’re on. It’s a minor annoyance but better than having no 1Password autofill at all. 1Password autofill for Android apps seems to be unaffected and still work as usual.

    My device is a Google Pixel 2 XL and the applications, (Android Pie, Samsung Internet, 1Password & Transmission) are up to date with the latest public releases (no betas) as of the date of this post.

  • brentybrenty

    Team Member

    @Braceyourself: Are you sure you're not using a different browser? I've just never heard of Samsung Internet being used on a Pixel phone...and Transmission is a Mac app and not even available for Android as far as I can tell. Can you clarify? Google's Autofill feature simply won't work unless the app's developer has explicitly added support for it, and as far as I can tell Samsung Internet didn't.

  • Hi @brenty. Yeah Samsung Internet is an app on the Google Play store. It's not exclusive to Samsung devices.

    Transmission was just for reference. It's the only app I own on Mac where I'm able to log in remotely from a browser. These local url's will prompt 1Password Auto-fill when no others will. I was hopping this info would help figure out why it wasn't working on regular sites as it seems to be there. My guess it's got something to do with the way Samsung Internet handles URL's. It masks them or something. I'm always having to fill in reCAPTCHA.

    When I use Google as the Auto-fill service in 1Password, 1Password shows up on every login page. But if it's a new password I'm prompted by Google Smart Lock to save it.

    I can also select 'None' as the Auto-fill service and get the same results without Google or 1Password offering to save my password. Although Samsung Internet will always ask if I want the browser to remember my password.

  • SystemSystem

    Team Member
    This discussion was created from comments split from: No prompt in any browsers on my Galaxy S8 Oreo.
  • brentybrenty

    Team Member

    @Braceyourself: Thanks for getting back to me! Interesting. Can you tell me the specific versions of Android, Samsung Internet, and 1Password you're using there, and the exact steps you're taking? Thanks in advance! :)

  • edited June 3

    @brenty

    Device: Google Pixel XL 2
    Android 9: Build number PQ3A.190605.003
    1Password: v7.1.5
    Samsung Internet: v9.2.10.15

    Open 1Password > Settings > Filling > turn off the Autofill toggle

    After this is done 1Password works for me in Samsung Internet on my Pixel 2 XL.

  • brentybrenty

    Team Member

    @Braceyourself: Thank you! I think I understand now, and it comes down to a few things:

    • It looks like Samsung Internet has improved their Accessibility support! 🎉🤞
    • Confusion about Accessibility versus Autofill
    • How 1Password works in either case

    We're looking into if we can officially support Samsung Internet, by way of testing to see if the improvements they've made make it reliable enough for 1Password to work with using Accessibility. They still don't support Autofill it looks like, but I don't blame anyone for being confused; it confuses me as well!

    Autofill is our first choice since it's expressly made to support things like saving and filling usernames and passwords -- a perfect fit for 1Password. Not all apps support this though, as it needs to be explicitly built in by the developer. It's most reliable though because there is really no guesswork, since the app declares what each field is for, etc. Very reliable.

    Accessibility is our second choice, as it involves more work on 1Password's part and it doesn't always work because much of it relies on the app declaring fields not especially for filling but so that folks using assistive technologies can interact with them -- like voice control. Apps supporting accessibility is good for those who depend on it to use their devices, but 1Password can also take advantage of those cues for filling as well. Very useful.

    In this case, without official support, 1Password is treating Samsung Internet like a regular app where it can use Accessibility, in that you can choose specific Login items to associate with it and fill them (rather than 1Password knowing that it's a web browser, and getting URL info from it to match them automatically).

    I hope that helps clarify, and thanks for bringing this up! Hopefully we'll be able to officially support additional browsers going forward. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file