Firefox extension does not work [browser history must be enabled]

I am using Ubuntu 18.04.2 LTS and Firefox 65.0.1 (64-bit), and the 1password extension does not work. Clicking on the 1password icon opens up a new window, which remains empty.
Below please find a screenshot with the error message from the console included.


1Password Version: Not Provided
Extension Version: 1.14.2
OS Version: Ubuntu 18.04.2 LTS
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @Lallala! Welcome to the forum!

    Firefox recently release the 65.0.2 update, and even more recently, the bigger 66.0 update. Just to make sure we have everything updated, can you please try updating Firefox too and see if this fixes the issue?

    Thank you!

  • Hi @ag_ana !

    Thanks for your feedback!
    I have updated Firefox to 66.0 and it makes no difference unfortunately. I have checked under win10 as well (also Firefox 66.0), exactly the same outcome. Out of curiosity, I have tried on a different computer as well, same issue.

    Does it work on your computer under Firefox at the moment?

  • brentybrenty

    Team Member
    edited March 2019

    @Lallala: It does, and we haven't been getting reports from other people that it isn't either. That's why this is a bit baffling. :) Do you maybe have other extensions or some setting in Firefox that's interfering with 1Password X? Some of the more restrictive options could cause some trouble. It's also not at all uncommon for a Firefox profile to be damaged and break things...but I think it's a bit unlikely that multiple computers would have a profile broken in exactly the same way. Anyway, let me know what you find. There must be some commonality between those machines -- other than just you. ;)

  • brentybrenty

    Team Member

    Also of note, I haven't ever heard of "the 1password icon opens up a new window" before either, so if there are other details you can share about that (is there a URL being requested?) that might help solve the mystery. Please share any errors in your background console logs from 1Password X:

    Save a console log for the 1Password extension

  • Thanks for your feedback @brenty!

    I have to slightly correct myself: it does not open a new window, but a new tab, when I click on the 1password icon in Firefox.
    The original screenshot shows such a newly opened tab with the address bar included, and the final error message in the console.

    The complete console log in debug mode is as follows:

    Could not map contract ID '@mozilla.org/widget/printdialog-service;1' to CID {06beec76-a183-4d9f-85dd-085f26da565a} because no implementation of the CID is registered.
    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. background.js:31
    WU moz-extension://1d2cf19d-9894-44cb-b363-f97803502b32/background/background.js:31
    TypeError: $Y is null[Learn More] background.js:31:566477

  • Hi @brenty! I forgot to mention that the previous error report is from win10 environment, while this one is from Ubuntu 18.04.2 LTS:

    Could not read chrome manifest 'file:///usr/lib/firefox/chrome.manifest'.
    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. background.js:31
    Rx moz-extension://f86079ec-a4f7-4927-b251-86d55a46db2b/background/background.js:31
    TypeError: $Y is null[Learn More] background.js:31:566477
    error occurred while processing 'sources: TypeError: can't access dead object
    Stack: [email protected]://devtools/server/actors/utils/TabSources.js:240:5
    [email protected]://devtools/server/actors/thread.js:1238:7
    [email protected]://devtools/server/main.js:1286:15
    [email protected]://devtools/shared/transport/child-transport.js:66:5
    Line: 240, column: 5 main.js:1155
    _unknownError resource://devtools/server/main.js:1155
    onPacket resource://devtools/server/main.js:1289
    receiveMessage resource://devtools/shared/transport/child-transport.js:66

    From an end-user point of view, same behavior: new empty tab is opened and that's it.

  • Dear @brenty and @ag_ana,

    It looks like that the problem is related to Browsing History settings. If it is set to "Never remember history", then the extension does not work. If history is allowed, then it is fine. Maybe this could be fine-tuned in a later update.

    Thanks for your time, attention and help!
    Keep up the good work with 1password. I think it is an awesome product!
    Cheers!

  • ag_anaag_ana

    Team Member

    Thank you for the update @Lallala, and for the kind words :)

    Please let us know if this happens again. For now, have a wonderful day :)

  • brentybrenty

    Team Member

    @Lallala: Aha. Yeah, that will do it. I'm sorry for the confusion there. Indeed, history is necessary for that it work currently so it can maintain state, but perhaps that will change in the future. Glad that enabling history did the trick for you. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file