Login to my.scouting.org not being filled in properly

I'm currently on MacOS 10.13.6 using Chrome (Version 73.0.3683.86 (Official Build) (64-bit)) and Safari 12.0.3 (13606.4.5.3.1) 1Password 7 Version 7.2.5 (70205002) AgileBits Store (1Password.com account converted from standalone app) Chrome 1Password Extension 4.7.3.90 and Safari's extension ver 7.2.5

I believe that Chrome behavior below is the same (at least end result is same) on my Windows 10 (1709) PC.

The issue:
Goto my login item for my.scouting.org which has the following as the website, and it immediately goes to the recover password and username page and fills in just my username.
https://my.scouting.org/

I see the main login page for that site as it flashes by on its way to the recovery page.

Seems to be running a script and the URL at the top never changes from https://my.scouting.org/

If I manually copy username and password from 1Password to the main login page it will log me in.

Same behavior if using extension or app ie: click item and it launches and fills it as described above.

Slightly different behavior in Safari:
Using Safari's extension (ver 7.2.5) it says on the main page but does not fill in the username, says "The username field cannot be blank" and seems to fill in the password (but I can actually tell its the username because if I manually copy the username from 1Password and pasted it then click login, it does log me in)

Maybe similar issue but not even getting to "dashboard-legacy" unless I manually copy the username and password
https://discussions.agilebits.com/discussion/101236/username-placed-in-wrong-field-on-https-my-scouting-org-dashboard-legacy


1Password Version: 7.2.5
Extension Version: 4.7.3.90
OS Version: MacOS 10.13.6
Sync Type: 1Password.com account

Comments

  • ag_anaag_ana

    Team Member
    edited April 2019

    Hi @Hawkwind!

    Thank you for reporting this! I was able to reproduce this issue on my machine, so I will open an internal issue so that the developers can look at this :)

    Seems to be running a script and the URL at the top never changes from https://my.scouting.org/

    The problem here is actually that the login page and the recovery page are the same page :D If you go to https://my.scouting.org/ in your browser, you will see that you can scroll right to see the recovery form. Because this is technically the same webpage, 1Password doesn't know what the correct username field is, since there are two :)

    ref: xplatform/filling-issues#458

  • ag_anaag_ana

    Team Member

    @Hawkwind I have also added some more information to my reply, including a screenshot :) I hope this helps!

This discussion has been closed.