[Chrome] "Standalone vaults not supported"

When Chrome starts (and when 1Password restarts after an update and Chrome is already running), a notification appears telling me that standalone vaults aren't supported.

Chrome notification

If I had to guess, I would guess that it has something to do with the fact that I have multiple Chrome profiles open. All but one of these profiles use the desktop app and accompanying extension, but one profile uses 1Password X. Not sure if you've tested this scenario; if you have, maybe you can tell me whether I'm on the right track and, more important, how I can make the notification go away.

Thanks.


1Password Version: 7.3 b10 (70300010)
Extension Version: 4.7.3.90 (X ver. 1.15.8)
OS Version: macOS 10.14.5 beta 2
Sync Type: iCloud+Dropbox

Comments

  • dtearedteare Agile Founder

    Team Member

    Hey Nik! It's great to hear from you! 👋🤗😘

    As the wonderful user you are you're on the 1Password X beta and have found the new feature that allows us to integrate with 1Password for Mac. This is really cool for features like Touch ID and sharing lock state. In order to integrate, we create a secure communication channel between them which requires both sides to have the exact same accounts. Additionally, accounts are needed as we rely on the server component when establishing trust. Each side generates a set of keys and uploads the public key to the 1Password servers to prove to the other side that they are trustworthy.

    Long story short you won't be able to integrate 1Password X with 1Password for Mac while having standalone vaults. You can either migrate over or you can turn off this feature entirely within 1Password X Settings. We're in the middle of some wording changes there so depending on when you do this you may see a different message, but in the current beta it's called Connect to 1Password for Mac. Turn that switch off and that notification you see should stop appearing. Also in an upcoming beta clicking that notification will open the proper support guide that walks though this in more detail. 🙂

    I hope you're doing great. ❤️

    ++dave;

  • Hey, Dave. Doing well, thank you. Wishing you the same.

    Long story short you won't be able to integrate 1Password X with 1Password for Mac while having standalone vaults.

    Got it. Thanks very much for the clarification; I'll disable the integration.

  • Hi Nik :smile:

  • Hello 1Password team,

    I am using both a local vault (which I am not going to ditch) in my 1Password desktop app and a subscription of 1Password in 1Password X and the desktop app. The sync feature of the beta is basically necessary to have it unlocked together with the desktop app. How can I get rid of that notification. It is unnecessary to notify every time I start the browser.

    BR and thanks.

  • YaronYaron

    Team Member

    Hey @Tabaluga!
    The only way to get rid of that notification is to remove 1Password X and install the regular extension that works with the desktop app.
    1Password X is relatively new and we're constantly exploring its nature and how users interact with it. This may change in the (near) future, but until then it is important for us to notify you about it, since most users do not understand why not all of their passwords show up in 1Password X.

  • dtearedteare Agile Founder

    Team Member

    Hi @Tabaluga,

    @Yaron is right that switching extensions will avoid this notification, but there is another way as well: you can disable Desktop App Integration in 1Password X. By doing so you are telling 1Password X to run completely independent of 1Password, so it will have no idea that you have standalone vaults.

    You can configure this within 1Password X by right-clicking on the toolbar icon in your browser and selecting Settings.

    I hope this helps.

    ++dave;

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file