Wrong p/w in Apple Mail for Gmail on Mac

For the last week I've had problems logging in to Mail on my Mac, but_not_on iOS. It never occurred to me that 1P was the problem so I kept updating my p/w both in the app and on the server via web mail. Then of the four a/cs [2x SMTP, 2x IMAP] I have I found random a/cs were reverting to different p/ws I used years ago.
Today I thought to look at 1P and there they were, wrong, but when I overwrite them it seems not to work.
Given that my friends get deluged with security emails from Google every time I change my p/w [and tells me I've logged in from a new device] I'd rather fix it in 1P so I can keep my latest and very long p/w on the server.
Any help in plain English appreciated!
Cheers, Colin


1Password Version: 6.8.9
Extension Version: 4.7.3.90
OS Version: 10.14.4
Sync Type: iCloud I assume

Comments

  • LarsLars Junior Member

    Team Member

    @colinc - I'm sorry for the trouble! However, I don't know how much help 1Password can be in this case, as entering your correct credentials into your email client is something you have to do manually via copy/paste (or keyboard entry) into your chosen email client. 1Password doesn't "revert" these saved credentials, no matter what is or is not stored within the 1Password database.

    For webmail sign-ins, you can of course use 1Password to fill your credentials, just like any other compatible website. But here again, 1Password will only fill what you've saved. I'm not sure what you meant by "...when I overwrite them it seems not to work." Are you trying to change the password in your saved Login item for those webmail sites? If so, how specifically are you going about it? Here are the instructions for changing a password for any given website; is this what you were doing? If not, please try that method. If this IS what you were doing, can you explain a bit more what you mean by "it seems not to work?" Thanks.

  • I am clearly very confused.

    Looking again at 1P in edit mode it has passwords for three Gmail a/cs I have. On one which I've not used in years it has a very old p/w, but that's to be expected.

    For my main one I clicked in the wrong place just now and 1P generated a new p/w, but under previously used the newest shown was the one BEFORE last, and on my secondary account 1P has one that is about three versions old.

    Despite the above logging to web mail is unaffected, it is only in Apple Mail that I have a problem. I suspect that my best option is to delete the two main accounts in Apple Mail [yesteday the secondary one was still working, but it was not this morning] and delete all Google p/ws in both Keychain and 1P and start afresh. I think I need to do it this drastically as for each account [email protected] I also have in Apple Mail an alias where xxxx is the domain, so [email protected] for [email protected]

    It'll take a long time to restore more than a decade of mail on my Mac but meanwhile as it is IMAP I assume my accounts on iOS devices will not be affected if I use my last p/w [that is if 1P allows reuse].

    I'm sorry if this sounds confused, but I am!

  • LarsLars Junior Member

    Team Member

    @colinc - I'm really sorry for the trouble, and I certainly hope you don't have to lose a decade's worth of email! I don't think that should be necessary, but advising you on gmail and/or native client management is beyond the scope of what we do here. However, unless there's more going wrong than I think, you shouldn't have to take that kind of extreme measure. I would think you could just change the password in Mail.app or in the Google accounts in System Preferences to the proper password from 1Password that you know works in the webmail client? I'm more than willing to help you with what I can help you with...but I'm not sure 1Password help is what you need here. Let me know if there's anything further I can do for you.

  • While I never doubted you were right Lars, the mystery deepened! Overnight my mail has all come back on my iMac [literally while I and my Mac slept!].
    I have one new [empty] account in Apple Mail which I think was from when I started to set up my accounts from scratch, but otherwise all is normal.
    I have been locked out of my mail on my Mac [not on the web interface, or out of any other Google service] for a whole week, and then it returns even though I'd deleted a whole raft of passwords days back.
    Google had a UK outage for a few hours yesterday, but this seems to have had nothing to do with it.
    Thank you for trying to help.

  • LarsLars Junior Member

    Team Member

    @colinc - I guess all's well that ends well? :) Let us know if there's anything 1Password-related we can assist you with in the future. Cheers!

  • Thanks Lars, all well except I have even less hair!

  • LarsLars Junior Member

    Team Member

    :) :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file