why does 1PW6 is now asking me to sign in with my Mac pw ???.

almost every time I use 1pw or 1pw mini, I get a pop up box asking me for my Mac's pw. Sometimes even entering that does not work to fill in password.
I'm using 2 Macs with Mojave 10.4.4 and 1pw 6.8.9


1Password Version: 6.8.9
Extension Version: 4.7.3
OS Version: OS X 10.4.4
Sync Type: DROPBOX
Referrer: forum-search:Why does 1PW6 is now asking me to sign in with my Mac pw ???.

Comments

  • LarsLars Junior Member

    Team Member

    @SausalitoDog - I'm sorry for the trouble. Would you be able to take a screenshot of the pop-up you’re seeing, and post it in a reply here?

  • Here is what I get...actually I got it fewer times today, so there may be some explanation that I don't know about...???


  • LarsLars Junior Member

    Team Member

    @SausalitoDog - so, do you see the little blue Safari logo on the lock there? That's a Safari prompt, not a 1Password prompt. :) More specifically, it's an HTTPAUTH prompt, which is becoming more and more uncommon (though still obviously not completely unhead-of). 1Password cannot fill these forms because they are (as you see) not themselves web pages (with which 1Password can interact), but rather from the browser itself. You can save these passwords in 1Password...but you will always need to copy/paste them.

  • Thanks, Lars. I figured it was something like that but it definitely mars the use of PW apps. Seems strange that this just began out of the blue. I can see that it is not all sites, so I will try to figure out if I can avoid the ones that are so pesty :-) Thanks for your help.

    tom

  • LarsLars Junior Member

    Team Member

    @SausalitoDog - it didn't just begin out of the blue; this has been the case in 1Password for Mac for years. What may have changed is that you've added new(er) sites that happen to use HTTPAUTH, so you're noticing it more now where previously you weren't at all. Glad I could clear things up, however! :)

  • I don't want to change browsers but a little experimenting with Firefox and it seems F may work on same site!!! ???

    I'll complain to United Airlines :-)

    cheers,

    tom

  • LarsLars Junior Member

    Team Member

    @SausalitoDog - I'm...surprised to hear that, as the site should behave the same regardless of the browser you're using, but if it works, great. :) :+1:

  • LarsLars Junior Member

    Team Member

    @SausalitoDog -- you know what? I think I mis-diagnosed this. Those aren't actual HTTPAUTH prompts (though they certainly look like them, which is what confused me). I think that's an issue with you still having the Safari password manager turned on, and it's asking you to confirm you're you on this computer before you have access to this store of passwords saved in Safari. Which you don't need, because you have 1Password. Try this: open Safari's Preferences > Passwords and turn OFF Safari's password manager. See if that makes any difference (might need to restart Safari, although you shouldn't).

  • Lars- That was definitely the problem. I've been using 1PW since very early in the game and from the start you warned against using both, but since I had no problems I never turned off the apple pw app (which now is pretty handy on a MBP touch) but I can see I have to. Once I turned off auto fill, 1PW worked fine again.

    Many thanks for the second look at my issue... GREAT SUPPORT FOR A GREAT PRODUCT!!!!!

    tom

  • ag_anaag_ana

    Team Member

    On behalf of Lars, you are welcome @SausalitoDog!

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file