Continuing Problems Managing Logins

OK gurus, as one trying my best to switch from Roboform to 1Password, I am getting extremely frustrated. After hours of frustration and help from MRC I have successfully migrated my logins from Roboform. I am now trying to "clean up" my logins and am running into so many problems I don't know where to start. As I try to use my 1Password logins, some from the migration do not work. As such I have to start from scratch and create a new login for the particular website. Reference the below screen shot on Chrome where it shows "Delta with a line below" it in my tags (a folder I created in Roboform) for Airline sites. This is not a working login and I need to delete it. I have already deleted it using 1Password for Mac app but it still shows here in Chrome, however it does not show in Safari. Question 1: Why do these things not talk to each other and how do I make them do so? Next: Again, in Chrome, when I go to logins on the left side and scroll down to the "Ds" it does not show this "Delta with a line below". What it does show is the proper login for Delta and when I click it, it works.

I feel like maybe what I need to do is delete all logins, forget migrating from Roboform, and just start creating each login as I need it one by one.

Please help! Thank you in advance!


1Password Version: 1 Password 7
Extension Version: ???
OS Version: OS 10.14.4
Sync Type: ???

Comments

  • LarsLars Junior Member

    Team Member

    @BenBob - sorry for the trouble. It looks as if you've installed 1Password X into Chrome, instead of the desktop-app-required companion extension. That's fine; 1Password X is a great product, but it's not the same thing as what you've got in Safari, which is the older (but still current) 4.7.3.90 extension. If you type chrome://extensions/ into the address bar and press enter, do you see 1Password X, or 1Password extension (desktop app required)?

    Now, if you open 1Password 7 for Mac itself (the main app, not the mini or the extension) and click Preferences > Vaults, what do you see? How many vaults, and what are their names?

  • Thank you Lars. Yes I have 1PasswordX on my Chrome browser because I thought I had to use that for 1Password to work in Chrome. That would explain why I am getting the notification shown in screen shot 1 below (I didn't understand why it was asking me to download the extension since I already had it). In answer to your question #2, I have 2 vaults as shown in screen shot 2 below. So what is the best way to manage all of this between browsers?

  • LarsLars Junior Member

    Team Member

    @BenBob - in Safari, the 1Password extension is built right into the main app as of version 7 of 1Password for Mac -- no extra extension to download. Safari is the only browser that works this way, however. For everything else (Firefox, Chrome, Brave, Vivaldi), you would want to download either 1Password X or the older (desktop app required) extension. There's no reason you shouldn't be able to use 1Password X, since all of your vaults/data are in your 1password.com account; no local vaults. I would recommend going through your imported data in the main 1Password app and removing any of the "delta with a line below"-type items you find; ones that may have been created in error during the conversion process. Once that happens, you should see the same thing in both 1Password X and in 1Password 7 for Mac.

  • Thank you Lars but that was what I was trying to say in my previous post. I have deleted the "delta with a line below" in the main app and it does not appear there. But it still appears in 1Password X.

  • LarsLars Junior Member

    Team Member

    @BenBob - it may not have synced yet. Try locking both 1Password 7 for Mac and 1Password X, then unlocking both again.

  • MrCMrC Community Moderator
    edited April 17

    @BenBob,

    I don't think you need to resort to tossing an entry and starting again. Instead, just correct an entry that isn't working for you. The burn it to the ground / rebuild strategy is rarely productive, and often is prompted by some minor misunderstandings and/or frustration.

    The converter should have placed all of your data into the records. In the case of the roboform converter, the target field is difficult to identify, because Roboform doesn't specifically identify the fields in the export (it works by just remembering the form data you filled, whereas 1Password has specific fields for 3 key components: URL, username, and password). The converter uses common web page form field names, as empirically found by users over time, to help map Roboform's web data into the correct 1Password fields. Sometimes web fields are horribly and uselessly named with labels such as "field 1" and "field 2" - its impossible to map those automatically and algorithmically into 1Password's "password" and "username" fields, for example. The converter does its best given ambiguity of the input data.

    That said, you'll find the un-mapped data in an item's Notes area. Just copy the value into the correct field(s). Once you have the three pieces of data in place for a Login, the login will generally work. Note: some of your URLs may not be the correct website Login "landing pages". You can go to the web page's login area, and copy the URL, or login and let 1Password's extension help you do the update to the existing record.

    Let me also suggest - since you are learning 1Password - do your cleanups as you actually work with, and use items, rather than trying to do them all at once. You'll improve your efficiency as you gain more understanding how 1Password works, and learn how you work best with 1Password.

  • Thanks again Lars. Everything was already locked and when I opened them up it was still the same. I'm thinking I may just delete all and input everything as I go along. It will take some time but it will help me clear out many logins that I really don't use and hopefully work better for organization and learning how 1Password works.

  • Thanks again for your input MRC. I just don't understand why this one rogue Delta login remains in Chrome, even though I deleted it in the 1Password app.

  • MrCMrC Community Moderator

    @BenBob,

    You're welcome.

    I don't know the answer to your Delta login issue, sorry.

    Your posts, and troubles, have prompted me to update the roboform converter to handle version 8's CSV export feature (this has actually been on my To Do list for a while). This is a much better export format than the silly print list (which was the only format in previous versions, and will still be required for Identity and Safe Notes). I'm working on that now.

  • Good luck MRC!

  • MrCMrC Community Moderator
    edited 12:24AM

    The roboform converter has been updated to support the CSV export format available for Logins + Bookmarks.

  • brentybrenty

    Team Member

    @BenBob: It sounds like you may have saved those (Delta) login credentials in Chrome itself:

    https://support.google.com/chrome/answer/95606?co=GENIE.Platform=Desktop&hl=en

  • Thank you Brenty and MRC!

  • BenBen AWS Team

    Team Member

    On behalf of Brenty and MrC you're most welcome. :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file