Disable credit card handling in chrome

I use Google payments to store and manage my credit / debit cards, with 1Password enabled it takes control of managing the credit cards and the only way to disable this feature seems to be disabling 1Pass all together.

Is there a way to disable just the credit card management part only?

(In chrome this is in Settings > Auto-Fill > Payment Methods. It will say 1Pass is controlling this setting and the only option is to disable it)


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:disable credit card

Comments

  • ag_anaag_ana

    Team Member

    Hi @ementalo! Welcome to the forum!

    If you use Chrome to fill your credit cards, Chrome should have priority during filling. If you don't invoke 1Password by clicking on the browser extension, or with the keyboard shortcut, Chrome should be the one filling your data automatically on the page.

    Are you seeing a different behavior on your device?

  • Thanks for the welcome!

    It seems that chrome has just handed all responsibility over to 1Password for that and the only way to regain the functionality is to disable 1Password all together.

    Here is what it shows in chrome settings, and the disable button just disables the whole extension not just for cc filling in.

  • LarsLars Junior Member

    Team Member

    @ementalo - I tried unsuccessfully to replicate the behavior you're seeing here in my own setup, but it would be quite helpful if I knew what your setup actually IS. Can you tell us:

    • What specific version of OS you have installed?
    • What specific version of 1Password native application you have installed (if any)?
    • What specific version of 1Password X you have installed?
    • What specific version of Chrome you're using?
    • Anything else you think might be important to us being able to help you troubleshoot this issue.

    In my own setup using macOS 10.14.4 (“Mojave”), 1Password X beta version 1.15.8 and stable-channel Chrome (73.0.3683.103) (as well as 1Password 7 for Mac 7.3.BETA-12, though I'm not sure how relevant that is), I see the following:

    ...which is what I'd expect.

  • @Lars

    MacOSX High Sierra 10.13.6.
    No Native Version
    1Password X – Password Manager 1.14.3
    Chrome Version 73.0.3683.103 (Official Build) (64-bit)

    ......

    I think I have figured it out now though. On the settings page if turn off the option "Make 1Password the default password manager" then I can now use chrome for the payment methods....which actually makes sense.

  • LarsLars Junior Member

    Team Member

    @ementalo - glad to hear it. :)

  • I am stuck in this position with no way out of it now on Windows 10 up to date, Chrome Version 78.0.3904.108 (Official Build) (64-bit) - it's either turn off 1password completely or no Google payment methods. I can't find that setting anywhere in the settings but I could be missing it. Any help you can give would be appreciated.

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @matarua! I'm sorry for the trouble. Can you tell me where you're seeing the specific setting regarding making 1Password X the default password manager, in Chrome? And also, what version of 1Password X do you have installed?

  • Thanks Lars, hopefully I can sort this out. I can not see that setting for payments mentioned above at all, its mentioned in a solution above and I can not find it.

    But I can find the setting to use 1password in this location of Chrome settings > Settings > Autofill > Passwords > it shows "1Password X – Password Manager is controlling this setting [DISABLE}

    Also I can find the setting to use 1password in this location of Chrome settings > Settings > Autofill > Payments > it shows "1Password X – Password Manager is controlling this setting [DISABLE}

    What happens if I press the [DISABLE} button it turns off 1password completely.

    I can't just turn off credit cards for example.

  • kaitlynkaitlyn

    Team Member

    Hey @matarua! Sorry for the confusion. It won't be possible to disable only credit card filling in 1Password X. However, you can still enable Chrome's autofill on top of 1Password X. It's not something we'd recommend since having two password managers enabled at the same time can result in each of them competing for attention at times, but it is possible. First, you'll want to disable the 1Password X setting that's called Make 1Password your default password manager. That'll allow you to control Chrome's autofill settings so you can enable the "Save and fill payment methods" option.

    Let me know how it works for you!

  • Hey Kaitlyn, I will try that. I can shift the payment to 1password maybe - but just so you know 'Autofill' is not just passwords and has addresses and other data stored saving a whole bunch of time to fill out forms etc - that's all gone now making me have to type out every single line again on a new form rather than autofill giving it a shot and me refining it. The previous version of 1password that I had which was version 4 worked fine, I have now started paying the upgrade cost to get the updated manager as it was having issues across my many devices and plugins started clashing and it became an issue - I hate to say we now have a more featured less featured product to deal with that changes workflow hugely for somebody who works a lot in the browser creatively for clients etc. This setting, payments, or autofill should be setting that can be turned off inside the 1password extension - that is a given and I don't run two password managers but they were both on, I use 1password for my passwords as that has that extra layer of security, but some other things like payments already have that and some other stuff is just non secure helpful stuff to me like address autofill (emails of which there are many, and physical) - so are you saying that if I disable 1password autofill it stays on? But I disable 1password payments and the extension quits completely? Seem counter-intuitive to me :-/

  • Kaitlyn, when I click 'Disable' on any of the autofill areas it turns off the extension, there's no way around it. So all my addresses are lost, payment methods too, or I lose 1password - why was this change ever made, it's insane :(

  • BenBen AWS Team

    Team Member

    @matarua

    It sounds like you'll want to turn off the "Make 1Password the default password manager" setting within 1Password X's settings page. Please let me know if making that change provides the desired result. We'd recommend having it on, and using 1Password to manage your credit cards and addresses, but if you'd rather use Google you'll need to turn it off.

    Ben

  • Thank you Ben, was at wits end trying to figure this out and when you said 'within 1Password X's settings page' I went in to my extensions and to the extension and where all the settings are and that is not option again, so had an aha moment and right clicked on actual 1password icon to look for settings there and then after a few clicks found that and got to see a whole bunch of settings - turning that off has gotten me back to where I was I think for now.

    If I was to turn this on again in the future how does 1 password handle addresses and payment methods in comparison to Google? Does it have any AI to also help autocomplete other forms? I am a designer and always filling out forms doing testing and stuff and it speeds up my workflow for Google to just remember what I did last time and offer that up as a suggestion. Having to unlock 1 password to do that would be a pain so does it auto suggest when you are locked?

  • BenBen AWS Team

    Team Member

    so does it auto suggest when you are locked?

    It will suggest unlocking. ;)

    If I was to turn this on again in the future how does 1 password handle addresses and payment methods in comparison to Google?

    I'm not familiar enough with how Google handles these things to make such a comparison, but I can say that 1Password is capable of filling credit card details (number, verification code, expiration date), as well as address details.

    Does it have any AI to also help autocomplete other forms?

    While it can likely handle generic forms, it wasn't necessarily designed to handle filling things other than logins, credit cards, and identities (addresses). As such your mileage may vary.

    I am a designer and always filling out forms doing testing and stuff and it speeds up my workflow for Google to just remember what I did last time and offer that up as a suggestion.

    Ironically, perhaps, that is how 1Password got started. Dave and Roustem found a need to fill in web forms while testing their software and so they developed a generic form filler. After giving it some thought they figured the functionality could be useful to a password manager, and started building 1Password ("1Passwd" at the time).

    Ben

  • user1337user1337
    edited February 13

    I'm having this same issue with the browser extension controlling the Google Payments, however, I do not see where to disable the 1Password setting under the settings. I can only enable the Google Payments through disabling the browser extension entirely, which obviously it not optimal.

    Win10 1909
    Chrome version 80.0.3987.100
    1Pass extension version 1.18.0

    Here's a screenshot of the settings that aren't account specific.
    https://imgur.com/a/AFZVE0X

  • kaitlynkaitlyn

    Team Member

    Hi @user1337! The setting you'll want to disable is Make 1Password the default password manager. That automatically disables Chrome's autofill feature. That said, are you strictly looking to fill your credit card information? If so, that's something that 1Password can do if you store a Credit Card item. If you need help with that, just let me know and I'd be happy to walk you through it.

  • Hi,

    The setting you'll want to disable is Make 1Password the default password manager. \
    Frustratingly, this is the exact thing that I mentioned I couldn't find at all either in the Chrome extension, Windows app, or site despite digging around for 30 minutes. Where should this be located since it's not available in the settings of any of the 3 platforms.

  • ag_anaag_ana

    Team Member

    @user1337:

    It's under the 1Password X settings, in the General section:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file