Keyboard shortcut doesn't work

Hi,

So here is something weird :

  • as soon as the browser is launched (Vivaldi 2.4.1488), the keyboard shortcut doesn't work until I manually clic on the extension and unlock it. Clicking on the 1password icon in the macOS taskbar does nothing but flickering. After being unlocked first time, the shortcut for the app works again but :
  • the keyboard shortcut for the app doesn't work on certain website (like agibits.com, twitter and many) but works on some others (live.com, here.com for example)
  • the extension shortcut never works (tried to setup different shortcuts)

Is that relative to Vivaldi ?

Regards

Comments

  • kaitlynkaitlyn

    Team Member
    edited June 2

    Hey @Ashokleyland – thanks for the reports! I'm a fellow Vivaldi user as well. :chuffed:

    • I've seen this happen sporadically, but I haven't nailed down the pattern just yet. Could you let me know what version of 1Password X and 1Password for Mac you're using? We've been releasing quite a few betas, so I want to make sure I'm testing the right one.
    • We've made some recent improvements in regards to the keyboard shortcut ⌘-\ that should help here. Keep an eye out for an update to the 1Password for Mac beta.
    • It's quite the bummer, but extension shortcuts don't seem to work properly in Vivaldi at all. It's been reported in Vivaldi's forums here and here, for example. You're welcome to report the issue to them again or comment on one of those forum posts just to check in and see where it's at on their priority list. I'd love to know as well!

    The first and last bullet points are relative to Vivaldi, but the other was happening briefly across multiple browsers. Like I said, that one should be resolved soon, though. Again, we appreciate you reporting this to us, and thanks for being on the 1Password X beta train!

    ref: x/b5x#1116, x/b5x#334

  • Hi @kaitlyn, i suspected it is Vivaldi related issue, I didn't take the time to test with Chrome but I just did and it works fine, I wish there was a beta for Firefox though.
    1PX : 1.15.12
    1password : 7.3 BETA-12
    Anyway, thanks for your answer.

  • littlebobbytableslittlebobbytables

    Team Member

    Hello @Ashokleyland,

    As a Vivaldi fan myself it's a shame it seems to be limited to Vivaldi. Hopefully it will see some love and other than a couple of minor blips I do love the browser.

    It would be nice if we can get a publicly available beta for Firefox like we have for Chrome. Hopefully that is something we can address at some point.

  • The keyboard shortcut (ctrl+shift+x) isn't working for me either, using Chrome on Windows 7. It's the only keyboard shortcut visible via Chrome's Menu : More Tools : Extensions : hamburger icon : Keyboard shortcuts. (Which you really should better publicize, for people who maybe have a hotkey conflict, or maybe experience this bug.) And Nir's HotKeysList reveals no conflict, either.

    After I click the browser-toolbar icon, ctrl+e works just fine.

    Help?

  • kaitlynkaitlyn

    Team Member

    Hey @Netpog! The issue that was originally reported in this thread was in Vivaldi, a different Chromium-based browser. I know the bug in regards to the keyboard shortcut is specific to Vivaldi, so it seems like you're running into something else. Have you attempted to change the keyboard shortcut recently? I'm wondering if deleting and re-adding 1Password X would help out here. Would you mind giving that a try and letting me know if you have any better luck using the keyboard shortcut?

  • Sorry for the slow response, @kaitlyn . I finally did as you asked. Deleting and re-adding 1Password X did not change the behavior: the ctrl+shift+X keyboard shortcut still didn't work. (But the re-install sure did get Google's Software Monitoring Tool excited! Took most of my CPU for a couple minutes.)

    Only then I thought to delete and immediately re-define the keyboard shortcut (via the extension manager, via the link in the 1Password X Settings). And now it works just FINE.

  • kaitlynkaitlyn

    Team Member

    Thanks for the update, @Netpog. I had assumed that deleting and re-adding 1Password X would essentially do the same thing, but I guess not! I'm glad you were able to get the keyboard shortcut working again simply by re-defining it. I'll keep that in mind in case anyone else runs into the same thing. I appreciate it!

  • kaitlynkaitlyn

    Team Member

    @Ashokleyland – I figured it'd be a good time to call you in too. Recently, I found that the command-shift-X keyboard shortcut started working in Vivaldi for me, so they must have fixed it! Hopefully you're finding the same. :)

  • Glad I found an easy work-around. Can't imagine why it's necessary. I hadn't used hotkeys in Chrome, otherwise. But maybe a past extension, long deleted, skunked my environment?

    I do like the feature whereby I'm prompted to use that shortcut, when I need to sign back into 1Password. Nice.

  • kaitlynkaitlyn

    Team Member

    @Netpog – That very well could have been it. That's great it's working for you now, though. I hope you're having a good week! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file