Unable to use 1Password on Northern Trust's new login page

Northern Trust (https://www.northerntrust.com/united-states/home) has a new login page and I'm unable to get the username/password fields to fill consistently. I'm getting very bizarre behavior. Sometimes I can get the User Id to fill, sometimes I can get the Password to fill -- I'm never able to get both to fill at the same time. Note - we use the token login field as well, but I know enough to tell it not to submit the form and we manually fill in the token field. I tried saving the site manually, but it actually stored •••••••• rather than the password. Even after changing field to store the correct information, it wasn't able to automatically fill it.

Any ideas?


1Password Version: 7.3.684
Extension Version: 4.7.3.90
OS Version: Win 10 Enterprise v1809 (OS Build 17763.437)
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @_pk: I was able to successfully save login credentials manually using 1Password there using an internal build. It may also work in the beta:

    https://support.1password.com/betas/?windows

    I'd be interested to see if it works for you, because 1) I believe all of the filling improvements we've made are already in the beta and 2) I can't be certain that filling is success given that I don't have a real account and they're doing some weird stuff there:

    <input type="password" class="css-la5i1d-styledInput" aria-label="password will be visible while inputing" tabindex="3" aria-required="true" id="accountAccessPasswordField" name="accountAccessPasswordField" autocomplete="on" placeholder="Password" autocapitalize="none" data-op-id="1">
    

    Would you be willing to give that a try? It would also be helpful to know the browser version you're using.

  • _pk_pk

    @brenty The beta does indeed handle the page correctly as far as I can tell. I'd rather not have to opt my users into the Beta track going forward. Is there any estimate as to when the rest of these 1Password Brain improvements will hit the stable channel?

    P.S. - we're using the Chrome extension.

  • littlebobbytableslittlebobbytables

    Team Member

    Hello @_pk,

    Sadly we're unable to offer even a guess as to when any potential update is publicly available. I do apologise but from past experience we've found the frustration and annoyance at not managing to keep a claim is worse than being unable to unequivocally state something.

    I don't know if it's of any use at all, it may be you would place it in the exact same group as using a beta but if you are a 1Password account user then our 1Password X extension may be a potential alternative. It tends to be a bit ahead of the native clients when it comes to filling improvements so if filling works in the beta I would expect 1Password X to fill as well. It is currently a standalone extension that doesn't connect to the native client although that is something we're hoping to add in the future. If this could be a possibility then our support page Get to know 1Password X will be a good place to start.

    I am sorry I couldn't offer even a potential date for the next stable build.

  • _pk_pk

    This login page is back to not working at all for me. The username appears to fill, but as soon as you change focus to the password field, it blanks out what was in the username field. I'm using the PC Beta with the Chrome extension.

  • ag_michaelcag_michaelc

    Team Member
    edited June 13

    Hey @_pk, I'm sorry for the troubles you're experiencing with this website. I was able to reproduce this issue in multiple 1Password clients, so I'm reporting this to our developers so they can work on a fix for this site. Thanks for your patience as we work to correct this and improve 1Password for everyone. :smile:

    ref: xplatform/filling-issues#576

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file