Firefox Extension says "desktop app required"

Hello AgileBits Team,

The 1Password extension for Firefox has suddenly stopped working for me on my Mac. When I open the Add-ons Magnager in Firefox, it says "desktop app required" in the extension title. The problem is: I do have the desktop app installed, and macOS, Firefox, the 1Password extension and the 1Password app are all the latest version.

I have tried rebooting as well as removing and re-installing the 1Password extension for Firefox, but none of these solutions fixed the problem for me. What can I do to make the extension work again? I am on macOS 10.14.4 Mojave with Firefox 66.0.4 and 1Password 7.2.5 from the Mac App Store.

Comments

  • brentybrenty

    Team Member
    edited May 7

    @kaffeeundsalz: "desktop app required" is part of the name of the 1Password desktop extension that works with the Mac and Windows 1Password apps. It's said that for at least a couple years. :) For example, the Chrome version:

    https://chrome.google.com/webstore/detail/1password-extension-deskt/aomjjhallfgjeglblehebfpbcfeobpgk?hl=en

    You state that

    The problem is: I do have the desktop app installed, and macOS, Firefox, the 1Password extension and the 1Password app are all the latest version.

    That doesn't sound like a problem to me at all. Can you clarify what you're having trouble with? Are you maybe just thinking there's a problem due to the misunderstanding with the name?

    You also mentioned that "The 1Password extension for Firefox has suddenly stopped working", but I'm not sure what you mean exactly. You may just be encountering a Firefox issue that Mozilla fixed over the weekend, so make sure you check for updates in Firefox and leave it open to apply them:

    Known issue: All Firefox extensions disabled

    Let me know. :)

  • edited May 8

    Hi @brenty,

    thanks for your kind and fast response. I really appreciate it. First off, let me apologise. I mistakenly assumed that "desktop app required" is kind of an error message that only shows up when something is wrong with the extension. I never spent much time with the Firefox Add-ons Manager, so I didn't recognise it as a note that is just part of the name. Sorry for being stupid.

    Now, the problem I have is this: Firefox and 1Password behave just as if the extension is not installed or enabled (but it is). On creating a new account somewhere on the web, 1Password no longer asks me whether I'd like to save the login details. Filling logins is also no longer possible; when I go to a login page an hit the keyboard shortcut for "Fill Login or Show 1Password", it's no longer the extension dialog that pops up but just the 1Password mini application from the menubar. When I then unlock my vault, 1Password tells me to install the Firefox extension (which, again, I already heave):

    Clicking the "Add 1Password to Firefox" button brings me to the download website of the 1Password browser extensions. Installing the extension from there works just normal, but it doesn't solve my problem. It also doesn't help to remove the 1Password extension first.

    I also cannot access 1Password by clicking the extension toolbar icon in Firefox. Doing so just gives me an empty flyout dialog:

    I have read your link concerning the Firefox certificate issue. However, I am not sure how it could help in my case. If I understand this correctly, Firefox 66.0.4 should fix the issue, and that's the exact version I have installed. Also, I recognise that the certificate issue should affect all Firefox extensions, but my other add-ons just work.

    I hope that I was able to clarify the issue.
    All the best
    kaffeeundsalz

  • littlebobbytableslittlebobbytables

    Team Member

    Greetings @kaffeeundsalz,

    It may be we need to review a diagnostic report but just before we do can you try the following for me please.

    1. Restart your Mac.
    2. Launch 1Password and unlock.
    3. Launch Firefox and attempt to use the 1Password extension.

    Even if that doesn't yield any success a clean starting point for generating the diagnostic report can be useful in trying to determine what the cause is. For the diagnostic report itself, this link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post that ticket ID here it will help us locate your diagnostic report and we'll see what it reveals.

  • edited May 10

    Hello @littlebobbytables,

    I followed your three-step instructions above, and it did yield a success – because now I can perfectly use my 1Password extension just as I'm used to. Thank you very much!

    Interestingly enough, I had restarted my Mac at least twice before I had any guess that you would include this as a recommendation in you forum post. What I don't understand is why these first attempts of rebooting and relaunching 1Password didn't solve the problem, even though I was basically following the steps that would later become your instructions.

    In further examining the problem, I also noticed that it was indeed not just the Firefox extension that had stopped working. In fact, I wasn't able to use 1Password in any of my browsers, so I suspect something must have been wrong with the communication between the extensions and the app.

    Anyway, I'm happy to report that my problem is now solved.

    All the best
    kaffeeundsalz

  • ag_michaelcag_michaelc

    Team Member

    Hey @kaffeeundsalz, I'm glad Adam and Brenty were able to help you out and get things up and running again. :smile: We're here for you if anything else comes up!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file