Blank page when using 1Password X in Firefox

Hi!

Due to the recent problems with the 1Password 4 add-on in Firefox I moved from 1Password 4 to 7. Now the 1Password X add-on is installed but shows a lock icon and when I click on that icon it I get an empty page. The address field in the browser says: moz-extension://63dbd60b-a1a3-45d0-beb2-04e388597f90/app/app.html#/page/welcome (but well, the browser page is empty).

I have the latest Firefox 66.0.5, I don't use private mode, and I do have history enabled.

If I remember well, 1Password X did show up a few days ago in Firefox 66.0.4, but at that time I didn't yet have switched to 1Password 7.)

Need your help.

Thank you, FF


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • GregGreg

    Team Member

    Hi @fackel,

    Thank you for getting in touch! :+1:

    It sounds like you bumped into a known issue. Could you please check if either of the following preferences are set in Firefox?

    • Never remember history
    • Always use private browsing mode

    Please try to disable either of those preferences and check if the issue remains. Additionally, please try to install the latest version of 1Password X (1.15.1) that we released yesterday.

    Thanks!

    ++
    Greg

  • Hello Greg,

    As stated in my post, neither of the two options is active (I read DaltonD's post, so thats why I started a new discussion on this topic).

    FF

  • GregGreg

    Team Member

    Hi @fackel,

    Have you installed 1Password X 1.15.1? Does the issue remains with it?

    Cheers,
    Greg

  • Yes, 1.15.1 got installed, but the issue remained.

    FF

  • GregGreg

    Team Member

    @fackel: This is quite strange. Have you restarted Firefox completely after the update?

    Also, please try signing into your account at https://my.1password.com. After that you will see a popup asking if you want to add the account to 1Password X. Click yes and let me know if things work better for you after that.

    Thanks!

    ++
    Greg

  • Hello Greg,

    Yes, I restartet Firefox multiple times in the mean time.

    Regarding the account: Since a few hours I don't have one any more--I deleted it after I bought a standalone license of 1Password 7 for Windows. Though, at the time I started this discussion I still had my 1Password account (with the test period active), and I remember that Firefox was listed together with my devices (iPad, iPhone, Windows PC) on which I used the corresponding 1Password app. The apps on Windows, iPad and iPhone currently are still running very well with my 1Password vault synched from Dropbox. It's only Firefox that isn't cooperative.

    Hope this helps.

    FF

  • Thought I should share this: Though nothing is visible in the browser window, there still is some HTML in the page.

    FF

  • ag_mcarlyleag_mcarlyle

    Team Member
    edited May 11

    Hey @fackel! It's definitely a bit strange that 1Password X wasn't working for you, but since you're now on a standalone copy of 1Password, you can't use 1Password X (it requires a 1Password account), so we can't really get to the root of the issue at this point. If you end up switching to an account and want to give 1Password X another go and it still isn't working, definitely let us know at that point in time. Otherwise, since you don't have an account anymore, make sure you grab the extension that ties in to the desktop 1Password 7 app:

    https://1password.com/browsers/firefox/

  • Hi there,

    I fixed the blank page issue with the 1Password X add-on on my computer: I uninstalled the add-on, cleaned-up my Firefox profile from 1Password and agilebits related files, re-installed the 1Password X add-on, and voila ... no blank page any more; the add-on nicely asked me to logon to my account.

    Well, I didn't log on, as I don't have the account any more, but now I'm happily using the older add-on together with my new standalone 1Password 7 - @ag_mcarlyle thank you for the hint.

    Thank you for the support,

    FF

  • ceceliacecelia

    Team Member

    Sweet! I'm happy to hear you were able to sort things out with a reinstall and that @ag_mcarlyle was able to get you set up with the correct extension, @fackel! ❤️

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file