Touch ID stops working after a while

2»

Comments

  • It just happened. Detailed email with diagnostics and screen shots on its way to support email.

  • ag_anaag_ana

    Team Member

    @adam1991 thank you for the update! We have received your email and we will get back to you over there as soon as possible.

    Thank you for your patience!

    ref: NEA-37616-327

  • ok, I have updated and I have an eye on it. So far, so good, not broken since yesterday. I have tried to force what you propose (leave it open, sleep, awake) and no luck.
    I'll produce a screenshot when it happens + diagnostics report.

  • brentybrenty

    Team Member

    Sounds good. While on the one hand we don't want it to break, if it does that could give us more information. :)

  • Hi, just to say that this issue has not happened since last weekend. I keep looking for it.

  • brentybrenty

    Team Member

    Thanks! Keep us updated. And especially be sure to note the details and send diagnostics if you encounter a similar issue after updating to the upcoming stable release. :)

  • Hi, this is just to say that since my last message I have not suffered this problem again. Either for upgrading the version or for any other reason I don't know, this is working perfectly now.

    Thanks for the help.

  • brentybrenty

    Team Member

    Thanks for the update! I'm glad to hear it. It sounds like you should be all set, but we're here if you need us. :)

  • Dear All,
    I to have the same issue. I am running High Sierra 10.13.6 on a macbook pro, and since upgrading from one password 7.2 to 7.3 the touch ID is greyed out in the preferences section of one password. Cannot enable it. Each time i open 1password i have to type in my password.

  • brentybrenty

    Team Member

    @Geneticist: Thanks for getting in touch! As mentioned above, updating macOS is a good first step since Touch ID has been more reliable since the release of Mojave last autumn. But if you're still having trouble, disabling Touch ID completely in 1Password and System Preferences, restarting the Mac (after applying any updates), and then setting it up again should do the trick. Let me know how it goes. :)

  • Hi again, bad luck... the problem has started again.

    It happened yesterday. I unlocked 1P with the password, then I locked it and restarted it: Again it requested password with no option for fingerprint. At this moment, it never offers the option to use my fingerprint, so it may be a good moment to track what is happening.

    Before this started happening, I had used the mac the day before and just closed the lid. 1password was not open.

    As discussed, see attached the screenshot of the login screen when I press cmd+shft+ç.

    I have sent the diagnostics report to the support email.

  • LarsLars Junior Member

    Team Member

    @anprieto - earlier in this thread, you said "I have updated." Can you tell us what version specifically of macOS and of 1Password for Mac you're currently running (as well as your browser(s), I suppose)? Thanks.

  • @Lars, see here:

    1Password 7 / Version 7.3 (70300020)
    Mac OS Sierra 10.12.6 (16G1918)
    Chrome Versión 74.0.3729.169 (Build oficial) (64 bits)

  • LarsLars Junior Member

    Team Member

    @anprieto - I'm going to be as straightforward as I can with you here, since you've stuck with us patiently in this thread for this long and provided some good, concrete feedback about what's happening. I think I may have misunderstood you earlier; I thought you might have upgraded your version of macOS, not just updated 1Password 7.

    I'm sorry this issue has continued to plague you intermittently, but from where we sit, here are the practical considerations, based on what you've told us so far:

    1. This issue is intermittent. By your account of it, sometimes it goes away for a significant time, then it returns.
    2. The affected component is Touch ID, not anything that is a data access or security-related issue.
    3. You are using the very oldest version of macOS which the current version of 1Password 7 for Mac will support.
    4. A low-and-declining number of Apple users continue to use Sierra today (under 12% and falling, as of May 2019)
    5. We don't have a lot of similar reports from other users of the 7.3/Sierra combination.
    6. Apple's implementation of Touch ID was notably less robust two years ago in Sierra than it is today.

    That's why our advice to someone experiencing such a problem (advice which we in fact did give you earlier) would be to upgrade to at least macOS 10.13 (“High Sierra”), and preferably all the way to macOS 10.14 (“Mojave”), because we've had no reports of similar issues with macOS 10.14 (“Mojave”). But you've told us that you aren't interested in upgrading to any newer version of macOS. That's your prerogative, but what that means is that this issue is among the most difficult-to-troubleshoot items of all (an intermittent one), which appears to affect only one user so far, and only on the oldest OS we support...and it may or may not turn out to be a bug within 1Password that we can do anything about. Even if it IS something that's "our fault" and we can do something about, it may wind up being an unsatisfactory (for you) length of time before anyone is able to devote the bandwidth/developer hours to it to fix it if it is a Sierra-specific 1Password bug.

    In other words, we support macOS 10.12 (“Sierra”) in 1Password 7 for Mac and thus, if you would like to send in a diagnostics report, we'd be willing to have a look to see whether anything specific jumps out at us that might explain the issue. Beyond that, however, while I'd like to tell you: sure, we'll quickly patch up any genuine bugs we find, the reality is that with a 45%-and-climbing share of the macOS market, ensuring compatibility with Mojave (and the upcoming Catalina) has to be our primary concern/objective, along with our own internal objectives for 1Password, refinements, new features, etc.

  • Thanks for such a long committed answer.
    Reason for not upgrading is that my previous experience with upgrading OS says that some things stop working correctly. In my previous Mac, Bluetooth has been started to mix with wifi and the latter became spotty. This was well reported by tons of users and Apple never solved it. I think that upgrading to the maximum level within Sierra makes sense, if you want to keep the Mac 2orking well and secure enough. Not beyond. I think that a 2 yr old mac should be well supported.

    I have sent in a diagnostic report earlier today.

    All things considered, I may think of upgrading but I would really appreciate if you could help me stay with the current os.

    Thanks in advance

  • LarsLars Junior Member

    Team Member

    @anprieto - Since you've already sent in a diagnostics report and you're being assisted by another colleague via email, and since this may very well involve details of your personal 1Password setup that should not be on this public forum, let's keep the conversation going via email instead of in multiple places at once. Thanks. :)

  • clarsenclarsen Junior Member
    edited June 27

    Touch ID has has gotten increasingly intermittent over the last couple of months and stopped working for me completely for the last couple of weeks.

    1Password 7
    Version 7.3 (70300020)
    1Password Store
    MacOS 10.14.5 (18F132)

    • Main 1Password window was not open.
    • Mac was locked before I started 1Password (using spotlight search). Unlocked automatically with apple watch.
    • No Touch ID option was shown. Had to enter master password to unlock 1password.

    For taking a screenshot, what would you like to see?

    The diagnostic utility https://support.1password.com/diagnostics/ is claimed to be "damaged" when I follow the instructions to open it - I guess SIP/Gatekeeper doesn't recognize the binary signature. I cleared it with 'xattr -c' in the meantime.

  • brentybrenty

    Team Member

    @clarsen: A screenshot would help because 1Password has different messages on the lock screen based on why Touch ID is not available (when the OS gives it enough information to determine that). Just to make sure we're on the same page, you will need to enter your Master Password sometimes no matter what. It's needed to decrypt the data. And no matter what, if we make a call to Touch ID and macOS rejects it, there isn't anything we can do.

    Diagnostics may help. I just downloaded the tool again here to double-check, and it runs fine. If your Mac is saying it's damaged, there's something wrong. It may legitimately have downloaded incompletely on your machine, or some other software may be modifying it. In either case, I'd try downloading again, and if the problem persists you should find out what's causing that to happen for you. Better safe than sorry.

  • clarsenclarsen Junior Member

    After rebooting the Mac, apparently 1password is able to use touchid again:
    1. On the first unlocking, the notice "master password must be entered to use touchid" shows which I haven't seen for the last couple of weeks.
    2. On locking and attempting to unlock 1password again, the fingerprint icon shows in the lock screen. Clicking on that shows the unlock dialog on the touchbar and I can use touchid to unlock.

  • brentybrenty

    Team Member

    Thanks for the update. That's what I'd expect to happen. If you run into another issue, please generate a diagnostics report immediately so we can take a look at the logs. Just keep in mind that even at the maximum setting, you will need to enter your Master Password at least once every two weeks, no matter what.

  • PTWithyPTWithy Junior Member

    I think this thread is relative to a problem I am seeing. I'm on Mojave 10.14.6 and 1Password 7.3.2. I enable TouchID, eventually 1Password expires that and requires my master password, which is all fine. But: after re-entering my master password, TouchID does not get re-enabled. The only way I can get TouchID to re-enable is to go to preferences, turn it off, and then turn it back on (so, enter my master password two more times). Surely this cannot be the intended way for it to operate?

  • brentybrenty

    Team Member

    @PTWithy: Where are you entering your Master Password exactly?

  • PTWithyPTWithy Junior Member

    Doesn’t matter whether I enter in the app or the browser extension. It seems that once it revokes TouchID, it won’t reenable unless I go into preferences and turn it off and back on.

  • ag_anaag_ana

    Team Member

    @PTWithy:

    Please generate a diagnostics report as soon as this happens again and send it to [email protected] so we can take a look.

    Thank you!

  • PTWithyPTWithy Junior Member

    I'll work on getting a diagnostics report. But also, another friend has the same problem and noticed that when they lose Touch ID, if they right-click on the menu bar shortcut and select "Quit 1Password Completely" and then re-launch, Touch ID works again. I have verified that I can repeat that myself.

  • brentybrenty

    Team Member

    @PTWithy: That's really interesting. Thanks for mentioning it! if you'd be able to reproduce the Touch ID failure, restart 1Password for Mac after quitting it completely, unlock using Touch ID, and then generate a diagnostics report, the logs may have a story to tell. :)

  • PTWithyPTWithy Junior Member

    @brenty
    I was able to reproduce this: Touch ID stopped working. Using "quit completety" and relaunching made it come back.
    I just emailed a diagnostic report to [email protected] with the subject "Touch ID stops working after a while". Hope it can shed some light on this.

  • LarsLars Junior Member

    Team Member

    @PTWithy - thanks! One of us will be with you shortly. You should've already received an automated response from our BitBit assistant which would contain a Support ID number -- can you post that here, to help us "connect the dots?" Thanks in advance!

  • PTWithyPTWithy Junior Member

    [#BYN-71394-154]

  • brentybrenty

    Team Member

    Thanks! We'll continue the conversation there.

    ref: BYN-71394-154

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file