Windows app not updating with latest passwords

ekkoekko
edited May 15 in Windows

I added a new login via the chrome 1pass addon, about 12 hours ago on computer X. Now on computer Y, running the 1pass windows app I find that login is not there, how do I get the windows app to check the 1pass server for new logins?


1Password Version: 7.3.684
Extension Version: Not Provided
OS Version: Win 10 x64 1809
Sync Type: nfi

Comments

  • brentybrenty

    Team Member

    @ekko: You listed the sync type as "nfi". I'm not sure what that is. Can you clarify? That will make all the difference as far as how you would troubleshoot this. And if you're using Chrome and a 1Password browser extension there, please let us know the exact browser and extension versions you have, as we'll as the versions you're using on your other devices. Thanks in advance!

  • ekkoekko

    It means I don't know. The exact browser is the latest version of both google chrome (normal channel) and the latest version of the 1pass extension for chrome

  • ekkoekko

    I don't think my original post made the following clear, the login was successfully saved to my vault by the extension 12 hours ago, my problem is purely that it is not appearing in the windows app on the second computer

  • ekkoekko

    I found the following in the log file for the windows app...
    "Network request #10 failed in 2ms, status KeepAliveFailure (The underlying connection was closed: A connection that was expected to be kept alive was closed by the server.)"

    and

    "batch push complete; updated: 0; failed: 0; new vault content version: 0; success: False
    time: 3,770ms
    "

  • GregGreg

    Team Member

    Hi @ekko,

    Do you see your updated Login item, when you sign in to your account on 1Password.com in the browser? If you do, it means that something is not right with 1Password 7 on your PC and we will need to investigate further. Please confirm. Thank you!

    ++
    Greg

  • ekkoekko

    Yes

  • ekkoekko

    I'm starting to suspect it is the network at the location of the second PC that is the problem. I cannot save anything new to the vault via the browser whilst logged into 1password.com. Strange that the website loads and I can peruse all of my vault...but just can't save changes to my vault, not sure how they blocked that on the network....

  • brentybrenty

    Team Member
    edited May 16

    @ekko: It could be any number of things, unfortunately, so it can be hard to pin down. Common causes:

    • Network filtering at the network level
    • Network filtering at the device level
    • Proxy
    • Firewall
    • "Security" software
    • Browser extensions

    We see this more often with the apps since many companies will only allow whitelisted apps to connect to the internet, or even be installed in the first place. But usually people can use their browser, as that's needed for many different things.

    I do agree though that it may be a good clue that everything else works, just not saving changes. So maybe it's more to do with some setting restricting certain browser features. Have you tried using a different browser on that computer?

  • ekkoekko

    yes, same issue across all browsers.

  • brentybrenty

    Team Member

    @ekko: Thanks for confirming. That kind of kills the browser-specific restriction theory. We'll probably need some logs, but I'm going to ask one of the web developers here what we should be looking for specifically. Hang tight. We'll get back to you. :)

  • ekkoekko

    Don't forget the windows 1password program is also not updating, that along with the other issue seems to point to a network restriction of some sort here.

  • GregGreg

    Team Member

    Hi @ekko,

    Could you please provide more information about your network setup? Is it your work computer? Thanks!

  • ekkoekko

    Yes, work computer and network.

  • GregGreg

    Team Member

    @ekko: Do you have any kind of VPN/proxy/firewall or other security software, where you can whitelist 1Password.com?

  • ekkoekko
    edited May 16

    There's security software and I have heard of a proxy / firewall but I don't have access to request any exceptions or rules for them.
    What does it mean that I can log in, browse all of my vault, reveal/conceal any masked field, load and browse all 1password.com webpages...but cannot save changes to my vault?

  • bundtkatebundtkate

    Team Member

    I had a chat with our development team about this, @ekko, and they'd like to take a look at some logs from your browser to see what happens when you try to save changes. You're right that what you're observing is odd to say the least, and we're hoping some logs from you might illuminate things. Here's what I'd like you to do:

    1. Recreate the issue and save a console logs as described here: https://support.1password.com/cs/browser-console/
    2. Attach these logs to an e-mail addressed to [email protected] and include a link to this discussion so everyone looking at your e-mail can take a peek at what we've discussed here
    3. For bonus points, grab the support ID from the autoreply you'll receive (it'll look like [#ABC-12345-678]) and post it here. The development team wanted me to get these logs to them, so this will help me ensure the right eyes get on your issue as quickly as possible.

    The team will take a look at those logs and see what we can find out. So you're aware, however, there's a good chance you're correct about your network environment being the trouble. If you aren't allowed to alter it yourself or request IT whitelist something for you, there may be nothing to be done here, at least not right away. This will absolutely help us figure out why this is happening and may allow us to make adjustments that will help 1Password work better in your environment, but there's a strong likelihood there's no immediate fix. I know this is frustrating and I'm sorry it's giving you such trouble, but I really appreciate the patience you've shown thus far and hope you understand why this could potentially take some time.

    Thanks again for all you've done so far and I'll keep an eye out for your e-mail. :chuffed:

  • ekkoekko

    Thank you for your help.

    I have emailed the log as requested, I'm all about bonus points too so the support ID is: #ZZS-33985-524

  • brentybrenty

    Team Member

    You rock! We'll take a look at those and get back to you via email. Thanks! :)

    ref: ZZS-33985-524

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file