Firefox 67.0 breaks 1PW extension 4.7.3.90.

Firefox updated to version 67.0 this morning and the 1PW extension immediately stopped working. Do you have a fix for this problem?


1Password Version: 7.3.684
Extension Version: 4.7.3.90
OS Version: Windows 7 SP1
Sync Type: Dropbox

Comments

  • bundtkatebundtkate

    Team Member

    I just updated Firefox to 67 now, @claywinkler, and I'm not having any trouble. Have you tried the turn it off and back on again drill? Close Firefox, wait a bit, open it again and see if you can fill. If not, close it again, then choose 1Password > Exit and open 1Password, then Firefox once more and see if that helps. If no luck (or you've already tried this), let me know. :+1:

  • Hi Kate.

    Thank you for the quick response. Much appreciated. I tried your steps, but the problem persists. The logs show the following line over and over:

      Refusing helper connection from "C:\Windows\explorer.exe", because of untrusted certificate.
    

    BTW, I grepped the logs folder and found that this message didn't start to appear until this morning when Firefox was updated.

    Please advise.

    Thanks.
    Clay

  • brentybrenty

    Team Member

    @claywinkler: Do you have "security" software that might be interfering? I'm not seeing that here either, but there's nothing on my PC that would prevent 1Password from verifying the browser's code signature. 1Password will refuse connections from anything with an unknown signature, or when it cannot even connect to try to check it. Have you tried restarting Windows? Let me know what you find.

  • Thank you for all the help. The problem went away with a re-install of FF.

  • brentybrenty

    Team Member

    Ah, excellent! Thanks for the update. It certainly makes sense that 1Password wouldn't be able to validate Firefox if it were damaged. I'm glad that reinstalling it helped. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file