1Password can't run in Samsung DeX. Try running in tablet mode

Hi all,

On a Samsung Tab S5E, in DeX mode, 1password won't start. I get this screen when launching 1password from a launcher or from a password prompt:

... which is a shame, since I find myself in DeX mode all the time as now you don't need an external monitor to use DeX. It's great for working and coding on the go.

I'm not sure what's the culprit here as DeX is able to open most non-optimized apps just fine, albeit in a small unresizable window.

This page could provide some hints: https://developer.samsung.com/samsung-dex/modify-optimizing


1Password Version: 7.1.4
Extension Version: Not Provided
OS Version: android 9
Sync Type: Not Provided

Comments

  • periperi

    Team Member

    Hi @mariusandra. Thanks for reaching out! It looks like there's something wrong here, as 1Password should be working on DeX. I'll pass this on to our development team so they can look into it. Thanks!

  • twstws Junior Member

    Hi @peri - has there been any progress on this?

  • periperi

    Team Member

    Hi @tws. We don't have anything to report here but I'll let you know when we do!

  • I'm on a Tab S4 in Dex mode and am getting the same notice.
    I've updated to Android 9 and One UI 1.1

  • periperi

    Team Member

    Thanks for reaching out, @JDubDev. Unfortunately there's an issue with using 1Password on DeX, and we have an open issue to investigate. I'll pass your feedback on to our team.

  • Thanks for the follow up @peri ! If there is anything I can test or check for you on my end let me know.

  • periperi

    Team Member

    Thanks for your offer to help! I'll keep this in mind if we do need help testing, @JDubDev. :)

  • I just started trying out DeX and was very disappointed to find out that 1Password didn't work. It's key to my access to almost everything. I'm happy to find out that it's supposed to work but there's some sort of issue. I'd rather that than be told that DeX isn't supported!

    Is there an update to this issue? I'm finding DeX more and more attractive, but it's a non-starter as long as I can't use my password manager.

  • saadsaad

    Team Member

    @zigguratt Thanks for sharing your feedback. I can understand your disappointment with being unable to use 1Password on the Samsung DeX platform. We don't intentionally restrict 1Password on Samsung DeX. There may be something specific (or lack thereof) with our app that is preventing it from running on the platform. While we don't have any updates to share yet, our development team have plans to review this feature request.

    We made several desktop optimizations as part of a 1Password update focused on the Chrome OS platform. The app is easier to use with a mouse and keyboard, and we'd love to see these features expanded to the DeX platform, so you can take advantage of these desktop-like capabilities too.

  • Thank you @saad. I realize from the preceding conversation that this is unintentional. I look forward to being able to use 1Password with DeX. I can see myself using DeX quite a bit, so it's essential that 1Password be available. Thanks again for the quick response!

  • I actually got it working, though 1Password still exhibits the same issue reported elsewhere: The screen isn't refreshed after password entry. It stays at "Unlocked" until you move or resize the window, or switch focus to another window to get it to change to your list of passwords. That's a very minor thing when compared to it not working at all! :)

    The way I got it working was to turn on DeX developer mode: Settings -> Samsung DeX -> About Samsung DeX. Then click on the Samsung DeX at the top five times. You'll be asked if you want to turn on developer mode. Obviously yes! Now go back to your phone settings and scroll to the bottom. You'll see Developer options. Click that and scroll to the bottom. Choose Force activities to be resizable.

    When you next start 1Password it works as expected.

  • periperi

    Team Member

    Thanks for the heads, up, @zigguratt!

    @mariusandra, @tws, and @JDubDev, does the workaround above work for any of you?

  • Hi all,
    I managed to enable developer mode, but couldn't find the "developer options" menu anywhere in the settings, even with the built in settings serach. However I did find the option in "Dex Labs", which I could search for in settings or could access by just clicking the "dex" logo on the bottom right of the screen.

    However, I had the option "force apps to resize" already on.

    Just in case I disabled it and enabled it again... and... somehow... 1password now opens in DeX mode! I don't know what did the trick in the end, but it works now! :smile:

    I have the same issue with moving/resizing the window after unlocking though. I can live with it...

  • periperi

    Team Member

    Thanks for the update! Glad that worked for you, and hopefully we can get this fixed soon!

  • twstws Junior Member

    @peri using @zigguratt's workaround did in fact work for me. Hopefully the real fix will be available sooner rather than later.

  • periperi

    Team Member

    Thanks for letting me know! :+1:

  • mverdemverde

    Team Member

    We've just published a beta update with some changes that may help resolve the issues experienced when trying to use 1Password with Samsung DeX. I would love to get your feedback on whether this improves things for you.

    If you're interested in helping us test the changes, you can opt in to the beta here. The usual cautions about beta software and bugs apply. On the plus side though, you'll get to be among the first to try out the latest features that we're building such as dark mode and managing trashed items!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file